Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkStationThinkStation Workstations
All Forum Topics
Options

93 Posts

04-16-2021

Netherlands

114 Signins

845 Page Views

  • Posts: 93
  • Registered: ‎04-16-2021
  • Location: Netherlands
  • Views: 845
  • Message 71 of 105

Re:P620 Bios Update Issue

2021-09-30, 14:54 PM

@arr9  

 

Did you set JP55 to 2-3 position before updating? 

Reply
Options

5258 Posts

02-22-2010

United States of America

3704 Signins

51750 Page Views

  • Posts: 5258
  • Registered: ‎02-22-2010
  • Location: United States of America
  • Views: 51750
  • Message 72 of 105

Re:P620 Bios Update Issue

2021-09-30, 15:09 PM

@Maria_vW - I think you might have a different issue going on.  Assuming you have your primary GPU installed in slot 3, and a display attached to that GPU, you should typically see video out during POST.  If you're not seeing graphics output until you get to the OS loading or OS log in screen, I think that's saying your graphics is not functional until a valid driver is being loaded by the OS.  Typically you see that sort of symptom when BIOS can't find a valid video OPROM for the mode it's in....for example your system is in full UEFI mode, but your GPU only contains a valid OPROM for legacy mode.

 

Can you describe what GPU you're using (along with your full system config just to be safe)?




If we've helped resolve your issue, please be sure to mark your topic as solved!
Reply
Options

93 Posts

04-16-2021

Netherlands

114 Signins

845 Page Views

  • Posts: 93
  • Registered: ‎04-16-2021
  • Location: Netherlands
  • Views: 845
  • Message 73 of 105

Re:P620 Bios Update Issue

2021-09-30, 15:25 PM

@Maria_vW  

 

I see you made a thread of your own to address your issue.

I am not going to jump into that thread as I do not have the full inside in the systems boot process to be of indept help.

But you are not the only one reporting the loss of the Logo and F-keys

 

Are you also familiar with this thread?

P620 BIOS update fail (S07KT21A)-English Community (lenovo.com)

 

antan reports that after an update he got beep codes that specificly indicated a GPU problem.

When he rebooted he reports the same boot phenomena as you.

The loss of the Lenovo logo and F-keys at boot. and the system booted strait into Windows.

 

In his case he found a solution by reseating the GPU card.

I am not saying that is precisely your situation, but apparently problems with the GPU can be the cause of this.

Reply
Options

45 Posts

12-15-2020

Germany

25 Signins

190 Page Views

  • Posts: 45
  • Registered: ‎12-15-2020
  • Location: Germany
  • Views: 190
  • Message 74 of 105

Re:P620 Bios Update Issue

2021-09-30, 15:41 PM

I don't get any beep codes at boot and reseating the card didn't help.

 

 

Reply
Options

45 Posts

12-15-2020

Germany

25 Signins

190 Page Views

  • Posts: 45
  • Registered: ‎12-15-2020
  • Location: Germany
  • Views: 190
  • Message 75 of 105

Re:P620 Bios Update Issue

2021-09-30, 15:43 PM

@psuturtle   see P620 - problems after installing BIOS S07KT22A-English Community (lenovo.com)

Reply
Options

5258 Posts

02-22-2010

United States of America

3704 Signins

51750 Page Views

  • Posts: 5258
  • Registered: ‎02-22-2010
  • Location: United States of America
  • Views: 51750
  • Message 76 of 105

Re:P620 Bios Update Issue

2021-09-30, 15:53 PM

@Maria_vW - Thanks for splitting that out into a separate thread.  Please edit that new post to remove your system SN.  It's against forum rules to post that info (and also for your own protection).

 

 

For this thread, I'm following up with our BIOS team now to try to get some additional feedback on 23A and some of the issues being reported here with this most recent update.  




If we've helped resolve your issue, please be sure to mark your topic as solved!
Reply
Options

93 Posts

04-16-2021

Netherlands

114 Signins

845 Page Views

  • Posts: 93
  • Registered: ‎04-16-2021
  • Location: Netherlands
  • Views: 845
  • Message 77 of 105

Re:P620 Bios Update Issue

2021-10-01, 0:03 AM

@Maria_vW  

 

I know your card used to work, but maybe this could show a discrepancy.

Reply
Options

45 Posts

12-15-2020

Germany

25 Signins

190 Page Views

  • Posts: 45
  • Registered: ‎12-15-2020
  • Location: Germany
  • Views: 190
  • Message 78 of 105

Re:P620 Bios Update Issue

2021-10-01, 5:24 AM

@GMP620   the card has UEFI support.  It was working fine before the S07KT22A BIOS update.

 

If the card was lacking UEFI support I would still get an image with HDMI out - but I get a black screen at boot with HDMI as well.

 

Re-seating the card does not help. (installed in slot-3)

 

Reply
Options

93 Posts

04-16-2021

Netherlands

114 Signins

845 Page Views

  • Posts: 93
  • Registered: ‎04-16-2021
  • Location: Netherlands
  • Views: 845
  • Message 79 of 105

Re:P620 Bios Update Issue

2021-10-01, 11:10 AM

@Maria_vW  

 

Just a thought.

Have you already tried setting PCIe slot 3, that holds your GPU card, temporary manual to gen3, using a settings tool, to see if there is a difference introduced in that area?

PCIe slot 3

PCIe x16

Link speed 8GT/s

 

 

 

Reply
Options

45 Posts

12-15-2020

Germany

25 Signins

190 Page Views

  • Posts: 45
  • Registered: ‎12-15-2020
  • Location: Germany
  • Views: 190
  • Message 80 of 105

Re:P620 Bios Update Issue

2021-10-01, 11:49 AM

@GMP620 Setting it to Gen3 does not change anything. :(

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms