Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Token Ring
Posts: 103
Registered: ‎05-13-2008
Location: Columbia, Mo.
0 Kudos
Accepted Solution

Can't get R&R or Power Manager to work under upgraded Win7 on X61

I recently upgraded my X61 from Win Vista Business to Win7 Pro. While doing so I installed the new and supposedly Windows 7 compatible versions of R&R and Power Manager. However, I can't seem to get either to work - I can't even start the applications. Both immediately crash and tell me that "Lenovo Application has stopped working" (R&R) and "Power Manager has stopped working." I do get the power gauge in the task bar, but I cannot click it (same error/crash). 


I followed the instructions and have therefore updated all the applicable drivers etc, e.g. the new version of CSS for R&R and the Power Management Driver for Power Manager, but it still doesn't work. I've also tried reinstalling (both uninstall followed by install and repair/reinstall). Does anybody know what's going on? What could be wrong?


Is anybody else experiencing the same [kind of] problem? Are there any solutions?





Per Bylund

Token Ring
Posts: 103
Registered: ‎05-13-2008
Location: Columbia, Mo.

Re: Can't get R&R or Power Manager to work under upgraded Win7 on X61


I believe I've found the reason for the problem I had with both R&R and the Power Manager (also discussed here): I did not have .NET framework 3.5.1 SP 1 installed. It is obviously disabled by default on Win7, so one will have to enable it through Control Panel -> Uninstall a program -> Turn Windows features on or off (and then make sure to check the Microsoft .NET Framework 3.5.1 check box).


The strange thing is that I have not found the information that .NET framework is required anywhere - Lenovo obviously didn't think of supplying it. I just happened to find the solution when installing the upgrade for the Lenovo Toolbox, which could not be finished without first installing the framework (and the Toolbox installation program told me this was required). 


So make sure you have the .NET framework enabled if you want to run a bunch of the ThinkVantage applications!



Per Bylund