Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Posts: 42
Registered: ‎10-18-2008
Location: Dubai, UAE
0 Kudos

Lenovo Fingerprint Software Error and new update corrupt?

[ Edited ]

I just ran TSVU and had 18 updates to download and install (including a bios update, fingerprint software update, loads of vista updates).


Ran through everything but now my fingerprint sensor doesn't work. The fingerprint software update is


When I open password manager, it says "The requested operation required fingerprint authentication, but the device is not installed. Please make sure the device is connected and retry the operation."


When I open the fingerprint software it asks for my windows password, and when I click on a finger to enroll it pops up an error, "Cannot communicate with sensor. Please confirm the sensor is ready."


In device manager, "Personal Identification Devices --> AuthenTec Inc. AES2810", has a warning symbol, and the status is "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)".


I tried uninstalling fingerprint software through control panel, restarting, reinstalling the software for the new version, and restarting, and it still doesn't work. I also tried updating the driver through device manager, and it said the latest is installed, and no option for rollback.


I eventually managed to find the older fingerprint software by googling it, and uninstalled fingerprint software from programs and features, restarted, installed the older version, restarted. Still didn't work, until in device manager I updated the firmware. After restarting fingerprint reader and software was working with all my saved data still there.  


I think the new fingerprint update is corrupt, or something weird went wrong on my machine.


I'm now running the older software version


Message Edited by nmabakhsh on 06-08-2009 06:34 AM
Posts: 42
Registered: ‎10-18-2008
Location: Dubai, UAE
0 Kudos

Re: Lenovo Fingerprint Software Error and new update corrupt?

nobody else had this problem? On a W500 32 Bit vista business... ?
Paper Tape
Posts: 2
Registered: ‎06-25-2009
Location: Malaysia
0 Kudos

Re: Lenovo Fingerprint Software Error and new update corrupt?

Hi, I had the same problem on W500 running Vista x64. Since, I cannot find any solution to this problem, have to uninstall the latest version and now running fine with old version.


Can anyone post the right fix to latest software problem of version