Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Paper Tape
Posts: 1
Registered: ‎10-23-2011
Location: United Kingdom
Message 301 of 327 (10,533 Views)

Re: System Update - An error occurred while gathering user information

Hello all,

 

I've been having no-end of problems with this issue and I've found a solution that works for me.

I've done the XML patch, which didn't help. 

 

What sorted it for me was to alter my regional settings to US English (I'm from the UK).

 

May or may not work for others, but it's fixed mine.

 

 

What's DOS?
Posts: 1
Registered: ‎11-01-2011
Location: Australia
Message 302 of 327 (10,421 Views)

Re: System Update - An error occurred while gathering user information

Please refer to http://bowlova.blogspot.com/ for solution.

Paper Tape
Posts: 3
Registered: ‎10-10-2008
Location: usa
Message 303 of 327 (9,441 Views)

Re: System Update - An error occurred while gathering user information

Well this worked for windows 7, after 29 pages you had the solution, much appreciated. Others should try this if running win7.
Paper Tape
Posts: 3
Registered: ‎10-10-2008
Location: usa
Message 304 of 327 (9,437 Views)

Re: System Update - An error occurred while gathering user information

Koteeks editing of xml file works, this user has figured out a solution that lenovo couldnt. Iam reposting as my orignal post didnt have what I was referring to. If you have win7edit this file in notepad and add the strings in step 3  as after the strings in step two. Thanks to Koteek from Russia. I made an account specifically to thank this member.

 

2. Find following strings in MappingInterf ace.xml:

        <OS>
            <OSTVIA>WIN7-PRO</OSTVIA>
            <OSeGatherer>
                <Name>WINDOWS 7 Professional</Name>
                <ServiceRelease>default</ServiceRelease>
            </OSeGatherer>
            <OSQuest>Windows 7</OSQuest>
        </OS>

 

3. Add after:

        <OS>
            <OSTVIA>WIN7-STARTER.SP1</OSTVIA>
            <OSeGatherer>
                <Name>WINDOWS 7 Starter</Name>
                <ServiceRelease>Service Pack 1</ServiceRelease>
            </OSeGatherer>
            <OSQuest>Windows 7</OSQuest>
        </OS>    
        <OS>
            <OSTVIA>WIN7-BUS.SP1</OSTVIA>
            <OSeGatherer>
                <Name>WINDOWS 7 Business</Name>
                <ServiceRelease>Service Pack 1</ServiceRelease>
            </OSeGatherer>
            <OSQuest>Windows 7</OSQuest>
        </OS>
        <OS>
            <OSTVIA>WIN7-HOMEBASIC.SP1</OSTVIA>
            <OSeGatherer>
                <Name>WINDOWS 7 Home Basic</Name>
                <ServiceRelease>Service Pack 1</ServiceRelease>
            </OSeGatherer>
            <OSQuest>Windows 7</OSQuest>
        </OS>
        <OS>
            <OSTVIA>WIN7-HOMEPREM.SP1</OSTVIA>
            <OSeGatherer>
                <Name>WINDOWS 7 Home Premium</Name>
                <ServiceRelease>Service Pack 1</ServiceRelease>
            </OSeGatherer>
            <OSQuest>Windows 7</OSQuest>
        </OS>
        <OS>
            <OSTVIA>WIN7-ULT.SP1</OSTVIA>
            <OSeGatherer>
                <Name>WINDOWS 7 Ultimate</Name>
                <ServiceRelease>Service Pack 1</ServiceRelease>
            </OSeGatherer>
            <OSQuest>Windows 7</OSQuest>
        </OS>
        <OS>
            <OSTVIA>WIN7-ENT.SP1</OSTVIA>
            <OSeGatherer>
                <Name>WINDOWS 7 Enterprise</Name>
                <ServiceRelease>Service Pack 1</ServiceRelease>
            </OSeGatherer>
            <OSQuest>Windows 7</OSQuest>
        </OS>
        <OS>
            <OSTVIA>WIN7-PRO.SP1</OSTVIA>
            <OSeGatherer>
                <Name>WINDOWS 7 Professional</Name>
                <ServiceRelease>Service Pack 1</ServiceRelease>
            </OSeGatherer>
            <OSQuest>Windows 7</OSQuest>
        </OS>

Token Ring
Posts: 89
Registered: ‎02-13-2012
Location: US
Message 305 of 327 (9,337 Views)

Re: System Update - An error occurred while gathering user information

Good find. Worked for me as well.

Token Ring
Posts: 89
Registered: ‎02-13-2012
Location: US
Message 306 of 327 (9,317 Views)

Re: System Update - An error occurred while gathering user information

Anyone happen to know a way to tweak the hack above into making it work in Windows 8?

Posts: 9,293
Topics: 25
Kudos: 713
Solutions: 643
Registered: ‎11-27-2007
Location: Bonnie Scotland
Message 307 of 327 (9,314 Views)

Re: System Update - An error occurred while gathering user information

You'll need to wait for Lenovo to release drivers for Windows 8 and add them to the database which SU pulls it's drivers from, and for Lenovo to release a version of SU for W8 which will probably happen when the drivers are released.

Andy  

______________________________________


Please remember to come back and mark the post that you feel solved your question as the solution, it earns the member + points

Did you find a post helpfull? You can thank the member by clicking on the star to the left awarding them Kudos

Please add your type, model number and OS to your signature, it helps to help you.

Forum Search Option

T430 2347-G7U W8 x64, Yoga 10 HD+, Tablet 1838-2BG, T61p 6460-67G W7 x64, T43p 2668-G2G XP, T23 2647-9LG XP, plus a few more.

FYI Unsolicited Personal Messages will be ignored.

  Deutsche Community     Comunidad en Español    English Community Русскоязычное Сообщество

PepperonI blog 

Token Ring
Posts: 89
Registered: ‎02-13-2012
Location: US
Message 308 of 327 (9,311 Views)

Re: System Update - An error occurred while gathering user information

@andyP

Gotcha.

Yeah, I was more looking for a hack to save time, rather than downloading the Win7 things manually, and installing them that way. The X220T is pretty much 100% operational upon installing Win8 anyways, but it would be nice to have TVSU for grabbing the bits and pieces that are missing.
What's DOS?
Posts: 1
Registered: ‎05-11-2012
Location: US
Message 309 of 327 (8,899 Views)

Re: System Update - An error occurred while gathering user information

Any idea how to get  ThinkVantage System Update to work on my W510 Windows Server 2008 R2 partition? I have it working fine on Windows 7...but I need to run Windows Server 2008 R2 and want all the drivers updated correctly.

 

Thoughts?

Posts: 9,293
Topics: 25
Kudos: 713
Solutions: 643
Registered: ‎11-27-2007
Location: Bonnie Scotland
Message 310 of 327 (8,897 Views)

Re: System Update - An error occurred while gathering user information

Hi lanceicys, welcome to the forum,

 

Server operating systems have never been, nor were they intended to be, supported by TVSU. You will need to manually obtain and install the drivers. 

 

Sorry for bearing the news you didn't want to hear Smiley Sad

Andy  

______________________________________


Please remember to come back and mark the post that you feel solved your question as the solution, it earns the member + points

Did you find a post helpfull? You can thank the member by clicking on the star to the left awarding them Kudos

Please add your type, model number and OS to your signature, it helps to help you.

Forum Search Option

T430 2347-G7U W8 x64, Yoga 10 HD+, Tablet 1838-2BG, T61p 6460-67G W7 x64, T43p 2668-G2G XP, T23 2647-9LG XP, plus a few more.

FYI Unsolicited Personal Messages will be ignored.

  Deutsche Community     Comunidad en Español    English Community Русскоязычное Сообщество

PepperonI blog 

top kudoed authors
User Kudos Count
3
1
1