Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Blue Screen Again
Posts: 10
Registered: ‎02-20-2011
Location: Montreal
0 Kudos

ThinkVantage System Update - wrong language

[ Edited ]

I'm currently running ThinkVantage System Update 4 (4.00.0030) on Windows 7 Pro x64 and I have the same problem. The program uses your Regional Setting FORMAT  to get the updates. This is the first tab option in Regional Settings (not your Regional Setting Input Language nor your Regional Setting System Locale). Why, I didn't find a good answer to that? The problem seems to persist from the early versions of System Update ; we are at version 4... common!!?


You can actually override the GUI language of System Update by changing the value of this registry key :

For Win 7 x64 :

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Lenovo\System Update\LanguageOverride


For x86 (32 bits) version, I think this is the key :

HKEY_LOCAL_MACHINE\SOFTWARE\Lenovo\System Update\LanguageOverride


 ... to the language of your choice (EN, FR, DE, IT, ES...).


Robot Mad Unfortunately, this is just the GUI language, not the language for which System Update will retrieve update from the server. The program will still use your Regional Setting FORMAT for this.


I've read many post on the topic but didn't find a right solution. The dowloaded software and drivers language should be retrieved as per language setting of the OS not on date, time and number formats. If it's too hard to get the right setting from a multilanguage system, why not simply put a configurable language option? Robot surprised Is Lenovo going to fix the problem?


For now, the workaround is to dumbly set the Regional Setting Format to the "language" you wish before starting System Update and set it back to your preferred format when all update are installed. Any better idea?



 P.S. Could a mod rename and move this topic in ThinkPad Forum please, because I think this is more related to System Update software than X Series Laptops Smiley Wink

X201 tablet w/ Multitouch, 8-Cell Battery
Core i7 620LM (2.00 GHz) w/ 4 GB DDR3 Memory
Windows 7 Pro 64 bits, HDD 320GB 7200RPM
Paper Tape
Posts: 6
Registered: ‎01-04-2009
Location: Belgium

X200T ThinkVantage System Update: wrong language

I bought an X200T in Belgium, chose the English version of Windows Vista Business upon first boot.

Yet some Lenovo  software is still in Dutch.

The ThinkVantage System Update wants to download updates for Windows Vista NL instead of ENG.  I have already downloaded the latest English version of ThinkVantage System Update but it insists speaking Dutch to me and does not recognize my system as being English.

Installing NL updates for an English OS is a recipe for disaster, I presume, so I cannot use that tool.




Paper Tape
Posts: 6
Registered: ‎01-04-2009
Location: Belgium

Re: X200T ThinkVantage System Update: wrong language

Sorry to reply to my own message, but I got it solved.


The System Updater apparently uses the "Current format" setting from the Regional and Language Options control panel.  This is wrong IMHO.

It should better check the version of the OS, the input language or the system locale.  All English in my case. 

Lenovo Staff
Posts: 3,570
Registered: ‎07-11-2010
Location: Malaysia
0 Kudos

Re: ThinkVantage System Update: wrong language

Posts: 13
Registered: ‎01-15-2013
Location: Japan
0 Kudos

Re: ThinkVantage System Update: wrong language

SU kept displaying in Japanese even after uninstalling, setting even language/region setting to US-English, redownloading and reinstalling it.  The above registry edit was the only thing that fixed it for me.  It had correctly set the default language to EN, but for some reason only SU wouldn't display in English.  This is on a fresh install of Windows 8.1 Pro Pack with Media Center English version with the Japanese IME installed.  SU version 5.06.0007.  There really needs to be a language setting in the preferences for the program.

 PS: This thread is the first entry if you Google a solution to this problem.