cancel
Showing results for 
Search instead for 
Did you mean: 
Views: 2,851

Question

I took the ThinkVantage Toolbox update per the recommendation -- now, the Toolbox icon shows up in my toolbar -- but when I try to actually run the toolbox program, I get  the system error message: Lenovo ThinkVantage Toolbox has stopped working. 

The toolbox program continues to operate behind the error dialog box until I click on the "close program" button.

I can't fathom what is making it report that it has stopped working -- any ideas?

The application log in event viewer has this entry:

 

Log Name:      Application
Source:        SideBySide
Date:          11/24/2009 11:12:29 PM
Event ID:      72
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      XXXXXXXXXX

Description:
Activation context generation failed for "C:\Program Files\Lenovo\Mobile Broadband Connect\DetwanHw.exe".Error in manifest or policy file "C:\Program Files\Lenovo\Mobile Broadband Connect\DetwanHw.exe" on line 9. The element trustinfo appears as a child of element urn:schemas-microsoft-com:asm.v1^assembly which is not supported by this version of Windows.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider />
    <EventID Qualifiers="49409">72</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2009-11-25T07:12:29.000Z" />
    <EventRecordID>11463</EventRecordID>
    <Channel>Application</Channel>
    <Computer>XXXXXXXXXXX</Computer>
    <Security />
  </System>
  <EventData>
    <Data>trustinfo</Data>
    <Data>urn:schemas-microsoft-com:asm.v1^assembly</Data>
    <Data>
        <Data>
    </Data>
    <Data>C:\Program Files\Lenovo\Mobile Broadband Connect\DetwanHw.exe</Data>
    <Data>C:\Program Files\Lenovo\Mobile Broadband Connect\DetwanHw.exe</Data>
    <Data>9</Data>
    <Data>
        </Data>
  </EventData>
</Event>

 

Answer

 

If you have an Event Log entry for Lenovo Broadband Connect (DetwanHw.exe) as described above, try the following workaround.

 

Workaround: Remove our Wireless WAN scriptlet

1. Navigate to this folder:

 

     <LTT Install Dir>\scriptlets\security_action_items\

     (typical installation is in C:\Program Files\PC-Doctor\scriptlets\security_action_items\)

 

2. Delete "MobileBroadband.xml"

 

If that does not address your situation, please post back and  be sure to include the following:

 

a. OS (and 32- or 64-bit)

b. Whether you are using the Lenovo preload, MSDN, or a custom corporate image

c. Lenovo PC Model number

d. Whether you are in a managed or an unmanaged environment

 

 

Was this information helpful?

Comments
pbrown12303

The startup error seems to be back. With version 6.0.5514.61 and a fresh install of the toolbox I get:

 

The description for Event ID 1 from source PC-Doctor cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

(7220) Asapi: (11:37:16:5530)(7220) DEFECT.LOCALIZATION - Error -- Missing String: scriptlets : button1 locale: PCDLocale: language = en, customer = lenovo, variant = ltt

ambrose33

My Thinkvantage Toolbox doesn't working. I just installed but it doesn't response every time I tried to run it.

The icon system tray say "Critical problem discovered!" I click the icon but crashed.

I deleted "MobileBroadband.xml", but nothing changed. 

It is very annoying. 

 

 

Error signature
szAppName : pcdrcui.exe     szAppVer : 6.0.5692.7     szModName : hungapp     
szModVer : 0.0.0.0     offset : 00000000  

Error signatureszAppName : pcdrcui.exe     szAppVer : 6.0.5692.7     szModName : hungapp     szModVer : 0.0.0.0     offset : 00000000  

 

 

a. OS: XP

b. Whether you are using the Lenovo preload, MSDN, or a custom corporate image: don't know

c. Lenovo PC Model number: X200

d. Whether you are in a managed or an unmanaged environment: managed

erack32

Same here. My newly updated Lenovo Thinkadvantage Toolbox (LTT) isn't working properly either.  Everytime I open LTT, it wants to close and send the following data to Microsoft:

EventType : clr20r3     P1 : pcdrcui.exe     P2 : 6.0.5849.23    
P3 : 4e08a551 P4 : mscorlib     P5 : 2.0.0.0     P6 : 4d8c190a
P7 : f4f  P8 : 7    
P9 : n3ctrye2kn3c34sgl4zqyrbfte4m13nb

This is for newly updated LTT version 6.05849.23. Please note that my previous version of LTT worked just fine.

A. OS: XP pro 32bit

B. preload MSDN

C. R400

D. unmanaged environment (home user)

 

Ironically, this new updated LTT works fine on my older R50e laptop.