English Community

Linux Operating SystemsUbuntu
All Forum Topics

2 Posts


Waco, Texas, USA

2 Signins

113 Page Views

  • Posts: 2
  • Registered: ‎05-16-2014
  • Location: Waco, Texas, USA
  • Views: 113
  • Message 1 of 2

K410 - Error 1962 - Ubuntu 12.04 Installation

2014-05-16, 4:29 AM

I am getting the message "Error 1962: No Operating System found", before any boot selection menu, when I try to boot the system.  What ROM Bios tests could be failing to cause that message?


My system is a Lenovo IdeaCentre K410.  The Bios Revision level is ECKT16A, BIOS Date is 04/06/2012, Boot Block Rev. Level is EC16A.   The tower has two identical 500GB disk drives.  I had been running a Linux, Mandriva, with multiple partitions (file systems) as RAID1 partitions.  The Linux boot used the MBR with a Linux boot loader, LILO.  Now Mandriva as an organization is out of business.  I chose to install Ubuntu 12.04 with a similiar configuration.

However the disks were totally zeroed, and a new partition label format, GPT, was used.  Both disks have an unraided 1MB partition with the bios-grub flag set.  Both disks have raided partitions; /boot,/, /usr, /tmp, /var, and /home.  I installed Grub on the first disk drive during the standard Ubuntu installation (which is supposed to write grub's own initial loader into the MBR, and populate the bios-grub partition.  I also installed Grub again on both disk drives using a boot rescue utility from Mandriva.  But I still get the error message.  Thank you for your assistance.


8 Posts



6 Signins

72 Page Views

  • Posts: 8
  • Registered: ‎02-06-2017
  • Location: US
  • Views: 72
  • Message 2 of 2

Re: K410 - Error 1962 - Ubuntu 12.04 Installation

2017-02-06, 4:44 AM

I know this is an old question, but it came up on the first page of search results so I wanted to help someone else.


Lenovo has configured their UEFI boot manager to only boot Windows on some IdeaCenters and probably other machines as well.


Here is another thread for this same problem.


The only way around this is to "trick" the UEFI into booting Windows.


I got most of this information from this Ubuntu thread.


These instructions worked for me for Debian.


First, install your Linux distro.


When it finishes, reboot, then re-run the installer in "rescue" mode (under "Advanced" or "Expert").


Set your root to the normal root environment (usually /dev/sda2) and execute a shell in /dev/sda2.  If you run the shell in the installer environment, you won't have access to the efibootmgr program.

Allow the installer to auto-mount the EFI partition; it will mount it in /boot/efi


Follow these instructions:


### in case you're a n00b, don't type stuff after the # sign; these are my comments

### make a Microsoft/Boot folder in the EFI partition and copy Grub's file there
cd /boot/efi/EFI mkdir Microsoft mkdir Microsoft/Boot cp /boot/efi/EFI/debian/grubx64.efi /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi ### add boot entry to EFI efibootmgr -c -L "Windows Boot Manager" -l "\EFI\Microsoft\Boot\bootmgfw.efi"
### it is ESSENTIAL that you type it in *quotation marks*, or the backslashes will not work.

This creates the \EFI\Microsoft\Boot\bootmgfw.efi file that Lenovo's EFI is looking for and adds it to the EFI boot list.  What we are actually doing is copying the grubx64.efi file to the Windows folder, which is the only place Lenovo looks for it.


Best of luck,



Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop





No, I don’t want to share ideas Yes, I agree to these terms