cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
chamibuddhika
Paper Tape
Posts: 3
Registered: ‎12-20-2018
Location: US
Views: 2,752
Message 1 of 8

Pop OS Clean Install Failed on X1 Extreme

Any one having trouble installing Pop! OS on X1 Extreme? I saw people had gotten it to work so gave it a try. When I tried to do a clean install of it (no Windows dual boot) from a bootable USB I couldn't complete the installation and I am stuck with a Boot menu which looks like in the picture. I retried couple of times and apparently it just added more entries to the boot menu. Boot is not going forward from this point onwards. Any ideas?

IMG_20181220_214244090.jpg

bert8
Fanfold Paper
Posts: 11
Registered: ‎12-10-2018
Location: US
Views: 2,687
Message 2 of 8

Re: Pop OS Clean Install Failed on X1 Extreme

Not sure if you've seen this thread, be warned that changing BIOS settings could brick your laptop:

https://forums.lenovo.com/t5/ThinkPad-X-Series-Laptops/Thinkpad-X1-Extreme-Black-Screen-Help/td-p/42...

 

That said, Lenovo just pulled down BIOS 1.15 and 1.13 from their download site. They currently have 1.10 published. I'm curious if 1.10 suffers the same problem as the later versions did. If you haven't touched your BIOS then you're probably running 1.13. If you're willing to risk it you can try to downgrade to 1.10 and switch to discrete graphics, which is reportedly what it takes to get most Linux distros running on the X1E. Just make sure you understand that this could brick your laptop, you'll have to send it back to Lenovo for warranty repair if that happens.

 

https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-...

bert8
Fanfold Paper
Posts: 11
Registered: ‎12-10-2018
Location: US
Views: 2,683
Message 3 of 8

Re: Pop OS Clean Install Failed on X1 Extreme

Disregard my last post, Lenovo will publish 1.17 on Monday which should resolve the issue:

 

https://forums.lenovo.com/t5/ThinkPad-X-Series-Laptops/Thinkpad-X1-Extreme-Black-Screen-Help/m-p/430...

dandv
Serial Port
Posts: 26
Registered: ‎02-24-2011
Location: US
Views: 2,605
Message 4 of 8

Can't even burn a Pop!_OS image

How did you manage to get a bootable Pop!_OS USB stick? Startup Disc Creator couldn't flash their ISO, and Etcher created one that can't boot.

chamibuddhika
Paper Tape
Posts: 3
Registered: ‎12-20-2018
Location: US
Views: 2,594
Message 5 of 8

Re: Can't even burn a Pop!_OS image

I think my error was a manifestation of the issue that you have linked. I didn't come across that github issue earlier when I was Googling around. Anyways I ditched Pop! OS and retried with Elementary OS and the installation worked out of the box. It's been running reasonably fine so far.

dandv
Serial Port
Posts: 26
Registered: ‎02-24-2011
Location: US
Views: 2,569
Message 6 of 8

Re: Can't even burn a Pop!_OS image

Does the window manager in Elementary OS support switching among windows with Super+0..9 number keys?

chamibuddhika
Paper Tape
Posts: 3
Registered: ‎12-20-2018
Location: US
Views: 2,540
Message 7 of 8

Re: Can't even burn a Pop!_OS image

Tried. It works for me.
didierw
Blue Screen Again
Posts: 21
Registered: ‎09-13-2018
Location: LU
Views: 2,276
Message 8 of 8

Re: Pop OS Clean Install Failed on X1 Extreme

Hello,

I'm running pop!os on the x1 extreme without problems on my second nvme disk.

Which version of pop!os are you using, the nvidia or intel version?

Is "secure boot" on?

If you are using the nvidia driver, you have to disable "secure boot"!

Hope this helps!

Didier

 

Check out current deals!


Shop current deals

Top Kudoed Authors