cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
hatchoo
Paper Tape
Posts: 2
Registered: ‎03-07-2019
Location: US
Views: 872
Message 1 of 3

T430 linux installation

Hello all. Recently bought a T430 (ebay) with ssd win10 installed. When I updated win10, it started to crash. It would get stuck on the windows logo. So I reformatted the ssd and tried to install linux mint 19. The linux live usb would boot, but it would not recognize the ssd when I try to install. Thinking it was a faulty drive, I changed it to the extra ssd that I have, but it still won’t get recognized. I also tried booting using a linux usb flash drive that I created, but it won’t boot. I would get to the Grub menu, but after selecting Linux Mint it would just get stuck on a blank screen. Weirdly enough, I was able to install windows 7 so at least I can use the laptop. So I’m not sure why LM19 won’t work on this machine. 

 

Secure boot is Disabled. 

UEFI/Legacy Boot is set to Both

Boot priority is UEFI First

CSM Support is set to Yes

flacks
Paper Tape
Posts: 3
Registered: ‎03-08-2019
Location: US
Views: 833
Message 2 of 3

Re: T430 linux installation

Hi hatchoo, have you checked `lsblk`, `dmesg`, etc, to confirm that the drive is not detected and attached by the kernel? You can also use the "Disks" utility (comes with LM and should be in the bootable ISO) to check for the existence of the drive. You may need to run `wipefs -a /dev/sdX` against the drive if the kernel indeed detects and attaches it, before the Linux Mint installer will prompt to install LM19 to it. HTH

Kindly,
Jean
hatchoo
Paper Tape
Posts: 2
Registered: ‎03-07-2019
Location: US
Views: 797
Message 3 of 3

Re: T430 linux installation

lsblk
NAME   MAJ:MIN    RM    SIZE   RO   TYPE    MOUNTPOINT
loop0          7:0          0      1.8G     1       loop   /rofs
sdb              8:16        1     29.1G    0      disk 
└─sdb1      8:17         1     29.1G    0      part    /cdrom
sr0             11:0          1     1024M   0      rom  

dmesg gave me long list.  Let me know if you want me to list the results here as well.

 

 

I ran Disks and it was able to see the ssd.  At first is shows me the win7 parition under the Volumes.  However, as soon as I try to install LM19, the Volumes changed to "No Media".  I also ran GParted and it was not able to detect the ssd.

Check out current deals!


Shop current deals

Top Kudoed Authors