English Community

Linux Operating SystemsUbuntu
All Forum Topics
Options

4 Posts

05-19-2018

US

8 Signins

84 Page Views

  • Posts: 4
  • Registered: ‎05-19-2018
  • Location: US
  • Views: 84
  • Message 1 of 6

Thinkpad X1 Carbon Yoga 3rd eratic Mouse and Keyboard Ubuntu 18.04 on Sleep

2018-05-19, 13:06 PM

In installed Ubuntu 18.04 and when I put the computer to sleep by closing the lid or suspend button, the touchpad is eratic and the keyboard LEDs flicker.  Any suggestions?  I've updated to the latest kernel 4.16.10 and no difference.

Solved! See the solution
Reply
Options

27 Posts

04-14-2018

US

55 Signins

319 Page Views

  • Posts: 27
  • Registered: ‎04-14-2018
  • Location: US
  • Views: 319
  • Message 2 of 6

Re: Thinkpad X1 Carbon Yoga 3rd eratic Mouse and Keyboard Ubuntu 18.04 on Sleep

2018-05-20, 8:33 AM

Check out this thread: https://forums.lenovo.com/t5/Linux-Discussion/Troubles-with-X1-Carbon-2018-X1C6-TouchPad-and-TrackPoint-under/td-p/4004815

 

Essentially you want to add "psmouse.synaptics_intertouch=1" to your Grub config so your kernel boots with that parameter. But you also have to comment out a line in the modules blacklist file to actually let the driver load. I believe details are on the last page of that thread.

Reply
Options

4 Posts

05-19-2018

US

8 Signins

84 Page Views

  • Posts: 4
  • Registered: ‎05-19-2018
  • Location: US
  • Views: 84
  • Message 3 of 6

Re: Thinkpad X1 Carbon Yoga 3rd eratic Mouse and Keyboard Ubuntu 18.04 on Sleep

2018-05-20, 13:31 PM

Yes, I did them all.  Disabled trackpad in bios, disabled thunderbolt, added the two parameters in grub config, disabled the driver. I made it a little further but now my keyboard does not work after I resume from suspend.

0 person found this solution to be helpful.

This helped me too

Reply
Options

4 Posts

05-19-2018

US

8 Signins

84 Page Views

  • Posts: 4
  • Registered: ‎05-19-2018
  • Location: US
  • Views: 84
  • Message 4 of 6

Re: Thinkpad X1 Carbon Yoga 3rd eratic Mouse and Keyboard Ubuntu 18.04 on Sleep

2018-05-20, 13:59 PM

Yes, I did them all.  Disabled trackpad in bios, disabled thunderbolt, added the two parameters in grub config, disabled the driver. I made it a little further but now my keyboard does not work after I resume from suspend.


 wrote:

Check out this thread: https://forums.lenovo.com/t5/Linux-Discussion/Troubles-with-X1-Carbon-2018-X1C6-TouchPad-and-TrackPoint-under/td-p/4004815

 

Essentially you want to add "psmouse.synaptics_intertouch=1" to your Grub config so your kernel boots with that parameter. But you also have to comment out a line in the modules blacklist file to actually let the driver load. I believe details are on the last page of that thread.


 

Reply
Options

4 Posts

05-19-2018

US

8 Signins

84 Page Views

  • Posts: 4
  • Registered: ‎05-19-2018
  • Location: US
  • Views: 84
  • Message 5 of 6

Re: Thinkpad X1 Carbon Yoga 3rd eratic Mouse and Keyboard Ubuntu 18.04 on Sleep

2018-05-20, 18:00 PM
It looks like I forgot to reconfigure grub, but once I did the mouse issue went away. However, the keyboard now takes about 30 seconds to work, but I guess I can live with that until there is a real solution. I'm happy to be able to put my computer to sleep.
Reply
Options

5 Posts

11-27-2018

US

6 Signins

76 Page Views

  • Posts: 5
  • Registered: ‎11-27-2018
  • Location: US
  • Views: 76
  • Message 6 of 6

Re: Thinkpad X1 Carbon Yoga 3rd eratic Mouse and Keyboard Ubuntu 18.04 on Sleep

2018-11-27, 17:42 PM

This appears to be solved by updating BIOS to 1.27, no grub tricks needed.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete