Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Linux Operating SystemsUbuntu
All Forum Topics
Options

3 Posts

03-16-2018

United States of America

5 Signins

60 Page Views

  • Posts: 3
  • Registered: ‎03-16-2018
  • Location: United States of America
  • Views: 60
  • Message 1 of 2

Trying to dualboot with Ubuntu, but SSD not recognized by Ubuntu

2018-03-16, 2:48 AM

Hello, I just bought the Flex 5 and I want to dualboot Win10 with Ubuntu, but when I try to install Ubuntu it doesn't see the ssd. From looking online it appears that this is because the SATA mode is set to Intel RST instead of AHCI. Any way of changing that triggers a warning that I risk formatting the hard drive. What's the right way to do this?

 

 

Specifically, I have the Flex 5-1470, and the model # I get from "WMIC CSPRODUCT GET NAME" is C189

 

This is the message I get if I try to switch to AHCI: "All existing data stored on the drivers will be erase when resetting Controller mode".

 

Reply
Options

3 Posts

03-16-2018

United States of America

5 Signins

60 Page Views

  • Posts: 3
  • Registered: ‎03-16-2018
  • Location: United States of America
  • Views: 60
  • Message 2 of 2

Re: Trying to dualboot with Ubuntu, but SSD not recognized by Ubuntu

2018-03-16, 4:35 AM

So following the directions here actually worked: https://medium.com/@petragospodneti/windows-10-and-linux-love-hate-dual-boot-problems-d9994cbe16c0

 

Note that the first command is actually 

bcdedit /set {current} safeboot minimal

 

It's just scary switching from RST to AHCI given that warning..

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms