Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Linux Operating SystemsUbuntu
All Forum Topics
Options

1 Posts

06-09-2021

India

2 Signins

15 Page Views

  • Posts: 1
  • Registered: ‎06-09-2021
  • Location: India
  • Views: 15
  • Message 1 of 1

Wifi networks are visible but not connecting in xubuntu 21

2021-07-08, 11:54 AM

Hi all, I bought a brand new Ideapad 5, without any OS. Initially, I installed Xubuntu 20.04 on it, then the touchpad was not working and also the wifi networks were showing but not connecting.

Then I installed Xubuntu 21, the touchpad started working but the wifi still gives the same error that the password is incorrect, which is obviously not because it is a hotspot from my mobile. I tried installing drivers from https://www.intel.com/content/www/us/en/support/articles/000005511/wireless.html and also followed this https://easylinuxtipsproject.blogspot.com/p/intel-wifi.html but no luck.

 

WLAN + Bluetooth™ - 802.11ac 2x2 Wi-Fi + Bluetooth 5.0, M.2 Card (taken from product specifications)

 

some the info about the wifi adapter and the things I tried -


prince@prince-IdeaPad-5-15ITL05:~/Desktop/iwlwifi-Qu-48.13675109.0$ uname -r
5.11.0-16-generic


prince@prince-IdeaPad-5-15ITL05:~/Desktop/iwlwifi-Qu-48.13675109.0$ lspci -nnk | grep 0280 -A3
0000:00:14.3 Network controller [0280]: Intel Corporation Wi-Fi 6 AX201 [8086:a0f0] (rev 20)
    Subsystem: Intel Corporation Wi-Fi 6 AX201 [8086:0074]
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi


prince@prince-IdeaPad-5-15ITL05:~/Desktop/iwlwifi-Qu-48.13675109.0$ sudo lshw -C network
  *-network                 
       description: Wireless interface
       product: Wi-Fi 6 AX201
       vendor: Intel Corporation
       physical id: 14.3
       bus info: pci@0000:00:14.3
       logical name: wlp0s20f3
       version: 20
       serial: 2c:8d:b1:91:28:0a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.11.0-16-generic firmware=59.601f3a66.0 QuZ-a0-hr-b0-59.u ip=10.42.0.1 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: iomemory:600-5ff irq:16 memory:600323c000-600323ffff


prince@prince-IdeaPad-5-15ITL05:~/Desktop/iwlwifi-Qu-48.13675109.0$ nmcli device
DEVICE             TYPE      STATE         CONNECTION 
wlp0s20f3          wifi      disconnected  --         
p2p-dev-wlp0s20f3  wifi-p2p  disconnected  --         
lo                 loopback  unmanaged     -- 

 

Please help I can't figure out how to make it work and connect to the wireless network   

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms