Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Linux Operating SystemsUbuntu
All Forum Topics
Options

16 Posts

02-21-2020

Bulgaria

20 Signins

80 Page Views

  • Posts: 16
  • Registered: ‎02-21-2020
  • Location: Bulgaria
  • Views: 80
  • Message 21 of 22

Re:X1 Carbon 7 gen - Improving Battery Life on Ubuntu

2020-03-31, 8:19 AM

Reverted back to the last kernel - audio and normal sleep are back.

 

Seems like there is a ghost process that attaches itself to different processes after I kill them.

I've ran calibration of powertop twice but:

  1. Powertop was showing 2-3w consumption for the ethernet hardware. I killed it "sudo ifconfig <eth-device-id> down"
  2. The ethernet process disappeared, consumption didn't go down, but the wifi process went up as if some invisible process just changed houses.
  3. Killed the wifi process, display backlight went up.

 

Any ideas how to catch this?

I remember reading something about bad combination of video driver & kernel. So video driver went in a loop making excessive consumption but was not shown as a process.

Also I don't see anywhere the GPU consumption.

Reply
Answer
Options

16 Posts

02-21-2020

Bulgaria

20 Signins

80 Page Views

  • Posts: 16
  • Registered: ‎02-21-2020
  • Location: Bulgaria
  • Views: 80
  • Message 22 of 22

Re:X1 Carbon 7 gen - Improving Battery Life on Ubuntu

2020-04-04, 17:03 PM

Update to 5.3.0-46-generic kernel - idle consumption went way down.

The upgrade broke the WiFi, bluetooth, audio output is now bad(maybe no subwoofer), recognized the internal mic but not working.

 

Minimal brightness, WiFi ON, no Apps - 2.7-3 Watts

 

Brightness about 30%, Chrome with 13 tabs, WiFi ON, text editor and Slack only 5.5 Watts

 

That's much better!

 

Still a lot of wakeups/seconds - about 1000. So if someone knows how to chase them down, would be great. Tried a lot of things but nothing interesting.

 

---------

 

If you want to change easily between kernels:

 

I've set the grub config to load the last chosen kernel.
sudo nano /etc/default/grub

GRUB_SAVEDEFAULT=true
GRUB_DEFAULT=saved

On reboot (Esc or Shift) to go into the Grub menu -> Advanced -> choose kernel

This way I can more easily switch between them to test.
 

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms