cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
satman778
Not applicable
Posts: 1
Registered: ‎07-09-2017
Location: IN
Views: 6,924
Message 1 of 2

problem with wifi on ubuntu 17.04 with idea pad 310 | RTL8821AE wifi drivers

This is my third laptop from leneveo series and this time i am strugling hard due to wifi issue i am facing on my machine.

 

Bought myself a nice new Ideapad 310, but I'm having wifi issues. I know it's not the card itself as it's working fine in Windows.

 

A little bit of console output:

 

techfossguru@techfossguru:~$ lspci | grep Wireless
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter

 

 

 

There is another odd thing I noticed that might be relevant: After the internet has dropped out, I can disconnect from the wlan via the icon but I can't reconnect. 

 

 

I would be very happy if you could help me with this problem. If you need any other information, tell me and I will post it.

Thanks!

 

EDIT: After some more searching, I found some posts/articles that describe exactly the same problem as I have:

Wireless disconnect issues Ubuntu 16.04 with RTL8821ae

https://medium.com/@elmaxx/rtl8821ae-wifi-drivers-in-ubuntu-16-04-4c1286524afa#.dsczz2t2w

https://ubuntuforums.org/showthread.php?t=2245164

 

 

Unfortunately, in some posts the problem stays unsolved and in some others, where solutions are posted, the solutions don't work for me, so I really count on your help.

 

Anonymous_User
Not applicable
Posts: 0
Views: 6,763
Message 2 of 2

Re: problem with wifi on ubuntu 17.04 with idea pad 310 | RTL8821AE wifi drivers

No its the card, search around you can find some people running Ubuntu or Mint that have some solutions you can try. The Realtek cards are really terrible with Linux. Personally I would buy a different card that works better if you want to use Linux. I ran into this several months ago with a notebook that had a RealTek card. Never did get it to work as well as with Windows. I finally replaced the card with a Intel and problem solved. 

Check out current deals!


Shop current deals

Top Kudoed Authors