cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bgupta91
Paper Tape
Posts: 6
Registered: ‎08-05-2019
Location: US
Views: 9,485
Message 1 of 13

thinkpad x1 7th generation ubuntu 19.04 linux learnings

I wanted to create a post about my experience with setting up Ubuntu on my new x1 carbon 7th gen which I got a few days ago.

 

TL;DR

I was able to install and dual boot Ubuntu 19.04 alongside Windows 10 (which comes pre-installed) without too much difficulty. Most things worked out of the box including touchpad, trackpoint, bluetooth/wifi etc, but not everything. I had issues with sleep/suspend, battery life, heat, and I just couldn't get the Synaptics fingerprint reader to work. I was able to resolve a decent amount of the issues after doing quite a bit of googling.

Overall, I think the new x1 is very usable and works well on Linux once you fix a couple annoying issues, but I think Lenovo could really improve this experience. Lenovo should allow for an option to ship with Ubuntu out of the box or provide some sort of Linux set up guide so you don't have to rely on several different user articles in a myeriad of forums.

 

Battery Life

Lenovo claimed 12-14 hours of battery life for this model and several reviews attested they saw 10+ hours. However, I immediatley noticed I was only getting about 5-6 hours on Ubuntu, even though Windows would tell me I have 10+ hours at the same battery level.

I have more testing I need to do on this, but tlp is the solution I found. Its an advanced power management system for Linux which accounts for things like turbo boost. This article gives a really good overview. You can set it up pretty easily and then reboot your laptop to see the results:

$ sudo add-apt-repository ppa:linrunner/tlp
$ sudo apt-get update
$ sudo apt-get install tlp tlp-rdw

Sleep/Suspend and Wake up with Laptop's lid close/open

This one really annoyed the crap out of me. My x1 7th gen would go into deep sleep when I closed the laptop lid, and would not wake up automatically when I went to open the lid. I spent a lot of time debugging Ubuntu's suspend settings thinking that perhaps it wasn't configured properly to wake up upon lid open event. This led to check /proc/acpi/wakeup, which already had:

LID              S4               *enabled

I discovered another video which said to make sure the BIOS power config for "Sleep State" was set to "Linux" instead of "Windows 10". I had an altogether different BIOS than the video:

C:\Users\bgupt>wmic bios get smbiosbiosversion
SMBIOSBIOSVersion
N2HET31W (1.04 )

A fancy new type of BIOS that even supports mouse input. But apparently my laptop shipped with an oudated version. I booted Windows and went to Lenovo's support page which has a tool that automatically updates drivers, utilities, and BIOS. This tool worked really well and updated my BIOS to N2HET31W 1.14. After this update, I set Config->Power->Sleep State to "Linux", after which closing/opening my lid in Ubuntu worked like it should Smiley Happy

 

Fingerprint reader *still doesn't work! Smiley Sad
The x1 7th gen ships with a Synaptics fingerprint scanner which is not listed on fprint's list of supported devices. I ensured my laptop had all the right fingerprint packages:

sudo apt install libpam-fprintd fingerprint-gui libbsapi

 Opening fingerprint-gui, it says "No device found!" and Settings->Details->Users has no option to enable fingerprint logins. This thread leads to me to believe there's no solution currently.

 

That's all for now. If you own a x1 carbon 7th gen and have had some difficulty or even success with your Linux installation adventures, please do share them here.

pleb
What's DOS?
Posts: 2
Registered: ‎08-05-2019
Location: US
Views: 9,388
Message 2 of 13

Re: thinkpad x1 7th generation ubuntu 19.04 linux learnings

Thanks for the post. I look forward to getting more involved when I get my laptop.
timatgca
Token Ring
Posts: 27
Registered: ‎12-29-2016
Location: AU
Views: 9,316
Message 3 of 13

Re: thinkpad x1 7th generation ubuntu 19.04 linux learnings

Measuring actual battery usage by the OS estimate of remaining battery is not reliable. 

It is better to run a tool which measures actual power use of a period of time (say, ten minutes)

 

On linux, use 

powerstat -d 0

(-d 0 means it starts right away, by default it waits a while to let the system settle down)

(you don't need to run it as root)

 

On Windows, I like the freeware BatteryInfoView from nirsoft

https://www.nirsoft.net/utils/battery_information_view.html

 

it has a logging option to record power use. For instance, you can see the idle usage of both systems. 

With a modern kernel and tlp linux does better than windows on my P50 and T480. My 32 GB, two SDD T480 idles on Ubuntu 18.04.2 at <4W with wifi on and the screen two stops above minimum, I bet the Carbon does better.

bgupta91
Paper Tape
Posts: 6
Registered: ‎08-05-2019
Location: US
Views: 9,246
Message 4 of 13

Re: thinkpad x1 7th generation ubuntu 19.04 linux learnings

Thanks this is a handy tip! Looks like I'm not doing better though:

bharat@bharat-ThinkPad-X1-Carbon-7th:~$ powerstat -d 0
Running for 480.0 seconds (48 samples at 10.0 second intervals).
Power measurements will start in 0 seconds time.

  Time    User  Nice   Sys  Idle    IO  Run Ctxt/s  IRQ/s  Watts
15:50:31   4.8   0.0   1.2  93.9   0.0    1   2398    968   8.59 
15:50:41   5.7   0.0   1.4  92.8   0.1    1   2636   1071   7.76 
15:50:51   5.6   0.0   1.2  93.1   0.0    1   2671   1074   6.92 
15:51:01   5.8   0.0   1.1  93.0   0.1    1   2474   1047   6.76 
15:51:11   5.5   0.0   1.2  93.3   0.1    1   2426   1041   6.55 
15:51:21   4.7   3.1   1.4  90.7   0.1    3   2571   1089   6.59 
15:51:31   5.1   0.0   1.0  93.8   0.1    1   2539   1024   6.86 
15:51:41   5.8   0.0   1.9  92.2   0.1    1   5034  11377   6.98 
15:51:51  10.4   0.0   2.9  86.6   0.0    2   6889  10538   7.50 
15:52:01  15.6   0.0   3.4  80.9   0.1    3   9373   6460   9.32 
15:52:11   8.9   0.0   1.8  89.2   0.1    2   4223   1568   8.69
bgupta91
Paper Tape
Posts: 6
Registered: ‎08-05-2019
Location: US
Views: 9,243
Message 5 of 13

Re: thinkpad x1 7th generation ubuntu 19.04 linux learnings

A couple weird issues I'm experiencing:

- Occasionally after a restart the trackpad doesn't work. In order to fix it, I have to do another restart, haven't been able to figure out a better fix. Never saw this happen in Windows or in the Bios so I'm almost certain its Ubuntu related
- Sometimes restart doesn't go through normally causing it to hang on the "Lenovo" screen where you can enter Bios. When this happens I need to manually press power button to shutdown

willismonroe
Serial Port
Posts: 23
Registered: ‎06-22-2019
Location: CA
Views: 9,176
Message 6 of 13

Re: thinkpad x1 7th generation ubuntu 19.04 linux learnings

Thanks for your tips.  I created a thread also about Ubuntu which you can find here: https://forums.lenovo.com/t5/Ubuntu/Guide-X1-Carbon-7th-Generation-Ubuntu-compatability/td-p/4489823

 

Two points about your last post:

 

I have also experienced the intermitent trackpad issue.  However it looks like there is a new firmware driver for the trackpad (found here under "Mouse, Pen, and Keyboard" https://pcsupport.lenovo.com/ca/en/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-...) that is unfortunately only installable in Windows.  But the changelog for the new firmware explicitly mentions fixing the issue with the trackpad in Linux (why isn't it installable in Linux?!).

 

The second issue is also something I've experienced, and I don't know any way to make it work.

 

Have you had any luck with getting the speakers to work better, or getting the microphone to work at all?

wrycode
What's DOS?
Posts: 1
Registered: ‎08-08-2019
Location: US
Views: 9,158
Message 7 of 13

Re: thinkpad x1 7th generation ubuntu 19.04 linux learnings

To add to the solutions people have posted about the touchpad, on Arch Linux the touchpad works fine out of the box, except that installing TLP (which you should do) disables it. This is because TLP does not detect that the Synaptics Touchpad is indeed an input device, so it does not exclude it from the USB_AUTOSUSPEND feature.

 

You can tell that this is the issue if the touchpad works for just a moment after waking up from suspend, and then stops working again.

 

The fix is to add the touchpad to the USB_BLACKLIST in TLP's config. To get the UUID, use

lsusb

So the option in my TLP config file looks like this:

# Exclude listed devices from USB autosuspend (separate with spaces).
# Use lsusb to get the ids.
# Note: input devices (usbhid) are excluded automatically
# Default: <none>
#USB_BLACKLIST="1111:2222 3333:4444"
USB_BLACKLIST="06cb:00bd"
xhejtman
What's DOS?
Posts: 1
Registered: ‎08-19-2019
Location: CZ
Views: 8,736
Message 8 of 13

Re: thinkpad x1 7th generation ubuntu 19.04 linux learnings

Is anyone facing the issue with touchpad/trackpoint, it generates spurious clicks for me. E.g. moving cursor over brower tabs, it randomly drags a tab or when I click on captcha picture to select it, it gets selected and immediatelly unselected, i.e., it generates two clicks instead of one. Using xubuntu 19.04. I tried to play with synclient options but no luck in this.

NikosAlexandris
SCSI Port
Posts: 77
Registered: ‎04-28-2014
Location: IT
Views: 8,585
Message 9 of 13

Re: thinkpad x1 7th generation ubuntu 19.04 linux learnings

Maybe of interest, the Lenovo ThinkPad X1 Carbon 7th Gen has been awarded the status of certified pre-install for Ubuntu 18.04 LTS 64-bit, obviously with the components described at https://certification.ubuntu.com/hardware/201904-26993/.

Remote Sensing & Geomatics
GPG Key Fingerprint 6F9D4506F3CA28380974D31A9053534B693C4FB3
elu_r
Paper Tape
Posts: 2
Registered: ‎08-26-2019
Location: NL
Views: 8,373
Message 10 of 13

Re: thinkpad x1 7th generation ubuntu 19.04 linux learnings

We keep having crashes on Ubuntu 18 and 19. Full freezes without anything in the logs.

 

Sometimes we also have complete system lags where the WA time skyrockets for a few seconds and we see GPU related errors:

 

[2220.745082] i915 0000:00:02.0: GPU HANG: ecode 9:1:0xfffffffe, in Xorg [1383], hang on rcs0

[ 2220.746111] i915 0000:00:02.0: Resetting rcs0 for hang on rcs0

 

Anyone else experiencing complete freezes / similar issues? Already tried latest 5.2.x kernels and 5.3 RC.

And we're back...

Move delayed but still coming

Learn More

Check out current deals!


Shop current deals

Top Kudoed Authors