English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

237 Posts

04-20-2011

UNITED STATES

699 Signins

2571 Page Views

  • Posts: 237
  • Registered: ‎04-20-2011
  • Location: UNITED STATES
  • Views: 2571
  • Message 1 of 14

W520 UEFI and Bitlocker

2011-05-21, 3:58 AM

When will there be a BIOS update to fix the UEFI/Bitlocker issue? The TPM won't pass the keys to Windows when UEFI mode is on. An X220 owner has this issue as well:

http://forums.lenovo.com/t5/X-Series-ThinkPad-Laptops/BitLocker-on-X220-with-UEFI-boot/td-p/426917

Solved! See the solution
Reply
Options

3538 Posts

07-12-2010

Malaysia

5065 Signins

104816 Page Views

  • Posts: 3538
  • Registered: ‎07-12-2010
  • Location: Malaysia
  • Views: 104816
  • Message 2 of 14

Re: W520 UEFI and Bitlocker

2011-05-23, 7:47 AM
@bogatyr,

I will check this with someotherguy internally on the status of the issue.

Thanks

//JameZ
Reply
Options

237 Posts

04-20-2011

UNITED STATES

699 Signins

2571 Page Views

  • Posts: 237
  • Registered: ‎04-20-2011
  • Location: UNITED STATES
  • Views: 2571
  • Message 3 of 14

Re: W520 UEFI and Bitlocker

2011-05-30, 21:45 PM

Bios 1.25 mentioned: (New) Added support for a new type of the Embedded Controller.

 

So I installed that today, thinking maybe that meant TPM support in UEFI. No such luck, Win7 is still saying it cannot contact the TPM for the encryption keys during the reboot test prior to encrypting.

Reply
Options

6475 Posts

10-29-2009

NC

17629 Signins

161518 Page Views

  • Posts: 6475
  • Registered: ‎10-29-2009
  • Location: NC
  • Views: 161518
  • Message 4 of 14

Re: W520 UEFI and Bitlocker

2011-05-31, 20:35 PM

I'm sorry but there is no solution for this issue yet.  If you need bitlocker support today, then please do not use native UEFI installation of Windows 7.

Reply
Options

31 Posts

02-04-2009

Singapore

1046 Signins

1734 Page Views

  • Posts: 31
  • Registered: ‎02-04-2009
  • Location: Singapore
  • Views: 1734
  • Message 5 of 14

Re: W520 UEFI and Bitlocker

2011-06-29, 6:47 AM

Any updates on this issue? Is there a chance that this will be fixed in the July bios release (the one that supposed to have a fix for the turboboost issue)?

---
www.yuryaverkiev.com
Reply
Options

6475 Posts

10-29-2009

NC

17629 Signins

161518 Page Views

  • Posts: 6475
  • Registered: ‎10-29-2009
  • Location: NC
  • Views: 161518
  • Message 6 of 14

Re: W520 UEFI and Bitlocker

2011-06-29, 12:51 PM

The BIOS versions that fix the BitLocker/UEFI problem on all current ThinkPad products (X220/T420/T520/W520) is currently in test phase and should be released soon.  I'm sorry I don't have any specific date but I think it is reasonable to expect the release within July and probably sooner.

Reply
Options

1 Posts

06-30-2011

Massachusetts

10 Signins

18 Page Views

  • Posts: 1
  • Registered: ‎06-30-2011
  • Location: Massachusetts
  • Views: 18
  • Message 7 of 14

Re: W520 UEFI and Bitlocker

2011-06-30, 11:11 AM

Since I bypassed the hardware check, I was able to get encrypted, but the TPM always rejects the PIN.  Does this BIOS address that issue also?

Reply
Options

6475 Posts

10-29-2009

NC

17629 Signins

161518 Page Views

  • Posts: 6475
  • Registered: ‎10-29-2009
  • Location: NC
  • Views: 161518
  • Message 8 of 14

Re: W520 UEFI and Bitlocker

2011-07-01, 20:46 PM

The issue isn't with bitlocker being able to encrypt or decrypt the drive, because that's all done in software.  The issue is authenticating with the TPM to get the decryption key, and that's where UEFI is currently failing.  Whether you authenticate with a PIN or not doesn't matter - the result is fail so you have to use the recovery key.

Reply
Options

6475 Posts

10-29-2009

NC

17629 Signins

161518 Page Views

  • Posts: 6475
  • Registered: ‎10-29-2009
  • Location: NC
  • Views: 161518
  • Message 9 of 14

Re: W520 UEFI and Bitlocker

2011-07-07, 13:21 PM

The BIOS to fix this issue has been released:

 

BIOS here

 

BIOS Text

 

- Fixed an issue where the BitLocker function could not be enabled on Windows
  64-bit.

0 person found this solution to be helpful.

This helped me too

Reply
Options

2 Posts

07-20-2011

REDMOND, WA

5 Signins

33 Page Views

  • Posts: 2
  • Registered: ‎07-20-2011
  • Location: REDMOND, WA
  • Views: 33
  • Message 10 of 14

Re: W520 UEFI and Bitlocker

2011-07-20, 23:42 PM

@someotherguy

Can you also help "port" it to X220?

It has been annoying me for some time.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete