English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

24 Posts

04-16-2010

Jakarta, Indonesia

160 Signins

329 Page Views

  • Posts: 24
  • Registered: ‎04-16-2010
  • Location: Jakarta, Indonesia
  • Views: 329
  • Message 1 of 11

W520 Ultrabay HDD ejects or dismounts on sleep or hibernation and doesnt reconnect

2013-01-24, 13:34 PM

W520

4270-CTO

 

I purchsed an aftermarket ultrabay. its the genuine Lenovo part that fits this machine, not the one with the extra space, so there is no action/movement of the harddrive. Im using a 320 WD Black Scorpion and running my VMs off it. 

 

I dont have any problems until I put the computer to sleep or it goes into hybernation. When that happens and I wkae the computer back up, the drive is not recognized and never comes back.  The only way to get it to come back is to physically eject the ultrabay (slide the lock switch to unlock position and pull it out) and then snap it back into place. 

 

This is becoming very problematic as it means I have to shut down all my VMs every time i need to put my computer to sleep or my VMs crash. 

 

I opened a ticket with Lenovo Premium Support but they basically had me run diagnostics on the harddrive, which I really dont think has anything to do with it. 

 

I updated all the drivers for RST as suggested on another thread as well as almost all drivers on the machine and still no luck. 

 

any ideas on what I could do to resolve this? I got this machine mainly for virtualization and not being able to use the ultrabay to its fullest extent is pretty frustrating. would really like to get this working smoothing.

 

thanks in advance,

Matt

Solved! See the solution
Reply
Options

24 Posts

04-16-2010

Jakarta, Indonesia

160 Signins

329 Page Views

  • Posts: 24
  • Registered: ‎04-16-2010
  • Location: Jakarta, Indonesia
  • Views: 329
  • Message 2 of 11

Re: W520 Ultrabay HDD ejects or dismounts on sleep or hibernation and doesnt reconnect

2013-01-24, 16:33 PM

Ok, I think this is resolved. 

 

The trick is that in order to conserve power, the computer wants to put that port (i think thats a correct reference) to sleep after a period of inactivity and only wake it up when its active again.  In the case of the DVD/CD-ROM drive thats putting a new disc in or starting up a disc thats already there. 

 

There is a power setting available in the Power Manager called "Automatic optical drive power off" that disables this power saving. By default this is set to "disable" which effectively means the drive is powered off after a time of inactivity.  The catch is this setting is only available when the DVD/CD-ROM drive is in the bay.  

 

To resolve for the ultrabay with HDD:

  • Insert the combo drive in the bay
  • Enabling the setting
  • Replace combo drive with the ultrabay

I havent done any extensive testing but putting the computer to sleep and waking it back up the HDD is available and spinning. 

Reply
Options

24 Posts

04-16-2010

Jakarta, Indonesia

160 Signins

329 Page Views

  • Posts: 24
  • Registered: ‎04-16-2010
  • Location: Jakarta, Indonesia
  • Views: 329
  • Message 3 of 11

Re: W520 Ultrabay HDD ejects or dismounts on sleep or hibernation and doesnt reconnect

2013-01-25, 12:36 PM

ok, this didnt resolve the issue. After waking my computer this morning, again the drive in the ultrabay is not showing up. 

 

Any ideas on resolution on this?

Reply
Options

2430 Posts

04-08-2011

US

5471 Signins

46460 Page Views

  • Posts: 2430
  • Registered: ‎04-08-2011
  • Location: US
  • Views: 46460
  • Message 4 of 11

Re: W520 Ultrabay HDD ejects or dismounts on sleep or hibernation and doesnt reconnect

2013-01-25, 17:34 PM

Which ultrabay HDD adapter did you buy?

Reply
Options

24 Posts

04-16-2010

Jakarta, Indonesia

160 Signins

329 Page Views

  • Posts: 24
  • Registered: ‎04-16-2010
  • Location: Jakarta, Indonesia
  • Views: 329
  • Message 5 of 11

Re: W520 Ultrabay HDD ejects or dismounts on sleep or hibernation and doesnt reconnect

2013-01-28, 12:26 PM

 Lenovo 0A65623 Internal ThinkPad 12.7mm Serial ATA Hard Drive Bay Adapter III

Reply
Options

24 Posts

04-16-2010

Jakarta, Indonesia

160 Signins

329 Page Views

  • Posts: 24
  • Registered: ‎04-16-2010
  • Location: Jakarta, Indonesia
  • Views: 329
  • Message 6 of 11

Re: W520 Ultrabay HDD ejects or dismounts on sleep or hibernation and doesnt reconnect

2013-01-28, 12:28 PM

one more follow up.  it seems that when the computer is put to sleep, if i wake it up before an indeterminate amout of time (>15 min? ), the drive still shows up. but when i wake up the computer after its been asleep for more than 30 min, the drive doesnt show up.

Reply
Options

2430 Posts

04-08-2011

US

5471 Signins

46460 Page Views

  • Posts: 2430
  • Registered: ‎04-08-2011
  • Location: US
  • Views: 46460
  • Message 7 of 11

Re: W520 Ultrabay HDD ejects or dismounts on sleep or hibernation and doesnt reconnect

2013-01-28, 17:37 PM

Does your machine hibernate after 30 minutes?

Reply
Options

24 Posts

04-16-2010

Jakarta, Indonesia

160 Signins

329 Page Views

  • Posts: 24
  • Registered: ‎04-16-2010
  • Location: Jakarta, Indonesia
  • Views: 329
  • Message 8 of 11

Re: W520 Ultrabay HDD ejects or dismounts on sleep or hibernation and doesnt reconnect

2013-01-28, 17:41 PM

no, i have hibernation set to Never. 

Reply
Options

24 Posts

04-16-2010

Jakarta, Indonesia

160 Signins

329 Page Views

  • Posts: 24
  • Registered: ‎04-16-2010
  • Location: Jakarta, Indonesia
  • Views: 329
  • Message 9 of 11

Re: W520 Ultrabay HDD ejects or dismounts on sleep or hibernation and doesnt reconnect

2013-01-30, 10:55 AM

Just an update here. I havent had this happen (wake the computer up after a long time being in Sleep Mode and the drive not show up) for 2 days now. Prior to making the power setting adjustment it happened every time so this is some progress. 

 

Once I can identify a repeatable pattern I will post back. 

Reply
Options

5 Posts

02-11-2012

CA

14 Signins

85 Page Views

  • Posts: 5
  • Registered: ‎02-11-2012
  • Location: CA
  • Views: 85
  • Message 10 of 11

Re: W520 Ultrabay HDD ejects or dismounts on sleep or hibernation and doesnt reconnect

2013-02-22, 3:12 AM

Having the same laptop and ultrabay as you do. The solustion I tried was to make it as virtual memory in Advanced system settings, say, make it 100MB to 110MB and the harddrive will come back everytime it wake from sleep. In Win7 you probably get an pop-up window, but in Win8 that works fine.  The issue is that I want to stop spinning of the extra harddrive after say 30secs, but if I didn't set it as virtual memory, it won't come back anyway from sleep, otherwise, the system will write to the the extra hardrive the page file and that's make it spin again even I don't want to.

 

Hope this helps you.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save