cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bengalih
Serial Port
Posts: 35
Registered: ‎01-10-2018
Location: US
Views: 7,592
Message 1 of 2

W530 - Synaptics Touchpad freezes with Windows 10 (1709)

* Let me preface by saying that I have no experience with this issue on another operating system for any extended period of time.  The laptop came with Windows 7 and in the limited time I was testing with that I had no issues.  I installed Windows 10 (1709) fresh and have had the issue consistently since then.  My tests indicate this is a driver and not a hardware issue *

 

Basically, what is happening is about once or twice an hour my touchpad pointer will become non-responsive.  I will move my finger on the pad and the mouse either doesn't move or doesn't appear (if offscreen/hidden/etc).

During this time the touchpad buttons work and the TrackPoint stick also works to move the pointer.  The issue seems limited to just the pad.

 

When the issue occurs it lasts for about 5 seconds or so.  During this time I try several things like tapping multiple times on the pad, trying to push harder, or moving the TrackPoint stick.  It seems that the latter often seems to kick control back.  TBH, I haven't yet shown enough patience to let it sit for 15 seconds and see if the control returns (I will be doing some more testing on all of this).

 

I am using the Windows 10 drivers shown on the download page:

Synaptics ThinkPad UltraNav Driver for Windows 10 (32-bit, 64-bit) - ThinkPad 19.0.17.135 - 1/28/18

 

I have tried other drivers from different Lenovo products (some earlier some later).

Either the drivers don't work at all, or they get rid of some important features (like the use of the middle button for scrolling).

 

I also cannot use the native Windows drivers becuase they too don't allow the middle button and especially because they have no ability to disable the tap-to-click feature which I cannot use.

 

I have some idea that the driver itself may be crashing although I haven't found evidence of this in the Event Viewer.  The reason I believe this is the other day I noticed that tap-to-click was enabled where I had previously turned it off.  When I opened up the trackpad settings it indeed showed off and then started to function normally (i.e. not on).  I believe the process of opening the settings reloaded the driver somehow and took the settings again.

 

This is getting frustrating as the issue seems to appear almost once every 30 minute+ session.

 

Any ideas?

 

Thanks.

bengalih
Serial Port
Posts: 35
Registered: ‎01-10-2018
Location: US
Views: 7,470
Message 2 of 2

Re: W530 - Synaptics Touchpad freezes with Windows 10 (1709)

Just wanted to update my OP here.  After doing more research outside of Thinkpads (amazed that more people were not complaining of this....as I'm sure there must be a decent share of older Thinkpad users still wanting to run Windows 10), I found what looks like a solution.

 

Under Advanced mouse settings > Touchpad, there is a section called "Smart Check Settings."

Under here is an option called PalmCheck with the following description:

 

"The PalmCheck™ feature guards against operating the TouchPad with accidental contact. PalmCheck allows the TouchPad to recognize when your palm is resting on it or brushing its surface while you are typing. This will help to prevent unwanted pointer movement or clicks.

If the TouchPad exhibits undesired pointer movement or clicks, increase the PalmCheck setting by moving the slider to the right toward Maximum. If the TouchPad misses intended motions or taps, decrease the PalmCheck setting by moving the slider to the left toward Minimum. You are more likely to experience missed motions or taps if the slider is in the red zone."

 

I didn't think this was really an accurate description of what was happening to me, but there is also a checkbox on that screen to disable (enabled by default) an option called "Prioritize for TrackPoint and keyboard input" with the following description:

 

"Prioritizing for TrackPoint and keyboard input will temporarily ignore contact on the touchpad for a short time following input on either the TrackPoint or keyboard.

Smart Check Settings can help reduce unwanted touchpad behavior. See each setting for more detail."

 

This sounded exactly like what was happening to me...the touchpad becoming disabled for a short time, bit I didn't think it was necessarily due to using the keyboard (I rarely use TrackPoint).  I disabled this option and over the course of at least 2-3 hours of use over several computing sessions have not experienced the issue again.

 

I don't know if this 100% solved it, but so far all signs point to yes as I would have experienced this issue at least 3 or 4 times during the same usage period.

 

I'm not sure if this feature was new with the latest drivers, enabled by default, or simply more sensitive but it didn't seem to affect Windows 7 build on this system.

 

Hope this helps someone else!

 

 

Check out current deals!


Shop current deals

Top Kudoed Authors