Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Fanfold Paper
Posts: 7
Registered: ‎01-18-2011
Location: Colorado

Re: Lenovo Y560 unable to install Windows 7 SP1

I have a G560 with the same issue of down level graphics driver( through that needs to be udpated before KB2454826 can be downloaded and installed, which will then allow SP1 to be downloaded and installed.


I did some research and there is a Intel automatic driver detect and update utility at the following link:


Click on the "Run Intel Driver Update Utility" button and it will auto detect what drviers you have and what new drivers are available to install


I think you should be able to install updated drivers directly from Intel.


Once the driver is updated then according to the Microsoft article Windows Update should automatically download KB2454826 and allow you to install SP1.

Blue Screen Again
Posts: 4
Registered: ‎02-25-2011
Location: Tennessee
0 Kudos

Re: Lenovo Y560 unable to install Windows 7 SP1

I tried your suggestion to use Intel automatic driver detection on my Y460 with NO LUCK!


The message it gave me was:  A customized computer manufacturer driver is installed on your computer. The Intel Driver Update Utility is not able to update the driver. Installing a generic Intel driver instead of the customized computer manufacturer driver may cause technical issues. Contact your computer manufacturer for the latest driver for your computer.


Has anyone found a way to install Windows 7 Service Pack 1 (SP1) ?


I have also not been able to install the new Windows Explorer - I'm sure for the lack of the SP1 - what's next?  Oh probably security patches.



Posts: 9,048
Registered: ‎12-26-2009
Location: Toronto, Canada
0 Kudos

Re: Lenovo Y560 unable to install Windows 7 SP1

What is the new Windows Explorer?

SP1 isn't too significant as a service pack; if you don't need it, you don't really need to install it except for the sake of being up-to-date.
W520: 2720QM, Q2000M at 1091/1376, 21GB RAM, 500GB + 750GB HDD, FHD screen & MB168B+
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Y3P: 5Y70, 8GB RAM, 256GB SSD, QHD+ screen
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
Paper Tape
Posts: 1
Registered: ‎05-19-2011
Location: AZ

Re: Lenovo Y560 unable to install Windows 7 SP1

[ Edited ]

SOLUTION for Lenovo G560 running Windows 7 Pro x64bit


1) Un-install the Intel Driver in device manager, this should roll it back to a standard vga graphics driver

2) Navigate to C:\drivers and delete any intel graphics driver folders

3) Restart

4) Run Windows Update and it will automatically find a new intel graphics driver update

5) Restart

6) You should now be able to run windows update and get sp1, as the intel driver it auto-found is outside of the range that prevents the update.


For reference, this is the Microsoft KB Article about this issue:


After the Windows Update, my driver version was


This worked for me, hope you guys find it useful! (I also called Lenovo support and informed them about this solution that I figured out)

What's DOS?
Posts: 1
Registered: ‎05-29-2011
Location: Spain
0 Kudos

Re: Lenovo Y560 unable to install Windows 7 SP1

d0z0r, thank you. Thank you so much! I would never try to delete the IntelVideo folder on c:\Drivers and for this reason the trick never worked for me.


It works on Lenovo Thinkpad Edge 11 perfectly (I'm now dowonloading Windows 7 SP1 from WindowsUpdate)


For non-experienced user:


1) On drive C, go to Drivers folder, and delete IntelVideo Folder (you may compress it with name encryption and password if you feel better Smiley Happy )

2) Right click on My Computer -> Properties. On the left go to Device Manager.

3) Browse through Display Adapters, and right click on IntelHD Graphics, and click Uninstall. It will take a while, and reintall VGA drivers. It will ask you to reboot. Do so.


Once logged on, windows will look for the drivers automatically (it takes a few minutes until search Windows Update, downloads and installs.)


Once you reboot again, check for new updates, and Voilá!, you get SP1!


Thank you so much again d0z0r !!!!!  You finishes a 4 pages thread within no time!!!!


Fanfold Paper
Posts: 6
Registered: ‎10-11-2008
Location: Israel
0 Kudos

Windows 7 x64 is stopped during start up after SP1 installation

Hi All,


My Windows 7 x64 is completely updated with Windows Update, except 'Windows 7 Service Pack 1 for x64-based Systems (KB976932)' (this is the only available update for my laptop, using Windows Update).


SP1 installation using Windows Update, completed OK.

But, during computer restart (after installation), it is getting up to the user & password step, and then stuck (have been tried several times, after 'Shut Down' by long pressing the on/off button).


The only way to recover was getting into safe mode (start up completed OK!) and uninstall the SP1.


Any idea?







Model: 6460-D6G

BIOS: 2.29 (7LETC9WW) 

CPU: T8300


Display adpt.: NVIDIA Quadro NVS 140M

Network: Intel 82566MM; Wireless: 4965AGN

Was originally installed with Windows XP Prof.

Reinstalled with Windows 7 x64 Prof. (clean installation)



Community Moderator
Posts: 4,201
Registered: ‎01-13-2008
Location: Bainbridge Island, WA, USA

Re: Windows 7 x64 is stopped during start up after SP1 installation

Here's a bit of a long shot:  With SP1 installed, boot to safe mode and disable your antivirus and security software (so it is OFF on next reboot).  See if that lets you get past the login screen.


My T400 did something similar after an SP1 update.  I couldn't log in via the fingerprint reader. ESET was detecting a change in the login software (since it was just updated) and was not allowing it to run.  Since I hadn't yet logged in, ESET couldn't present a query window to ask permission to run it.


In my case, I could still log in manually.


I don't really think that's what is wrong in your case, but maybe it's worth a try.


Good luck,


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored. ... GeezBlog

English English Community   Deutsche Deutsche Community   Español Comunidad en Español   ru.gif Русскоязычное Сообщество

Fanfold Paper
Posts: 6
Registered: ‎10-11-2008
Location: Israel
0 Kudos

Re: Windows 7 x64 is stopped during start up after SP1 installation

Yes, it was the ESET that cause the whole thing.

It was necessary to uninstall it (in safe mode), in order to complete the SP1 installation.

Then, I have reinstalled the ESET. So far it looks fine.



Punch Card
Posts: 34
Registered: ‎07-12-2011
Location: France
0 Kudos

Re: Windows 7 x64 is stopped during start up after SP1 installation

[ Edited ]

Thanks for a great set of posts. Wondered why I hadn't got SP 1 installed for Home Premium 64-bit Windows 7 on my new G560 - uninstalled Intel driver and Voila! - on reboot, new driver was installed and SP1 visible in download list. Didn't even need to delete any driver folder (couldn't find one, actually). Astounding that Lenovo leave us fumbling around in the dark on this. Thanks again to forum members who take the trouble to post their solutions.


Lenovo G560 - Windows 7 Home Premium x64
Punch Card
Posts: 34
Registered: ‎07-12-2011
Location: France
0 Kudos

Re: Windows 7 x64 is stopped during start up after SP1 installation

[ Edited ]

Well, I spoke too soon. Changing the Intel Video driver to certainly made SP1 available for download but installation failed with an error code 80070020. Tried an installation with Avast Antivirus turned off but it failed again.


When I changed the Intel driver to, I didn't delete the IntelVideo folder because I couldn't find a Drivers folder in the root of C. As I now seem to have Intel driver installed, does it matter? I'm not exactly a computer novice, but this is my first Windows 7 machine so please excuse any daft questions.


I've run the System Update Readiness Tool but still no dice.


I notice that in this Lenovo website page, my new G560 is not listed as SP1 compatible!


Any suggestions greatfully received




Lenovo G560 - Windows 7 Home Premium x64