Showing results for 
Search instead for 
Do you mean 
Punch Card
Posts: 31
Registered: ‎03-21-2010
Location: Sydney
Message 1 of 7 (1,735 Views)

Win7 update not working after adding 750GB HD

I've got a T410. I recently bought a 750GB seagate HD and attempted an OS restore via those thinkpad restore DVD's I created using thinkpad tools.


Now Win7 update does not work. It says my windows7 update service is not running but it is! I've got this exact same problem but none of their solutions are working.


Has this happened to anyone?

Lenovo Staff
Posts: 4,027
Registered: ‎10-29-2009
Location: NC
Message 2 of 7 (1,726 Views)

Re: Win7 update not working after adding 750GB HD

 from this forum wrote an excellent blog post about this exact issue, please see:


Punch Card
Posts: 31
Registered: ‎03-21-2010
Location: Sydney
Message 3 of 7 (1,657 Views)

Re: Win7 update not working after adding 750GB HD

The instructions on that page did not work for me.


I was able to fix this by installing Windows 7 SP1 update using the stand-alone ISO image installer. Do not use the downloadable installer, instead download the ISO file (about 2GB), burn it to a DVD and install from the DVD.

Community Moderator
Posts: 5,924
Registered: ‎01-13-2008
Location: US
Message 4 of 7 (1,652 Views)

Re: Win7 update not working after adding 750GB HD

[ Edited ]

Hi ziggyboy,


I'm glad you got it working.


Do you mind sharing what didn't work?  I'd like to correct or enhance that page if I can.


In my case, it was necessary to install SP1 (or the hotfix) _and_ the intel driver.  Perhaps that wasn't clear or maybe I just had a special case.


[edit] I just saw your comment on my blog post.  Thanks for adding your experience.  It all helps - I hope.




The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.

The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored. ... GeezBlog


Communities:    English English   Deutsche Deutsche    Español Español    Português Português    ru.gif Русскоязычное

Punch Card
Posts: 31
Registered: ‎03-21-2010
Location: Sydney
Message 5 of 7 (1,648 Views)

Re: Win7 update not working after adding 750GB HD

[ Edited ]

I posted a comment on your page.

I tried installing various versions of the Intel RST drivers. It installs OK and if I click on the RST tool it detects my drive as an RST drive (even stating 4K physical, 512 logical) but Windows Update and any other update still didn't work. I even tried updating to SP1 using the downloadable file but it fails.

I wasn't hopeful but thought I'd try anyway.... downloaded the 2GB SP1 update ISO file, burned to a DVD and installed from there. Install magically completed and Windows Update worked after the reboot.

You mentioned in your page that you've got SP1 already installed, the Lenovo restore disks didn' maybe that's why it didn't work for me.


Also... I think you'd need SP1 and the Intel RST drive. I already had it installed before updating to SP1 so Update worked straight away.

Posts: 183
Registered: ‎12-11-2009
Location: US
Message 6 of 7 (1,566 Views)

Re: Win7 update not working after adding 750GB HD

I had a similar problem to ziggyboy, found that, starting with the OEM Win7 installation on my new 750 GB HDD installed in a Lenovo R500, I had to (1) install Intel Rapid Storage Tech  (2) Install SP1 (using the file on the Microsoft DVD, I didn't download it).

    Then & only then did Windows Update work.  I tried installing SP1 before Intel Rapid Storage Tech & failed.

     I left messages to this effect on geezblog & on the forum for Lenovo R models.

What's DOS?
Posts: 1
Registered: ‎05-24-2013
Location: Mt. Pleasant, SC
Message 7 of 7 (1,041 Views)

Re: Win7 update not working after adding 750GB HD

[ Edited ]

For what it's worth, I ran into this problem after upgrading (via a Norton Ghost 11 cloning operation) a 512GB drive in a Thinkpad W500 to a 1TB drive, which (as I came to realize in retrospect) also amounted to upgrading from a 512-byte block size to a 4K ("Advanced Format") block size.  Windows Update, Windows Search, Windows Defender, and some other features on my Win7-64bit system were newly failing in various manners after the otherwise unremarkable disk upgrade.  Even IE and Flash were showing weird behaviors such as failing to respond to clicks on options in pop-ups such as the Yes/No options in the Set Edition pop-up at and the Open/Save/Cancel options after downloading a file in IE.  All other methods described on the net for fixing a broken Windows Update failed to help (e.g., running MS Fixit, turning Windows Update auto-run frequency from Auto to Never and then back to Auto, deleting the %windir%\SoftwareDistribution\Logs directory, etc. etc. etc.), but then I found some articles (including MS KB982018) referencing this curious interaction between disk upgrades and Windows Update, and in the end the one and only one thing I needed to do was upgrade my disk driver from the Intel Matrix Storage driver (version 8.9.0.something) originally supplied with my W500 to the latest Intel Rapid Storage Technology driver.  First I did a backup and created a restore point just to be safe, then ran the iata_enu.exe file (Intel RST driver package from December 3, 2012, see that I had downloaded from Intel's support site, rebooted, and voila, everything began working fine.  There was an unusually intense amount of disk activity for about 5-10 minutes after I logged in the first time after the reboot (I'm guessing it was all the previously broken Win7 features "fixing themselves"), such that at times it almost appeared the system had become unresponsive, but after all of that initial disk activity settled down, everything worked fine and all the prior weirdness I had seen following the disk upgrade had resolved.


-- Larry Afrin

   Medical University of South Carolina


P.S.  In retrospect, I guess I could have also installed the 3/22/13 ( or the very latest (5/2/13, RST package, but hey, did the trick for me, so unless I find some other bit of goofiness down the road, I'm not sure I see a point in upgrading again.


Moderator Note; s/n edited for member's own protection

Top kudoed Authors
User Kudos Count