English Community

Software and Operating SystemWindows 8.1, 8, 7, Vista and XP Discussions
All Forum Topics
Options

1 Posts

06-11-2010

Atlanta

3 Signins

19 Page Views

  • Posts: 1
  • Registered: ‎06-11-2010
  • Location: Atlanta
  • Views: 19
  • Message 11 of 15

Re: Windows 7 - T400 - 2504 Docking Station

2010-06-11, 17:25 PM

I had this same problem and it baffled me but I found the solution. This worked for me. It appears as though the USB drivers got corrupted being placed on the dock the first time. I dont think I let the docking station finish installing the device drivers before I pulled it off... Anyway...

 

  1. Go to the Device Manager.
  2. Make sure you are using your touchpad because the mouse temporarily wont work when you do this.
  3. unplug all USB devices.
  4. Under Universal Serial Bus Controllers right click on each of the devices that say " Intel(R) ICH9 Family USB Universal Host Controller" and select uninstall.
  5. Restart your computer while it is on the docking station and let it automatically reinstall all the USB controllers and voila.. It Worked for me!
Reply
Options

1 Posts

06-23-2010

Lafayette IN

6 Signins

15 Page Views

  • Posts: 1
  • Registered: ‎06-23-2010
  • Location: Lafayette IN
  • Views: 15
  • Message 12 of 15

Re: Windows 7 - T400 - 2504 Docking Station

2010-06-23, 15:22 PM

My serial port for my docking station is not working. It requires drivers, does anyone know where I can find these drivers

Reply
Options

3 Posts

08-02-2010

California

3 Signins

77 Page Views

  • Posts: 3
  • Registered: ‎08-02-2010
  • Location: California
  • Views: 77
  • Message 13 of 15

Re: Windows 7 - T400 - 2504 Docking Station

2010-08-02, 22:26 PM

Thank You!

Reply
Options

1 Posts

10-25-2011

UK

3 Signins

12 Page Views

  • Posts: 1
  • Registered: ‎10-25-2011
  • Location: UK
  • Views: 12
  • Message 14 of 15

Re: Windows 7 - T400 - 2504 Docking Station

2011-10-25, 15:59 PM

I had the same problem with a T500 docking station, when upgraded to Windows 7 , USB ports on the docking station were disabled. Used solution suggested by nerdherd and now all seems ok.

 

Thank You!!!!!

Reply
Options

3 Posts

01-06-2012

Germany

24 Signins

62 Page Views

  • Posts: 3
  • Registered: ‎01-06-2012
  • Location: Germany
  • Views: 62
  • Message 15 of 15

Re: Windows 7 - T400 - 2504 Docking Station

2012-01-06, 18:25 PM

Hi NerdHerd!

The discussion has apparently ended - yet the problem still persists, at least on the Thinkpad T400 with Advanced MiniDock 2504 I just bought second hand. I Installed all available updates (both MS for W7-SP1, 64bit, as well as Lenovo's), flashed the BIOS and everything.

Monitor, LAN and power passthrough (almost) work fine, though no USB support whatsoever. Tried your trick - in vain. Next to the USB issue, however, the docking station (DS) shows a few other issues: Pressing the DS *power* button won't do anything at all. Pressing the eject request button leads to the blinking state - and eventually falls back to stable lighting! Likewise, the FN+F9 combination won't initiate anything. Did the trick of "cold initialization" (= power off/shutdown) of both components I read about somewhere else, too.

Of course there's this dimension that it's a leasing/second hand model (both parts: notebook and DS) and I had to install almost all of the Lenovo/ThinkVantage stuff on my own following the W7 installation. And yet, as frequent as this problem apparently popped up in the past: Should this really be the reason for the malfunction?!? Apparently there's a known issue when it comes to the OS with lots of users reporting their first related problems only after upgrading to various W7 releases ...

Any news? Thank you!

Ralph

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete