Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Software and Operating SystemWindows 8.1, 8, 7, Vista and XP Discussions
All Forum Topics
Options

8 Posts

06-09-2009

Japan

32 Signins

114 Page Views

  • Posts: 8
  • Registered: ‎06-09-2009
  • Location: Japan
  • Views: 114
  • Message 1 of 7

X301 Windows 7 RC1 - Bluetooth defaults to "off"

2009-06-09, 10:04 AM
I've searched for hours on this problem, but can't find an answer (or anyone who has this particular problem). The Bluetooth on my X301 defaults to powered down upon both startup and resume from sleep. I have no choice but to manually reenable it by using the FN+F5 combination, which is a big annoyance for someone who uses a Bluetooth mouse as the primary input device. I have the latest Lenovo Windows 7 Power Managment drivers, Hotkey drivers, and System Utility drivers installed, but there doesn't appear to be a way to force the Bluetooth to stay on. I also set the Bluetooth device in the Device Manager to disallow applications to turn the device off, but it definitely doesn't stop the system from defaulting the Bluetooth device to off. Interestingly, I had Windows previously installed, and never had this problem, but this problem now exists with the exact same drivers installed. I'd be glad to hear if anyone has had this problem or if there are any ideas...
Reply
Answer
Options

8 Posts

06-09-2009

Japan

32 Signins

114 Page Views

  • Posts: 8
  • Registered: ‎06-09-2009
  • Location: Japan
  • Views: 114

Re: X301 Windows 7 RC1 - Bluetooth defaults to "off"

2009-08-11, 5:32 AM
Well, the problem is fixed. It can be confirmed as a hardware problem. After my web camera stopped working, I sent my X301 in for repair. They replaced not only the cable running to the camera, but the system board as well. Upon rebooting, the Bluetooth is once again turned on by default. Actually, I'm a bit surprised that this was a hardware problem, but that would explain why nobody else has had this problem.
Reply

Replies(6)
Options

8 Posts

06-09-2009

Japan

32 Signins

114 Page Views

  • Posts: 8
  • Registered: ‎06-09-2009
  • Location: Japan
  • Views: 114
  • Message 2 of 7

Re: X301 Windows 7 RC1 - Bluetooth defaults to "off"

2009-06-11, 5:57 AM
Does nobody else have this problem? As an update, I plugged in an extra 64GB disk (with a previous copy of Windows 7 already installed), and Bluetooth worked automatically. That is, until I installed the Windows 7 Lenovo Power Management Driver. After that was installed, the Bluetooth again defaulted to "off" every time the machine is rebooted or loaded from suspend. Uninstalling the Power Management driver and uninstalling the "Thinkpad PM Driver" (with deleting the files) does not solve the problem, so it's clear that something is replacing the default settings irreversibly.
Reply
Answer
Options

8 Posts

06-09-2009

Japan

32 Signins

114 Page Views

  • Posts: 8
  • Registered: ‎06-09-2009
  • Location: Japan
  • Views: 114
  • Message 3 of 7

Re: X301 Windows 7 RC1 - Bluetooth defaults to "off"

2009-08-11, 5:32 AM
Well, the problem is fixed. It can be confirmed as a hardware problem. After my web camera stopped working, I sent my X301 in for repair. They replaced not only the cable running to the camera, but the system board as well. Upon rebooting, the Bluetooth is once again turned on by default. Actually, I'm a bit surprised that this was a hardware problem, but that would explain why nobody else has had this problem.

0 person found this solution to be helpful.

This helped me too

Reply
Options

10 Posts

08-19-2008

New York

34 Signins

179 Page Views

  • Posts: 10
  • Registered: ‎08-19-2008
  • Location: New York
  • Views: 179
  • Message 4 of 7

Re: X301 Windows 7 RC1 - Bluetooth defaults to "off"

2009-11-25, 23:21 PM

I have the same problem and I can confirm without any doubt that inability to automatically turn on BlueTooth after resume is definitely not a hardware problem.

 

This started to happen on my ThinkPad T61 only after I re-formatted it and installed Windows 7 from scratch. BlueTooth worked perfectly with factory-installed Vista and continued to work after Vista-to-7 upgrade. I also briefly had Ubuntu Linux on this notebook, which also had no issues with Bluetooth.

 

It is only after re-installed clean Windows 7, BlueTooth now defaults to "off". I tried all Lenovo updates, drivers and ThinkVantage tools current as of November 2009 - nothing helps.

 

I am sure there is some simple switch buried somewhere in Windows Registry which controls this. Obviously, IBM or Lenovo engineers do know how to make Bluetooth turn on by default, because it works in factory-formatted machines. If any of you Lenovo people read this, please help us.

 

 

 

Reply
Options

1 Posts

01-09-2009

Rome, Italy

4 Signins

49 Page Views

  • Posts: 1
  • Registered: ‎01-09-2009
  • Location: Rome, Italy
  • Views: 49
  • Message 5 of 7

Re: X301 Windows 7 RC1 - Bluetooth defaults to "off"

2009-11-26, 16:01 PM

Hi,

 

I'm having the same issue on different ThinkPad laptops (X301, R500), where my company technicians have installed W7.

Before upgrading to 7, bluetooth worked perfectly on both XP and Vista (and Ubuntu on X301).

I cannot even find bluetooth listed among hardware peripherals.

 

If someone found a solution, that would be more than welcome. :smileyhappy:

 

Regards

Reply
Options

1 Posts

09-17-2010

wyoming

6 Signins

18 Page Views

  • Posts: 1
  • Registered: ‎09-17-2010
  • Location: wyoming
  • Views: 18
  • Message 6 of 7

Re: X301 Windows 7 RC1 - Bluetooth defaults to "off"

2010-09-17, 0:29 AM

I was having the same problem... fn+F5 worked fine

Reply
Options

3 Posts

10-16-2010

Phoenix

8 Signins

41 Page Views

  • Posts: 3
  • Registered: ‎10-16-2010
  • Location: Phoenix
  • Views: 41
  • Message 7 of 7

Re: X301 Windows 7 RC1 - Bluetooth defaults to "off"

2010-10-16, 6:16 AM

It's kind of sad that Lenovo hasn't responded to this thread since this is kind of easy to fix.  I have the same problem, only sometimes, on my x301 running windows 7 ultimate 64 bit.

 

Here's what I did to get around having to manually enable bluetooth each time:

 

 

Create a batch script in your startup that runs the below command:

C:\"Program Files"\Lenovo\HOTKEY\TpFnF5.exe /BTON

 

here's a step by step:

1) open notepad

 

2) copy and past the below into your notepad window:

C:\"Program Files"\Lenovo\HOTKEY\TpFnF5.exe /BTON

 

3) in notepad, do file -> save as

 

4)  in the "Save as type" drop down list, select all files

 

5)  save the file with the name BTON.bat on your desktop

 

6)  close notepad

 

7)  right click on the taskbar, and select show desktop

 

8)  find BTON.bat on your  desktop and drag it to the start mentu, startup folder

 

Bluetooth will now turn on at startup.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms