cancel
Showing results for 
Search instead for 
Did you mean: 
Lenovo Staff
Views: 2,356

Question

WMP worked one day and not the next. I click on the icon and get

"The file wmploc.dll has a version number of 11.0.6000.6349 where 11.0.6000.6344 was expected. Windows Media Player is not installed properly and must be reinstalled. Do you want to install the Player from Microsoft Web site?"

So I install it from the website after validation and it tells me the following:

"There is a more recent version of Windows Media Player (11.0.6000.6349) already installed on your computer. It is not possible to use and older installation package (11.0.5721.5146) to install files or to repair your current version of the player."

  I also tried doing a System Restore to an earlier date but it could not help either.

Answer

The following registry edit is known to resolve this issue:

REGISTRY DISCLAIMER

Modifying REGISTRY settings incorrectly can cause serious problems that may prevent your computer from booting properly. Microsoft cannot guarantee that any problems resulting from the configuring of REGISTRY settings can be solved. Modifications of these settings are at your own risk.

 

Steps:

  1. Click on the Start Orb and type REGEDIT in the Search Bar and hit Enter
  2. Click Continue of prompted by UAC
  3. Right Click the Computer Icon and Left Click Export to backup a copy of your registry, save this in a safe place
  4. Navigate to the following folder and delete these entries by right clicking the values in the right pane and clicking delete:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\Setup\Installed Versions\wmp.dll
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\Setup\Installed Versions\wmploc.dll
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\Setup\Installed Versions\wmplayer.exe

  5. Reboot your machine

Was this information helpful?

Contributors