cancel
Showing results for 
Search instead for 
Did you mean: 
Views: 11,314

 

 

While the Lenovo Companion app is included as part of many Lenovo systems that shipped with Windows 8 or 8.1 preloaded, some customers may have upgraded Windows to a different version, performed a clean install, or upgraded an older system to Windows 8 and wish to install the Windows Companion application.

 

Some customers may have encountered difficulty locating this application in the Windows store.  

 

Here is the deep link that will work for Lenovo users on Win 8 and 8.1.   This deep link will take them directly to the Windows Store to download Companion:

 

ms-windows-storeSmiley TongueDP?PFN=E046963F.LenovoCompanion_k1h2ywk1493x8

 

There is also this browser link that can be provided for Lenovo users to learn about Companion (whether they are on a Win 8/8.1 system or not)  http://apps.microsoft.com/windows/en-us/app/lenovo-companion/60d82dc7-9037-4295-90e2-1dff4293995a If they are a Win 7 they will be prompted to upgrade to Win 8.1. If you are on a Win 8/8.1 system and use this browser link, you will automatically be redirected to the  Windows Store to download Companion. 

Was this information helpful?

Comments
alan002

I tried reinstalling Companion about a month ago.  Since the I get the following error message 5 or 6 times a day.

"Installation Failure: Windows failed to install the following update with error 0x80070003: E046963F.LenovoCompanion."

 

Does anyone know how to fix this problem?  I am open to either option at this point.

1. Unstall Companion - which I cannot do since the installation is still pending.

2 Complete the installation.

 

Mightymouse_22

Hi I having trying to fix this problem about Companion for about 6 months now with no results. When I do find the program available to download I get a message saying to go to Microsoft store, which I have done several times.  It does not work!  When I updated to Windows 10 it worked perfectly for a bout a year or more.  I am running a ThinkCentre 3 in 1. I am running a z93 all-in one.

It is very fustrating especially when it worked fine before.  Does anyone have a solution that they would like to share?

 

Please let me know.

 

Frank

Contributors