Showing results for 
Search instead for 
Did you mean: 
Paper Tape
Posts: 1
Registered: ‎02-27-2017
Location: PL
Views: 2,228
Message 1 of 3

[Lenovo IdeaCentre 300-20ISH] Windows 7 Pro x64 installation problem.

When I try to instal Windows 7 Pro x64 it stuck at 1st screen with language selection (language selection screen), I'm not sure if my keybord and mouse doesn't work (it works fine in BIOS) or if PC crashes and I can't do anything.
Num Lock is on but I can't turn it off, same with CAPS Lock and so on.
I tried few copies of Windows 7 and tried boot from DvD or Pendrive with same problem ...

My PC is Lenovo IdeaCentre 300-20ISH bought at (polish shop) IdeaCentre 300-20ISH at
Here are some settings about boot and USB in my BIOS:
Boot Options
USB Settings

Keyboard and muse are plugged into port USB 2.0 (tried USB 3.0 but same **bleep**).

I'm waiting for any suggestions that might help!


Community SeniorMod
Community SeniorMod
Posts: 3,066
Registered: ‎12-31-2011
Location: US
Views: 2,151
Message 2 of 3

Re: [Lenovo IdeaCentre 300-20ISH] Windows 7 Pro x64 installation problem.

Win 7 doesn't have USB drivers for Intel Skylake, and they must be injected into the install media.   There's several tools to do that, Google for them, and use Windows forums if more information is needed. 

I do not work for Lenovo. I do not respond to Private Messages for help, your questions should be posted in the appropriate forum where the information exchange may help others. If I helped you, click the 'Kudos' button, if solved, the 'Accept as Solution'.
Paper Tape
Posts: 3
Registered: ‎10-01-2018
Location: NP
Views: 412
Message 3 of 3

Re: [Lenovo IdeaCentre 300-20ISH] Windows 7 Pro x64 installation problem.

mine is lenovo ideapad 300 15is, 

bios update resulted numlock turn on and off every few seconds with a bleep. what is the solution or say how do i downgrade tha bios???????????

Check out current deals!

Shop current deals

Top Kudoed Authors