Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Software and Operating SystemWindows 8.1, 8, 7, Vista and XP Discussions Knowledge Base

Failure configuring Windows Updates - Windows 8

Symptoms

Microsoft Windows 8 Updates may fail to apply

 

After downloading Windows Updates and rebooting, the system will attempt to apply the updates and fail.  The error message, “Failure configuring Windows updates”, will display at 15 percent.  The system will attempt to apply the updates three times and then the system will revert the changes and reboot back into Microsoft Windows 8.

Diagnosis

The above symptom is associated with, but not limited to, the following Lenovo System families running Nitro Pro 7.4.1.24 PDF, or prior version under Windows 8.

 

ThinkCentre
ThinkStation
ThinkPad
Idea Tablet
IdeaPad
IdeaCentre

Solution

An update from Nitro Pro 7 PDF is available by following the steps below:

 

1. Launch Nitro Pro 7.4.1.24 PDF.
2. After a few seconds, an Update Manager pop-up will display that a new version is available.

 

nitro update.png


3. Click "Install Update" and follow the on-screen prompts.
4. The system will upgrade to version 7.5.0.29 which corrects this issue.

 

NOTE: A patch will be available via System Update soon to correct the issue without upgrading - this would be delivered to Think system users.  Idea System users might need to manually update via the steps above.

 

An interrim work around proceedure would be to disable the Nalpeiron Licensing Service in Services by following the steps below:

 

1. Press Windows key + X.
2. Click on Run.
3. Type “services.msc” in the Open box and click OK.
4. In the right pane of the Services window, scroll down and locate “Nalpeiron Licensing Service”.
5. Right click on “Nalpeiron Licensing Service”, choose “Stop”, and then close the Services window.
6. Open Windows Updates and Install updates. When prompted, reboot the system. Updates should then apply normally.

 

NOTE: These steps will need to be followed whenever Windows Updates are available until the patch or the new version is applied to the system.

 

Was this information helpful?

Yes No

Comments

tynecub On 2013-05-06, 11:41 AM

I have the same problem on my C340 which I got in December.  I cannot find the above but have been having the faliure of the installs and the system reverts back to one of the last settings.

 

You would have thought there would have been a simple solution to a problem as I am not a great one for IT but do try my best  :)

MelOrecklin On 2014-04-30, 21:48 PM

Nitro Pro came with my IdeaPad Flex 15.  Subsequently, I reinstalled Windows 81 from a boot image which deleted the Nitro Pro (and other software).

 

A copy of Nitro Pro is not on the D: Partion.  How can I obtain a legal copy?

jaysonuk On 2014-05-30, 18:32 PM

I bought a used Z585, revert using onekey gave me a windows 8 as shipped from factory November 2012. let windows find updates... Almost 1gb of updates! Tried 3 times to install and came up against this problem. Stopped the Nalpeiron service and got them to install but then many other problems such as couldn't access all of PC settings. So armed with the knowledge and experience of others here this is what I did, it may work for you:

 

start with the revert to the basic Windows 8 installation.

 

Let the anti virus update to latest version and updates (Macafee trial in my case)

 

go to windows update and download but choose to install yourself all the updates windows finds, ignore looking for specific KB numbers, you want them all eventually.

 

Download to desktop the Macafee (or whatever anti virus you have) complete removal tool

 

Disconnect from the internet wifi (use airplane mode) or unplug ethernet cable.

 

Uninstall Nitro Pro if you have it and disable the Nalpeiron service.

 

Uninstall Macafee or anti virus and then run the complete removal tool

 

Re boot (which you will be prompted to do anyway)

 

What you want is your computer not connected to internet with no anti virus running and no known programs or services such as Nitro pro which are known to be troublesome. And all the windows updates ready to install

 

Then go to the updates and select 10 or maybe 15 at a time and install them in blocks following the prompts to restart etc every time. In my case I had 95 updates altogether. But each block installed OK first time and eventually I had my updated Windows 8

 

Dont forget the first job when you have successfuly installed them is get an Anti virus prog. I decided to let Windows Firewall and Defender take over until I was sure everything was OK

 

You may have success just by updating Nitro or disabling antivirus while installing but I took the long way and it worked for me. I was then offered update to 8.1 which went ok also.

 

I wasted 2 frustrating days messing around with this problem and only too pleased to have found a way to work it in the end, so the reason I'm posting is maybe it will give others a few ideas if they are stuck.

palash1898 On 2014-08-06, 23:23 PM

I have recently bought a Lenovo tablet IA Z2760 (windodws 8).  After two days of using,  It started auto updating windows and restarts, and then Gives a Masage " failure configuring updates reverting changes Do not turn off..... and then stuck into the loop...! Any one hep me.. how can I get out of this...

JayDedhiya On 2014-08-19, 16:48 PM

Hi,

 

I have AMD A10, i just got it 2 days back & I am facing the similar problem like the above user.

 

It started auto updating windows and restarts, and then Gives a Masage " failure configuring updates reverting changes Do not turn off..... and then stuck into the loop...Any SOLUTIONS?

 

Thanks & Regards,

Jay

NateS On 2014-09-02, 20:57 PM
marcus34 On 2014-11-28, 22:45 PM

 

this might help with this issue :

 

http://support2.microsoft.com/gp/windows-update-issues

benford On 2015-06-01, 11:30 AM

I cannot get microsoft updates. The PC warning note asks me to restart it. This does not work and I return to the statement that the update can't be used since "...the update service is not running..." I don't know what this means. Cane anyone advise me how to get the update service to run? It is now 60 days out-of-date.

hank12 On 2017-10-30, 12:55 PM

can anyone help? firstly I am not technicaly minded, I have a laptop  b50-30 80es,it was running very slow and decided to refresh it,it now goes realy fast but it has 185 updates backed up,I have tried loading them(for hours)but they just wont load.

any easy suggestions please.

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Delete