Support in other languages: 
Showing results for 
Search instead for 
Do you mean 

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team

Community Spotlight

Visit the Community Blog

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
Fanfold Paper
Posts: 10
Registered: ‎01-13-2012
Location: United States
0 Kudos

Problem with Windows 8 on T520 mSATA

Short version: Installed Windows 8 on the mSATA (with Windows 7 on the main SSD).  When I boot to the mSATA, Windows 8 opens/works fine. When I shut down then power up again, I cannot get into any BIOS setup screens to reset the boot order...it just keeps booting to Windows 8. I need to pull the mSATA drive to boot to Win7.

 

Long version: Added a Kingston mSATA to install Windows 8. Pulled the Intel SSD to do the install and everything went fine. Put the SSD back in.  If I boot to Windows 7 and then shut down, when I power back up I can use the ThinkVantage button to get into the BIOS setup, or the f12 key to get to the boot order screen. But, if I change the boot order to get the machine to boot to Windows 8 on the mSATA, then do 'Power - Shut down' from Windows 8, when I power up again, neither the ThinkVantage or the f12 key do anything, and the machine boots to the mSATA.

 

When I power up after being in Win7, the black 'Thinkpad' screen includes the line under the Thinkpad logo that says "To interrupt normal setup...Push the blue ThinkVantage button." But when I boot up after being in Windows 8 on the mSATA, the black Thinkpad screen does not include that line.

 

I have BIOS version 8AET56WW (1.36).  I have installed the UltraNav driver on Windows 8.

 

Any suggestions appreciated...pulling the mSATA drive each time is not fun.

Fanfold Paper
Posts: 10
Registered: ‎01-13-2012
Location: United States
0 Kudos

Re: Problem with Windows 8 on T520 mSATA

Silly me...should have thought of this simple workaround:

 

Set the SSD (with Windows 7) ahead of the mSATA (Windows 8) in the boot order so it always defaults to the SSD, even after a shutdown from Windows 8. Doing that makes f12 available to select a boot drive every time the T520 powers up.  (It also enables the ThinkVantage button to open the BIOS setup. If f12 is not working on your machine, change the setting in the BIOS.) That solved the booting issue.

 

But, every time I boot to the mSATA, then shut down and boot to the SSD, CHKDSK runs.  So, I changed the BootExecute setting in the registry to disable autocheck of the C drive.

Paper Tape
Posts: 3
Registered: ‎10-09-2012
Location: Schweiz
0 Kudos

Hi. Have the very same Problem!   How Could you change th...

Hi. Have the very same Problem!

 

How Could you change the Bootorder? Did you have to take out the msata?

 

Greatz Melody