English Community

Software and Operating SystemWindows 8.1, 8, 7, Vista and XP Discussions
All Forum Topics
Options

215 Posts

01-09-2013

China

270 Signins

3288 Page Views

  • Posts: 215
  • Registered: ‎01-09-2013
  • Location: China
  • Views: 3288
  • Message 1 of 36

SOLVED! WAN Miniport #2 yellow exclamation mark in Device Manager

2013-03-06, 6:11 AM

This topic is to collect some information, if someone has any, about the WAN miniport #2 virtual device in Windows 8

 

There are many complaints but so far there has been no resolution to the problem.

 

Just as a heads up, since it windows doesn't allow you to uninstall it I tried to delete it through registry and lost the ability to see any networks while the hardware itself was recognized and working.

 

EDIT: The **bleep** thing is out! Had to call excorcist in:P jk..

 

Anyway, I want kudos for this, now.

 

Found the solution following this link: http://oyam.ca/blog/2011/11/windows-miniports.html

 

FIne gentleman who runs it had a tip waiting for us, summary is below:

 

To do this, DO NOT edit the registries. There are number of other registry keys that depend on the miniports being present, and it is super easy to completely break the network stack, to a point where the base network card driver won’t work. (If you did this already, let’s hope your system has restore points — you can restore to previous snapshot and try doing it the non-registry way outlined there.) When doing this, take a note of the miniports that you are removing, you’ll need to know this later when reinstalling.

So, to remove each non-working miniport, do the following:

    Right click on the non-working miniport, choose “Update Driver”.
    Choose “Browse my computer”.
    In the next window, choose “Let me pick driver from a list”.
    Uncheck “Show compatible hardware”. From the “Manufacturer” list, choose “Microsoft”, and from the “Network Adapter” list, choose “MAC Bridge Miniport”. (It can be any device the user is allowed to uninstall.) *here I chose the first entry, Generic Broadband device driver.
    Back in the device manager, delete the device that just turned into the “MAC Bridge Miniport” device.

Once done removing the bad miniports, reboot. Don’t skip this, it’s important. Otherwise there is a change things will go bad again.

 

And it works!!! Rebooted two times just to be sure.

Solved! See the solution
Reply
Options

1 Posts

03-28-2013

Hawaii

6 Signins

40 Page Views

  • Posts: 1
  • Registered: ‎03-28-2013
  • Location: Hawaii
  • Views: 40
  • Message 2 of 36

Re: SOLVED! WAN Miniport #2 yellow exclamation mark in Device Manager

2013-03-28, 5:58 AM

Thanks!  The fix you've cited works!

0 person found this solution to be helpful.

This helped me too

Reply
Options

4 Posts

05-20-2013

New Zealand

7 Signins

41 Page Views

  • Posts: 4
  • Registered: ‎05-20-2013
  • Location: New Zealand
  • Views: 41
  • Message 3 of 36

Kudos

2013-05-20, 10:59 AM

I tip my hat to you sir. Excellent Google research.

 

It's issues like this to makes me glad I don't deal with Windows on a daily basis.

Reply
Options

5 Posts

05-04-2013

Germany

4 Signins

63 Page Views

  • Posts: 5
  • Registered: ‎05-04-2013
  • Location: Germany
  • Views: 63
  • Message 4 of 36

Re: SOLVED! WAN Miniport #2 yellow exclamation mark in Device Manager

2013-05-20, 11:43 AM

Thank you very much for this working fix !!!!!!!! :smileyvery-happy:

Reply
Options

10 Posts

01-31-2013

United States

24 Signins

150 Page Views

  • Posts: 10
  • Registered: ‎01-31-2013
  • Location: United States
  • Views: 150
  • Message 5 of 36

Re: SOLVED! WAN Miniport #2 yellow exclamation mark in Device Manager

2013-05-20, 18:29 PM

Beautiful! Thanks!

Reply
Options

7 Posts

05-02-2013

USA

9 Signins

80 Page Views

  • Posts: 7
  • Registered: ‎05-02-2013
  • Location: USA
  • Views: 80
  • Message 6 of 36

Re: SOLVED! WAN Miniport #2 yellow exclamation mark in Device Manager

2013-05-21, 19:45 PM
Brilliant, thanks!
Reply
Options

1 Posts

05-22-2013

Philippines

1 Signins

11 Page Views

  • Posts: 1
  • Registered: ‎05-22-2013
  • Location: Philippines
  • Views: 11
  • Message 7 of 36

Re: SOLVED! WAN Miniport #2 yellow exclamation mark in Device Manager

2013-05-22, 7:01 AM

dude ! REALLY ! THANK YOU ! you helped a lot !

Reply
Options

3 Posts

05-24-2013

New York

3 Signins

31 Page Views

  • Posts: 3
  • Registered: ‎05-24-2013
  • Location: New York
  • Views: 31
  • Message 8 of 36

Re: SOLVED! WAN Miniport #2 yellow exclamation mark in Device Manager

2013-05-24, 13:02 PM

I got as far as the step  where you suggest choosing “MAC Bridge Miniport”...that option doesn't exist for me (x230, Win 8)??  Should I just ignore and go ahead and choose generic bband driver??

Reply
Options

7 Posts

05-02-2013

USA

9 Signins

80 Page Views

  • Posts: 7
  • Registered: ‎05-02-2013
  • Location: USA
  • Views: 80
  • Message 9 of 36

Re: SOLVED! WAN Miniport #2 yellow exclamation mark in Device Manager

2013-05-24, 17:14 PM
Yep, that's what I did. I think what selected wasn't even the right driver for that, but worked nonetheless.
Reply
Options

3 Posts

05-31-2013

Sweden

10 Signins

24 Page Views

  • Posts: 3
  • Registered: ‎05-31-2013
  • Location: Sweden
  • Views: 24
  • Message 10 of 36

Re: SOLVED! WAN Miniport #2 yellow exclamation mark in Device Manager

2013-06-02, 8:42 AM

I'm glad you've found a solution, however, when I go inte the Network Adapter List, I do not have the option of choosing "MAC Bridge Miniport" there is no such miniport. Does anyone have an alternative I can use? Or is there some other way to Solve this problem? I'm using a Lenovo ThinkPad Edge E530.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete