cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
msmotr
Paper Tape
Posts: 2
Registered: ‎01-02-2018
Location: US
Views: 824
Message 1 of 2

Ideapad Flex 4 Keyboard won't disable when in tablet mode

BRAND new (box still sitting beside me) Lenovo Flex 4,  Windows 10.  Tablet mode doesn't disable the keyboard and touchpad, which makes holding/carrying/using it in tablet mode impossible, as any contact with the "back" of the tablet causes unwanted input from the keyboard/touchpad.  So much for 2-in-1 functionality, right?

 

I've seen that this is (and has been for years) a common issue, but can't seem to find a solution that is applicable to my machine, here or elsewhere.    The things I'm supposed to toggle in settings ("Make Windows more Touch-friendly") don't exist, or the applications I'm supposed to download (Lenovo Harmony and Lenovo Settings)  are 3-4 years old and have been replaced with "Lenovo Vantage", which has no place in it to solve the problem.

I'm at a stuck point, and am strongly considering returning the laptop, as one of it's prime selling points is functionally unusable.
Help?

msmotr
Paper Tape
Posts: 2
Registered: ‎01-02-2018
Location: US
Views: 779
Message 2 of 2

Re: Ideapad Flex 4 Keyboard won't disable when in tablet mode

Ok, solved my own problem. Some reading around the interwebs revealed that the problem was likely my YMV (Yoga Mode Control) driver.  Even though I completed all of the updates and my computer told me all drivers were current, that wasn't true.  

The driver that came pre-loaded on the machine may have been the most current version, but it apparently wasn't the CORRECT driver.  I had to download a new YMC driver (link below) from the Lenovo Support website.    It was quick and easy, and fixed the problem immediately.  Incidentally, it also fixed the Rotational Lock issue I was still trying to address, too.

https://support.lenovo.com/us/en/downloads/ds121689

Top Kudoed Authors