Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Gaming – Lenovo LegionY Gaming Accessories & Curved Gaming Monitors
All Forum Topics
Options

2 Posts

02-22-2021

Bulgaria

3 Signins

10 Page Views

  • Posts: 2
  • Registered: ‎02-22-2021
  • Location: Bulgaria
  • Views: 10
  • Message 1 of 3

Legion M600 mouse not registering clicks at 125hz poling rate

2021-02-22, 8:57 AM

When I use the receiver or when wired at 125 hz poling rate sometimes the mouse is not registering left or right clicks. I believe this is a software bug because it is not happening in BT mode or at 1000HZ. Also the mouse needs to be really close to the receiver to work properly , otherwise it feels sluggish and sometimes when you select text or drag a window it does not respond. I have logitech g603 mouse and it works perfectly at 3-4 meters from the receiver so its a weak one in the m600. I hope that with future updates things will become better because when it works properly its a good mouse.

Reply
Options

2278 Posts

04-23-2019

United States of America

527 Signins

19844 Page Views

  • Posts: 2278
  • Registered: ‎04-23-2019
  • Location: United States of America
  • Views: 19844
  • Message 2 of 3

Re:Legion M600 mouse not registering clicks at 125hz poling rate

2021-02-22, 9:57 AM

Hello @imladenov,

 

Welcome to the Community Forums.

 

Have you tried reinstalling the software for the mouse?
You can download it here: https://support.lenovo.com/us/en/accessories/acc500165-lenovo-legion-m600-wireless-gaming-mouse-overview-and-service-parts



Hope this helps.
Regards,
Jack_Lenovo1



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

2 Posts

02-22-2021

Bulgaria

3 Signins

10 Page Views

  • Posts: 2
  • Registered: ‎02-22-2021
  • Location: Bulgaria
  • Views: 10
  • Message 3 of 3

Re:Legion M600 mouse not registering clicks at 125hz poling rate

2021-02-22, 17:41 PM

Yes, already tried that. To me its a bug. No big deal for now but for the sake of battery saving it would be nice to have the 125hz mode working properly.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms