Showing results for 
Search instead for 
Did you mean: 
Views: 18,180


  • Typing on the halo keyboard produces different output.



The issue is that the physical keyboard of the Yoga Book is mapped to a different keyboard layout.



1. Swipe down the status bar and click the wrench icon to open the 'Settings' application. Or simply open the 'Settings' application.

2. Scroll down to the 'Personal' section, and open 'Languages & Input'.

3. Since it is the physical keyboard, we now click 'Physical Keyboard' to change its settings.
Here is were it gets a little bit confusing. I see the following options:
- Gboard - Multilingual typing
- TouchPal - TouchPal
- Show virtual keyboard
- Keyboard shortcuts helper


4. You want to choose 'TouchPal - TouchPal'.


5. Select the language or keyboard layout that matches your Yoga Book. If you need help determining the correct keyboard layout or language, post a picture of your Yoga Book's halo keyboard on the forums.


Windows 10 (1709)

1. Click the start button.

2. Click on the 'Settings' icon on the left slightly above the start button in the expanded start menu.

3. You should now see all tiles of the Windows settings. Choose 'Time & Language'.

4. Now you should see several sections. 'Country or region', 'Languages' or 'Related settings'. Choose 'Languages'.

5. Click the language you primarily use or all the languages you use.

6. When a language is clicked, it will slightly expand, and you will see a button labeled 'Options', click it.

7. In the 'Keyboards' section, add the keyboard layout of the 'Halo keyboard' of your Yoga Book.

8. In the 'Keyboards' section, remove every keyboard layout you don't use and don't have. This will prevent switching accidentally to a different keyboard layout.


Note: If you need help determining the keyboard layout of the 'Halo keyboard' on your Yoga Book, take a picture of the keyboard, and upload it to the forums, someone will come and help you.

Was this information helpful?


While this workaround to use virtual keyboard may look relief to Stuff, it is not to users on Android. 

1) Touchpal is painful slow even with features disabled.

2) Ctrl+Space is not switching Halo keyboards.

3) Where different keyboard layouts for Halo were available in Android 6, with Android 7.1.1 those are not working anymore, i.e. Latvian layout on SE keyboard.


Probably something more... Oh, yes.... Users do ask about Physical Halo keyboard, and saying to use virtual instead is if not insulting, then at least not the solution at all!


Help me determine which keyboard layout I have..I have the window version and used the directions posted above and still cant find the matching keyboard layout...halo keyboard.jpg


Hi, for English language it is look like you have American international keyboard layout, and because you have special symbols on the keyboard try to add localized layouts such as Spanish or Greek.