cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
hogejo
What's DOS?
Posts: 1
Registered: ‎01-17-2017
Location: IE
Views: 5,879
Message 11 of 16

Re: FIXED! Middle Click Functionality Disabled on Windows 10 upgrade . . . FIXED!!!!!!!

Anyone had any luck with the Elan driver/device? I have found the keys under

 

HKEY_USERS\S-1-5-21-3742862496-3192314997-3477395287-1001\SOFTWARE\Elantech\PointStick

 

But the keys are completely different. Furthermore, if I change the behaviour in Mouse -> Advanced Settings -> ThinkPad -> TrackPoint -> Middle button, nothing changes in Regedit.

 

I tried removing the driver, installing the Elan drivers and even got to a stage where it stopped working completely. Now I managed to get back to factory state, but it is VERY annoying, that this works out of the box on Linux, but it is still a nightmare on Windows.

 

So if anyone has an Elan version and knows how to fix this, I have a beer for you.

WubbGmbaa
Fanfold Paper
Posts: 8
Registered: ‎06-20-2016
Location: US
Views: 5,104
Message 12 of 16

Re: FIXED! Middle Click Functionality Disabled on Windows 10 upgrade . . . FIXED!!!!!!!

Figured I'd stick this here, since it might help someone -

 

My T420's trackpoint drivers just got updated, and the stupid trackpoint-scrolling was back.

 

Went through my registry, double-checking things, before I realized that they have FINALLY gone and added an option for classic scrolling in the mouse control panel, so we don't have to mess with registry editing anymore.

 

It's in Control Panel -> Mouse -> TrackPoint. Click "neither" in the middle box, then settings below it, set "scrolling type" to "smooth".

LarryM2
Serial Port
Posts: 32
Registered: ‎10-03-2015
Location: US
Views: 5,085
Message 13 of 16

Re: FIXED! Middle Click Functionality Disabled on Windows 10 upgrade . . . FIXED!!!!!!!

No, that does not fix the problem most users are concerned about. It makes it worse!

 

I agree that it's convenient to have settings in the Control Panel, but most of us WANT to be able to hold the blue button and use the Trackpoint to scroll pages up/down and left/right.  This has worked reasonably well (better with the Synaptics driver than the Microsoft driver, but worked with both) except for "Metro" apps. That is what we are hoping to see fixed.

 

Applications like the Edge browser, News, the new Start menu, and the tiled "applications picker" don't scroll with any driver we've found. That's still a problem. Your proposed solution does not help.

Larry M
Raleigh, NC USA
LarryM2
Serial Port
Posts: 32
Registered: ‎10-03-2015
Location: US
Views: 5,070
Message 14 of 16

Re: FIXED! Middle Click Functionality Disabled on Windows 10 upgrade . . . FIXED!!!!!!!

Finally got Metro apps to scroll for me today, after several previous attempts. Here's what I did:

When I first tried this months ago, it --almost-- worked perfectly. I got good scrolling in Chrome, even in exotic javascript apps like Gmail and Yahoo! mail. But I couldn't get it to scroll in Metro apps (Edge browser, start menu, tiled start page).

 

Today I absentmindedly installed the Windows mouse driver, which made things worse. In the course of restoring what I had, I installed a newer Synaptics driver:

Old version: 19.0.17.13 25 Aug 15, install path: drivers|WIN|UltraNAV|WDF|...

New version: 19.0.17.115 20 Sept 16, install path: drivers|WIN|UNAV|WDF\...

 

You do have to take some unnatural actions to make this driver install. Downloading it and attempting to install it will unpack it (to the path above) and then announce failure. To force the install, open the mouse in Device Manager, select Driver, Update Driver, Manually, then Have Disk, navigate to the path above, then select X86 (32-bit) or X64 (64-bit), as appropriate and continue the install. Reboot when asked.

 

This restored all the features I had and now scrolls in Metro Apps. Everything I wanted. Kind of quirky that they changed the path but it does let you keep both sets around in case you do need to revert.

 

As an aside, I turned on the System Restore feature today--I was surprised that it was off by default.

Larry M
Raleigh, NC USA
Insomniacno1
Punch Card
Posts: 46
Registered: ‎05-11-2010
Location: DK
Views: 3,203
Message 15 of 16

Re: FIXED! Middle Click Functionality Disabled on Windows 10 upgrade . . . FIXED!!!!!!!

Nice to see you got it working LarryM2 - good for youSmiley Happy

 

It would be nice if Lenovo would work with Microsoft to get the ALPS Touchpad to scroll in Metro(Modern UI) - So far, both Lenovo and Microsoft has ignored my requests(it's not only me asking, also people not owning thinkpad, but having ALPS touchpad) - The stupid thing is that the scroll works in Firefox, registry(YES, stupid), devicemanager, and others - but don't work in Edge, Store, Startmenu and the pages under Settings. I tried basically all the 8 series of drivers(and the re-branded Win10 drivers) and they disable the the touchpad completely after reboot - Stupid - they ought to come up with a message that they are not compatible, but that would mean that the driverprogrammers actually had a brain.

 

I even tried touchpad drivers from other laptop manufacturerers like DELL and Toshiba, to no use.

 

I tried getting Mark_Lenovo to help, by addressing the issue to him in the forum, but the moderator went in and changed the title - Thank you(sarcasm)! I tried going through the long list of Windows 10 approved Thinkpads to see if I could find a matching driver - of course not, all drivers are in either series 8 ALPS drivers or synaptics drivers.

 

So my X300 works with everything in windows 10 - EXCEPT scrolling in Metro(Modern) UI - Nice(sarcasm).

 

JBJ

 

Posts made by insomniac1971 is also mine.
Thinkpads: T61, R61, R500, T500, X300
LarryM2
Serial Port
Posts: 32
Registered: ‎10-03-2015
Location: US
Views: 2,819
Message 16 of 16

Re: FIXED! Middle Click Functionality Disabled on Windows 10 upgrade . . . FIXED!!!!!!!

If you read this posting on 7 December 2017 before I deleted it, disregard it. The fix above still works.

 

I received the latest Windows update and once again they gratuitously replaced the working Synaptics driver with a broken "PS/2 TrackPoint" driver. When I tried to reinstate the Synaptics driver it wouldn't install and I received a message to the effect that "Windows has determined that the PS/2 TrackPoint driver is the best choice."

 

I hadn't realized that in the driver replacement dialog, the message beginning

"-->Manually replace..." was actually clickable (not informational) and permitted overriding the Windows default. I followed the procedure above and all is back to normal (thankfully).

 

Still have to see if Microsoft also messed up the printer driver...

Larry M
Raleigh, NC USA
Top Kudoed Authors