cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
exto
Paper Tape
Posts: 3
Registered: ‎11-21-2011
Location: canada
Views: 2,552
Message 21 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

I agree fully.  It's unfortunate as I am happy with my Laptop otherwise, I have been running linux for the last 5 years on my previous machine, purchased the w520 and due to so many issues, I have been forced to switch back to windows :-(

 

I also will not be purchasing a Lenovo for my next computer. 

niriven
Punch Card
Posts: 21
Registered: ‎11-04-2011
Location: USA
Views: 2,539
Message 22 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

same problem. this is plagued with posts all over the net. i have ran linux for so many years on and off, bought a w520, and now i cannot even boot into any distrobution without vt-d disabled (which sucks). someone already posted this, but it seems like there is a good possbility it is a bios bug:

 

https://bugzilla.kernel.org/show_bug.cgi?id=43054

 

** TO LENOVO: Please provide feedback on this. We have bought this machines only to not be able to run our operating system of choice.

Mainframe_Snob
Punch Card
Posts: 50
Registered: ‎12-25-2009
Location: EU
Views: 2,528
Message 23 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

I see that I am not alone in lambasting lenovo for their shabby behaviour in this matter.

 

The W520 will also be my last machine from lenovo.

niriven
Punch Card
Posts: 21
Registered: ‎11-04-2011
Location: USA
Views: 2,328
Message 24 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

Did some more google digging and found out some information as to why this does not work. Seems as though the linux kernel devs are working on a workaround so it does not cause a boot hang, but this involves falling back to XAPIC. The CPU is X2APIC capable though, which means we do not get this feature on the W520 unless Lenovo fixes their BIOS. This just means slower virtualization on XAPIC. Disabling VT-D seems to workaround the issue (maybe not reporting X2APIC capable CPU?)

 

I posted here in general, so any comments will help to get them to fix the BIOS bug:

 

http://forums.lenovo.com/t5/W-Series-ThinkPad-Laptops/W520-BIOS-Bug-Please-fix-or-comment-Lenovo/td-...

Mainframe_Snob
Punch Card
Posts: 50
Registered: ‎12-25-2009
Location: EU
Views: 2,305
Message 25 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

I very much doubt whether lenovo have the inclination or competence to address this issue.

 

As I have stated before, never again lenovo.

 

There are enough threads in various forums, including this one, highlighting this problem.

 

 

Aubrey

niriven
Punch Card
Posts: 21
Registered: ‎11-04-2011
Location: USA
Views: 2,121
Message 26 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

Found what seems to be like a simple workaround to boot 64-bit, discrete graphics and VT-d. In the bios setup under boot, change the boot to UEFI only. I tried this on arch linux and i can successfuly boot and reboot 10 times without a boot lockup.

 

Not a bad workaround if you don't mind UEFI. Time to install Debian Smiley Happy

johnv474
802.11n
Posts: 223
Registered: ‎06-05-2011
Location: US
Views: 2,082
Message 27 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

Is it just me, or is it difficult to be sympathetic to someone who a) calls herself a snob, b) insults the people she demands help from, c) acts like an arrogant entitled snot all the while?

If you want help, there are behaviors that are more likely to help you get what you want, and behaviors that are less helpful.

And, yes, I am classifying and judging you the same way you are doing to others. Do you like people to treat you this way? Do you think others do?

Quit whining and fix your own problems. Linux Is Not Windows.
Mainframe_Snob
Punch Card
Posts: 50
Registered: ‎12-25-2009
Location: EU
Views: 2,079
Message 28 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

Most likely just you.

 

 

A most childish reply which does not at all help in fixinx these issue(s).

 

 

Aubrey

johnv474
802.11n
Posts: 223
Registered: ‎06-05-2011
Location: US
Views: 2,063
Message 29 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

It's not my job to fix your issues.  It's your job to fix your issues... or, apparently, as you believe, Lenovo's job to fix your custom computing issues.

 

Your reply only underscores my previous remarks.  It's very hard to be sympathetic or want to help you when you insult the people you want help from.

 

I rest my case.

Flazo
Fanfold Paper
Posts: 1
Registered: ‎07-29-2012
Location: Nerderlands
Views: 2,051
Message 30 of 42

Re: W520, Debian 64-bit (Testing) + VT enabled

I may of found a reason why VT-D whit X2APIC is giving problems

 

Looking at Intels VT-D specs v1.3

http://download.intel.com/technology/computing/vptech/Intel%28r%29_VT_for_Direct_IO.pdf

 

You will find that there is a opt-out  for X2APIC available at ch 8.1

After finding this i immediately dived into the ACPI Data Table of my Bios to look at the used setting

and this is what i found

 

/*
 * Intel ACPI Component Architecture
 * AML Disassembler version 20120711-32 [Jul 11 2012]
 * Copyright (c) 2000 - 2012 Intel Corporation
 *
 * Disassembly of RSDT_13_DMAR.BIN, Sat Jul 28 19:28:58 2012
 *
 * ACPI Data Table [DMAR]
 *
 * Format: [HexOffset DecimalOffset ByteLength]  FieldName : FieldValue
 */

[000h 0000   4]                    Signature : "DMAR"    [DMA Remapping table]
[004h 0004   4]                 Table Length : 000000B0
[008h 0008   1]                     Revision : 01
[009h 0009   1]                     Checksum : 46
[00Ah 0010   6]                       Oem ID : "INTEL "
[010h 0016   8]                 Oem Table ID : "SNB "
[018h 0024   4]                 Oem Revision : 00000001
[01Ch 0028   4]              Asl Compiler ID : "INTL"
[020h 0032   4]        Asl Compiler Revision : 00000001

[024h 0036   1]           Host Address Width : 23
[025h 0037   1]                        Flags : 01<-

[030h 0048   2]                Subtable Type : 0000 [Hardware Unit Definition]
[032h 0050   2]                       Length : 0058
[034h 0052   1]                        Flags : 01
[035h 0053   1]                     Reserved : 00
[036h 0054   2]           PCI Segment Number : 0000
[038h 0056   8]        Register Base Address : 00000000FED91000

 

*W520 Bios 1.34 and 1.37 tested.

(Note that this are only the first 31 rows of the file and that XDRT version of the DMAR table is the same, at least what i could see in a fast look)

 

As you see that the Flag value that I marked is set to 1 which does the following according to the VT-D  1.3 standard

 

Bit 1: X2APIC_OPT_OUT - For firmware
compatibility reasons, platform firmware
may Set this field to request system
software to opt out of enabling Extended
xAPIC (X2APIC) mode. This field is valid only
when the INTR_REMAP field (bit 0) is Set.
Since firmware is permitted to hand off
platform to system software in legacy xAPIC
mode, system software is required to check
this field as Clear as part of detecting
X2APIC mode support in the platform.

 

What this means is that X2APIC will not work whit the current bios.

All the software is effected for this part at least

 

This flag may  be causing problems whit the Linux boot loaders.

people have been reporting that VT-D gives almost no problems whit nox2apic added to the boot loader which is what the system is supposed to do anyway (whit X2APIC_OPT_OUT on in the DMAR table)

(http://forums.lenovo.com/t5/Linux-Discussion/64-bit-Linux-W520-amp-nVidia/td-p/577789/page/2)

 

So there is indeed a part wrong whit the bios that Lenovo should fix

Guide how to look at your APCI table:

http://software.intel.com/en-us/blogs/2009/03/02/intels-virtualization-for-directed-io-aka-iommu-par...