Motorola Community

Moto G PhonesMoto G8 Familymoto g power
All Forum Topics
Options

26 Posts

04-27-2010

US

86 Signins

431 Page Views

  • Posts: 26
  • Registered: ‎04-27-2010
  • Location: US
  • Views: 431
  • Message 1 of 18

Google Voice not working on Moto G Power

2020-05-23, 17:38 PM

I have a new Moto G Power phone. GV is not working properly. In particular, even though I configure GV to always use the GV number as caller ID on outgoing calls from the Android Phone app, only the carrier number ever shows up. I have used this feature without problem on several phones, including Moto G5, G7 and Samsung A50, so I am baffled.
 

It seem as though GV is not really managing the calls via Phone at all. For example, if I configure GV to "Select number before each call", when I place a call using Phone, the popup appears to ask me which number to use, but then Phone continues to place the call using the carrier number, without even waiting for my response!

 

Has anyone else seen this problem? Thanks

Reply
Options

1903 Posts

10-16-2018

GB

1720 Signins

26498 Page Views

  • Posts: 1903
  • Registered: ‎10-16-2018
  • Location: GB
  • Views: 26498
  • Message 2 of 18

Re:Google Voice not working on Moto G Power

2020-05-23, 17:54 PM

I don't use Google voice as such but do use the text to speech option on my Android phone. This requires me having Google Gboard installed and updated,

 

https://play.google.com/store/apps/details?id=com.google.android.inputmethod.latin&hl=en_GB

 

and Google Text to speech updated,

 

 

 

 

https://play.google.com/store/apps/details?id=com.google.android.tts&hl=en_GB

 

 

Then making sure it's properly enabled in the Phone's settings. For this go Phone settings > Search box at the top and type voice and find the option to check.

 

 

HTH :)

 

Reply
Options

1912 Posts

03-11-2019

US

589 Signins

41955 Page Views

  • Posts: 1912
  • Registered: ‎03-11-2019
  • Location: US
  • Views: 41955
  • Message 3 of 18

Re:Google Voice not working on Moto G Power

2020-05-26, 17:25 PM

Hi dwhiting56,

 

Thanks for posting your concern. Can you provide us on how are you able to set up Google Voice for Outgoing calls? If you can provide screenshots on how to set it up, that would be more helpful but please blur out or censor any personal number that will be shown. We will try to test it out on our end. 

 

Best regards,
Zeke
Motorola Support



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

26 Posts

04-27-2010

US

86 Signins

431 Page Views

  • Posts: 26
  • Registered: ‎04-27-2010
  • Location: US
  • Views: 431
  • Message 4 of 18

Re:Google Voice not working on Moto G Power

2020-05-30, 21:06 PM

I basically use the GV defaults, linked to my carrier number (which I had via the same SIM card on my prior phones: G5 and G7). I have attached a screenshot of settings for "Calls started from this device’s phone app". Because it didn't work on this new phone, I have tried all kinds of different settings in GV. No combination of settings that I have tried so far seems to work, whereas this always worked on past phones.

 

Another annoying result of this problem is that, when I make a call using Bluetooth in my car, my carrier number (NOT my GV number) is used as the outgoing caller ID, so people see a call from an unknown number. I don't publish my carrier number, since that can change over time. My GV number is my long-term number, and has been for  years.

 

Is there some other setting you would like to see?

 

Thanks!

 

 

Reply
Options

10458 Posts

03-05-2018

US

1112 Signins

150123 Page Views

  • Posts: 10458
  • Registered: ‎03-05-2018
  • Location: US
  • Views: 150123
  • Message 5 of 18

Re:Google Voice not working on Moto G Power

2020-06-01, 19:09 PM

Hi dwhiting56,

 

 

May we request the following in order for us to better assist you? We'll test and see if we can duplicate this.

 

1. Please update your profile with the current phone, carrier and serial number -- this will help me investigate. Please make sure that the options under Settings > System > Motorola Privacy are on as well, and let me know (just reply here) if it's okay for me to look at your apps to see if they are a source of problems.

See here for the instruction. 

 

2. Also, when you encountered the same behavior using the Google voice, can you please generate a bug report?

 

To capture Bug Report:
Go to Settings ->Developer options -> Enable USB debugging > Toggle On
Enable Settings -> Developer options -> Enable Bug Report shortcut > Toggle On
Once the issue is reproduced: Go to Settings -> Developer options -> Click on take bug report or Press Power button and then choose Bug Report from the Power down menu.
Wait for some time until the bug report is collected. It takes around 3 to 4 minutes to collect the Bug Report.
Then upload the BugReport to your personal Google Drive and then share the link to the BugReport on the forums in a reply.
Provide observations of what you saw happen right before the bug report was taken. Please indicate the local time when you observed the behavior. 

To enable developer options: 
1. Go to Settings > About phone > Build number 
2. Tap Build number seven times. After the first few taps, you should see the steps counting down until you unlock the developer options. Once activated, you will see a message that reads, “You are now a developer!”
3. Go back to Settings, where you’ll find a Developer options entry in the menu

 

Thanks!

 

Best regards,
Rich
Motorola-Lenovo Support



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

26 Posts

04-27-2010

US

86 Signins

431 Page Views

  • Posts: 26
  • Registered: ‎04-27-2010
  • Location: US
  • Views: 431
  • Message 6 of 18

Re:Google Voice not working on Moto G Power

2020-06-03, 0:31 AM

Thanks for the quick response. I updated my profile (Moto G Power, Verizon, plus SN/IMEI) and enabled developer mode. 

 

Here is the bug report. I made a couple of calls, one with the setting to "Always use GV number" and one with "Select number with each call". The local time was about 5:20 - 5:25pm.

 

   https://drive.google.com/file/d/1C_udd6OzJoimf1NfXTAbrn8JhjLCvhH6/view?usp=sharing

 

It is very strange because now when I dial a number with the Phone app, it first makes a call with the carrier number. Then when I hang up on that outgoing call, it makes a SECOND call using the GV number. 

 

Thanks!!

 

Reply
Options

26 Posts

04-27-2010

US

86 Signins

431 Page Views

  • Posts: 26
  • Registered: ‎04-27-2010
  • Location: US
  • Views: 431
  • Message 7 of 18

Re:Google Voice not working on Moto G Power

2020-06-03, 2:18 AM

Here is another bug report, perhaps cleaner. I restarted the phone, made one call using Phone (with GV set to have Phone always use the GV for outgoing calls), and then generated the bug report. The call was at 7:12pm local time

 

    https://drive.google.com/file/d/1frF7aoVvAfabLe5jAF-9te6IOXmRtyq6/view?usp=sharing

Reply
Options

26 Posts

04-27-2010

US

86 Signins

431 Page Views

  • Posts: 26
  • Registered: ‎04-27-2010
  • Location: US
  • Views: 431
  • Message 8 of 18

Re:Google Voice not working on Moto G Power

2020-06-03, 2:24 AM

FYI, my phone model number (SKU) is XT2041-4

Reply
Options

1912 Posts

03-11-2019

US

589 Signins

41955 Page Views

  • Posts: 1912
  • Registered: ‎03-11-2019
  • Location: US
  • Views: 41955
  • Message 9 of 18

Re:Google Voice not working on Moto G Power

2020-06-03, 20:50 PM

Hi dwhiting56,

 

Thanks for providing the bug report. I have already forward the files to the engineering team. I'll post back on this thread once they provided an update.

 

Best regards,
Zeke
Motorola Support



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

26 Posts

04-27-2010

US

86 Signins

431 Page Views

  • Posts: 26
  • Registered: ‎04-27-2010
  • Location: US
  • Views: 431
  • Message 10 of 18

Re:Google Voice not working on Moto G Power

2020-06-03, 23:58 PM

Great, thanks!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete