Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Unlockable PhonesMOTOROLA Android Developer Community
All Forum Topics
Options

1 Posts

06-09-2021

United States of America

1 Signins

30 Page Views

  • Posts: 1
  • Registered: ‎06-09-2021
  • Location: United States of America
  • Views: 30
  • Message 1 of 2

G stylus won't charge after replacing screen and digitizer

2021-06-09, 23:36 PM

Good afternoon everyone. I'd like to say, I am a die hard Motorola man. I've tried others and nothing beats a Moto.

 

This is probably something stupid such as a loose connection or something. However, I wanted to touch base with you techies and see if there's something I may not be thinking of.  Everything seems to be working just fine except, it was on about 30% battery when I did the screen swap. I plugged it in and it was with my same Moto wall charger. It acted like it was charging so I didn't bother to look but, after a while if playing around I saw that battery saver came on. It was then that's went into the battery app and saw it was saying  " Plugged in, Can't charge right now!". Well, of course I did what anyone would do. Went to engineering mode and did a battery check. All came back fine. Battery present. Health good. Etc there was one error that seemed very insignificant at the time and now I can't remember it but it didn't have anything to do with what I considered to be related to the issue and I believe it has been there several times before this issue. Now,  of course I can't get into the phone to see what it is. 

One more thing that may be of help is I tried a few other Moto chargers with same  output. Changed wires. Checked home circuit. Even tried charging on my car charger. It kept this message every time and it stayed on 1% battery and all the while I could use the phone like normal all day until it had become unplugged accidentally earlier and  now im ready to open her up again. While I was researching and writing this I left it plugged into my car charger. For the heck of it I tried to turn it on. It came on. For just a minute or two. Instead of letting it charge, I needed to get a few messages out and whatnot and it died again.  Any ideas??? Could my blue and white cables be switched? Is there something I'm not seeing here???  Thanks a bunch in advance.

Reply
Options

4270 Posts

03-11-2019

United States of America

766 Signins

60600 Page Views

  • Posts: 4270
  • Registered: ‎03-11-2019
  • Location: United States of America
  • Views: 60600
  • Message 2 of 2

Re:G stylus won't charge after replacing screen and digitizer

2021-06-10, 15:48 PM

Hi Teronman,

 

Thank you for posting here but opening the device and repairing by yourself is beyond our scope of support. We do recommend to take it to a nearest authorized service center to have the phone checked. We will also transfer your post to the Android Developer there could be other users might be able to provide some insight on this. 

 

Best regards,
Zeke
Motorola Support



Did someone help you today? Press the Thumbs up icon on the bottom right thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms