Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto G Phonesmoto g100
All Forum Topics
Options

8 Posts

10-06-2021

Germany

9 Signins

50 Page Views

  • Posts: 8
  • Registered: ‎10-06-2021
  • Location: Germany
  • Views: 50
  • Message 11 of 23

Re:g100 and "Ready For" - Crashes and Reboots

2021-10-13, 13:56 PM

Since your phone has still pretty much stock software, to rule out some app causing the issue, the only thing i can think of right now, is to try getting a replacement unit from Amazon.

 

Maybe you received a defective phone.

 

That is definitely not a nice solution, i am aware of that, but i don't know at the moment what to suggest to try.

 

Is the phone overheating by any chance?

 

i get temperatures about 40-50 degrees Celsius in Aida64, while in desktop mode and charging.

 

Maybe check the temperatures before returning the phone.

 

I'll let you know if i have another idea what to try.

 

 

EDIT:

in my early days of using the g100 the display refresh rate, was at to automatic.

i experienced that the if the phone changes refresh rates, some app tend to malfunction.

 

Try setting the refresh rate to a fixed value in the settings 60 or 90 Hz, and try again.

 

from my experience using a permanent setting for that, stabilizes things

Reply
Options

8 Posts

10-06-2021

Germany

9 Signins

50 Page Views

  • Posts: 8
  • Registered: ‎10-06-2021
  • Location: Germany
  • Views: 50
  • Message 12 of 23

Re:g100 and "Ready For" - Crashes and Reboots

2021-10-13, 14:01 PM

EDIT:

 

in my early days of using the g100 the display refresh rate, was at to automatic.

 

i experienced that the if the phone changes refresh rates, some app tend to malfunction.

 

 

 

 

Try setting the refresh rate to a fixed value in the settings 60 or 90 Hz, and try again.

(settings -> display -> refresh rate)

 

 

 

from my experience using a permanent setting for that, stabilizes things

Reply
Options

9 Posts

10-12-2021

Germany

10 Signins

80 Page Views

  • Posts: 9
  • Registered: ‎10-12-2021
  • Location: Germany
  • Views: 80
  • Message 13 of 23

Re:g100 and "Ready For" - Crashes and Reboots

2021-10-13, 14:19 PM

Hi cRanger,

 

Thank you for your suggestions.

I do actually have a second g100 factory sealed lying here as I planned to replace two phones with it, but due to the issues I was hesitant to open it up. I will think about if I want to go that route.

 

As for temperatures, I used CPU info (open source) from the play store and it typically is between 30 and 40 during normal usage. I would think this is normal.

Furthermore, even if I stress the phone with a benchmark, the temps stay well below 60 degrees Celsius and the phone and ready for work just fine at these temps, so I am quite certain that CPU load and/or temps are not the cause for the random black screens.

 

I will test if the screen refresh rate changes anything, thanks.

Reply
Options

9 Posts

10-12-2021

Germany

10 Signins

80 Page Views

  • Posts: 9
  • Registered: ‎10-12-2021
  • Location: Germany
  • Views: 80
  • Message 14 of 23

Re:g100 and "Ready For" - Crashes and Reboots

2021-10-13, 18:41 PM

Hi again,

 

I've decided to unpack the other phone as well.

Then I've tested before applying any updates as well as after, and the issue still persists even on the second phone.

Hence this most likely is a software issue or a hardware issue that affects potentially many devices.

I also found a way to trigger this even easier: Start any video in netflix in full screen and pause it. After a few seconds the screen goes black and only recovers when i press alt+tab, or sometimes pressing space works as well.

Note that moving the mouse or pressing any other key like the Windows key does not recover from that state, hence I don't believe this is intended behaviour. The mouse does not even appear on the screen anymore when this happens.

However I think this narrows down the issues to some incompatibility of Ready For with Netflix, maybe in the cases where it crashed without Netflix being actively used it was due to being paused in the background or something like this.

By the way the change in screen frequency did not stop the issue (would have been strange since the frequency of the external screen is a different one anyways), but thanks again for the suggestion.

 

Reply
Options

8 Posts

10-06-2021

Germany

9 Signins

50 Page Views

  • Posts: 8
  • Registered: ‎10-06-2021
  • Location: Germany
  • Views: 50
  • Message 15 of 23

Re:g100 and "Ready For" - Crashes and Reboots

2021-10-13, 20:00 PM

Interesting,

 

thank you for letting us know.

 

Since that happens on both devices.

 

There is no way in my opinion, that both have the same defect.

And one that can be so reliably reproduced.

 

I am afraid, i ran out of ideas now.

Motorola Agents, please help. :-)

 

Ready for appears not to work with Netflix.

I don't have that app, i use YouTube, so i cannot try.

 

 

The last thing i can think of is the following:

 

if you intent to watch Netflix, instead of selecting Desktop mode, after plugging the device in the dock.

 

Select the mode next to it, called Video.

then it should ask you what video app to run.

 

There you select Netflix, maybe it works with video exclusive Mode.

 

Reply
Options

2293 Posts

11-24-2020

India

230 Signins

24205 Page Views

  • Posts: 2293
  • Registered: ‎11-24-2020
  • Location: India
  • Views: 24205
  • Message 16 of 23

Re:g100 and "Ready For" - Crashes and Reboots

2021-10-14, 6:04 AM

@ cRanger wrote:

Hello Agent Sandeep, Hello Agent Sunitha,

 

thanks again for your replies and help Offers.

 

 

I think i found out what was causing my issues.

The reason is a bit embarrassing, but on the other hand i could not have known that.

 

I spend last Friday night searching for the root of the issues.

 

My methods where mostly trial and error, and process of elimination, until i find out what caused the problems.

 

Then i ran the phone over the weekend nonstop on the dock, and Monday, Tuesday all night on the dock.

 

None of the issues reappeared, the phone worked reliable with the dock the past 4 days.

 

I've had sometimes some user interface and mouse movement stuttering and lags, but everything was stable, nothing crashed, no graphical glitches, no black screen.

 

 

The issue was my screen.

 

i bought that screen many years ago.

my screen has 3 HDMI ports.

 

I plugged in HDMI port 1 and 2 my computer and laptop.

HDMI port 3 stayed empty.

 

I've used my screen like that for years. HDMI port 3 was always empty.

 

now with the purchase of the g100 I've finally had a use for HDMI port 3.

 

it appears that HDMI port 3 on my screen has some kind of malfunction.

i don't know, maybe some soldering connection has come loose inside the screen, or it short circuits inside the screen, something like that.

 

When i use the phone on HDMI port 1 or 2, it works without issues.

 

it's HDMI port 3 on my screen that is broken.

 

when i connect my laptop to port 3, the laptop does show black screens as well. no catastrophic failure like a Laptop crash, but i think it's evident that HDMI port 3 on my screen is broken.

 

I've used the phone on HDMI port 1 the past 4 days, besides and some stuttering sometimes, nothing bad happened.

 

Maybe it's possible to implement some failsafe in the phone software, to display a warning message, if the phone has trouble communicating with the HDMI port.

 

Mystery is solved for me 😃

 

 

 

Hi, 

 

Great! I'm glad you found the root cause of the issue and thank you for sharing the solution. Please don't hesitate to post again in case you need further assistance. We are here to help!

 

Thanks

Sunitha 



Did someone help you today? Press the thumbs up icon on the bottom right to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

2293 Posts

11-24-2020

India

230 Signins

24205 Page Views

  • Posts: 2293
  • Registered: ‎11-24-2020
  • Location: India
  • Views: 24205
  • Message 17 of 23

Re:g100 and "Ready For" - Crashes and Reboots

2021-10-14, 6:19 AM

@ metalmac wrote:

Hi again,

 

I've decided to unpack the other phone as well.

Then I've tested before applying any updates as well as after, and the issue still persists even on the second phone.

Hence this most likely is a software issue or a hardware issue that affects potentially many devices.

I also found a way to trigger this even easier: Start any video in netflix in full screen and pause it. After a few seconds the screen goes black and only recovers when i press alt+tab, or sometimes pressing space works as well.

Note that moving the mouse or pressing any other key like the Windows key does not recover from that state, hence I don't believe this is intended behaviour. The mouse does not even appear on the screen anymore when this happens.

However I think this narrows down the issues to some incompatibility of Ready For with Netflix, maybe in the cases where it crashed without Netflix being actively used it was due to being paused in the background or something like this.

By the way the change in screen frequency did not stop the issue (would have been strange since the frequency of the external screen is a different one anyways), but thanks again for the suggestion.

 

 

Hi, 

 

Thank you for testing! I'm sorry to know you are facing the same problem with both of your devices. I will try my best to help you with this and we will also try to test it. Meanwhile, it would be great if you could help me with some more details here: 

 

  • Does it happen only while using the Netflix application? 
  • Have you tested with other streaming applications? If not, please check. Let me know if you face the same problem. 
  • Try clearing the Netflix application Cache/Data. Here are instructions: Go to Setting>> Apps and Notifications>>See all apps >>Tap on App>>Force stop>> Click ok>> storage >>Clear cache/data. Restart the phone post this and check. 

 

Let me know how it goes. 

 

Thanks

Sunitha 



Did someone help you today? Press the thumbs up icon on the bottom right to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

9 Posts

10-12-2021

Germany

10 Signins

80 Page Views

  • Posts: 9
  • Registered: ‎10-12-2021
  • Location: Germany
  • Views: 80
  • Message 18 of 23

Re:g100 and "Ready For" - Crashes and Reboots

2021-10-14, 11:21 AM

Hi cRanger and Sunitha,

 

thanks for your suggestions.

Using the TV mode unfortunately doesn't change anything, I believe this just launches the desktop mode and immediately opens Netflix in full screen.

Neither does clearing the cache and/or data of Netflix.

I have since tested other streaming apps, here are my results:

  • Youtube does not exhibit this behaviour, it pauses fine while in full screen
  • Netflix as stated blanks the screen as soon as a video is paused and is difficult to recover from
  • Amazon Prime Video does not work at all using Ready For, neither in the app where it just states DECRYPTION_ERROR nor in a Browser where I just get another error code, this is quite disappointing
  • Disney Plus exhibits the same behaviour as Netflix, once i pause a video the screen blanks a few seconds after
  • Audible has no such problems (but only has to stream audio)
  • Spotify has no such problems (but again only has to stream audio)

From this I believe it is quite clear to say that there is some issues with the playback of decrypted Video contents, which is what Netflix, Prime and Disney Plus have in common. Youtube streams their videos unencryptedly as far as I am aware.

Also audio streaming does not seem to cause any problems (I am not sure if Audible and Spotify stream this encryptedly).

Reply
Options

2293 Posts

11-24-2020

India

230 Signins

24205 Page Views

  • Posts: 2293
  • Registered: ‎11-24-2020
  • Location: India
  • Views: 24205
  • Message 19 of 23

Re:g100 and "Ready For" - Crashes and Reboots

2021-10-19, 10:04 AM

@ metalmac wrote:

Hi cRanger and Sunitha,

 

thanks for your suggestions.

Using the TV mode unfortunately doesn't change anything, I believe this just launches the desktop mode and immediately opens Netflix in full screen.

Neither does clearing the cache and/or data of Netflix.

I have since tested other streaming apps, here are my results:

  • Youtube does not exhibit this behaviour, it pauses fine while in full screen
  • Netflix as stated blanks the screen as soon as a video is paused and is difficult to recover from
  • Amazon Prime Video does not work at all using Ready For, neither in the app where it just states DECRYPTION_ERROR nor in a Browser where I just get another error code, this is quite disappointing
  • Disney Plus exhibits the same behaviour as Netflix, once i pause a video the screen blanks a few seconds after
  • Audible has no such problems (but only has to stream audio)
  • Spotify has no such problems (but again only has to stream audio)

From this I believe it is quite clear to say that there is some issues with the playback of decrypted Video contents, which is what Netflix, Prime and Disney Plus have in common. Youtube streams their videos unencryptedly as far as I am aware.

Also audio streaming does not seem to cause any problems (I am not sure if Audible and Spotify stream this encryptedly).

 

Hi, 

 

Thank you for testing and I appreciate you for sharing the additional information. Could you please confirm if you are using the same HDMI cable on both phones? If yes, can you test with a new/another cable? Let me know if you still face the same problem. 

 

I look forward to your response.

 

Thanks

Sunitha 



Did someone help you today? Press the thumbs up icon on the bottom right to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

9 Posts

10-12-2021

Germany

10 Signins

80 Page Views

  • Posts: 9
  • Registered: ‎10-12-2021
  • Location: Germany
  • Views: 80
  • Message 20 of 23

Re:g100 and "Ready For" - Crashes and Reboots

2021-10-19, 20:06 PM

Hi Sunitha,

 

I did not use the same HDMI cable on both phones, but for the sake of testing i tried again with different cables and screens. As of now I have seen this behaviour on 4 different Monitors with 3 different cables as well as 3 different HDMI docks (including the original Motorola HDMI cable that came with the box), therefore I highly doubt that the cable, monitor and/or dock is the issue here.

 

Best regards

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms