Motorola Community

Moto G Phonesmoto g7 play / moto g7 / moto g7 power / moto g7 plus
All Forum Topics
Options

6 Posts

07-09-2020

US

5 Signins

40 Page Views

  • Posts: 6
  • Registered: ‎07-09-2020
  • Location: US
  • Views: 40
  • Message 1 of 65

Lost LTE on Sprint after Android 10 upgrade on Moto G7.

2020-07-09, 18:08 PM

This morning I have upgraded my moto g7 to android 10 and lost lte on Sprint. The carrier setting are nowhere found. only 3G is available. The phone worked fine before the upgraded. and the other phones with sprint has lte. I no longer can update profile from sprint. that option is no longer available. When sprint tried to update profile from their side it fails I was updated OTA to android 10(QPU30.52-23). i have Select Settings>>Select Network & Internet>>Select Mobile network>>Select Preferred network type>>LTE/CDMA Under Advanced I have APN settings only. I used to have a carrier settings under advanced. Not anymore. I have tried a reset network settings. It did not help. Please help. Model XT1962-1. The phone originally from Google FI

Reply
Options

6 Posts

07-09-2020

US

5 Signins

40 Page Views

  • Posts: 6
  • Registered: ‎07-09-2020
  • Location: US
  • Views: 40
  • Message 2 of 65

Re:Lost LTE on Sprint after Android 10 upgrade on Moto G7.

2020-07-09, 20:55 PM

did Factory reset and got Android 9 back and LTE too. used lenovo's smart assist to back up data. Restoring it now. I hope they fix the issue, so I can install update. I think they forgot to test on CDMA providers. 

Reply
Options

6 Posts

07-09-2020

US

5 Signins

40 Page Views

  • Posts: 6
  • Registered: ‎07-09-2020
  • Location: US
  • Views: 40
  • Message 3 of 65

Re:Lost LTE on Sprint after Android 10 upgrade on Moto G7.

2020-07-09, 22:19 PM
  1. With the phone powered off, press and hold the Volume Down button and the Power button at the same time until the device turns on.
  2. Press the Volume Down key to highlight Recovery mode.
  3. Press the Power key to restart into Recovery mode.
  4. The screen will display an Android robot with a red exclamation mark.
  5. While holding down the Power key, press and release the Volume Up key, then release Power.
  6. Use the volume keys to scroll to Wipe data/factory reset and press the Power key to select it.
  7. Scroll down to Yes - erase all user data and press the Power key to select it.

I did not reset from Recovery mode. I went back and picked factory mode and did factory reset from there.

Reply
Options

11 Posts

07-09-2020

US

10 Signins

95 Page Views

  • Posts: 11
  • Registered: ‎07-09-2020
  • Location: US
  • Views: 95
  • Message 4 of 65

Re:Lost LTE on Sprint after Android 10 upgrade on Moto G7.

2020-07-09, 22:50 PM

Ha! I had already tried reseting thru settings and then thru the recovery mode and it didn’t revert, tried factory mode instead and my phone works again!! Thanks vsuser!

Reply
Options

39 Posts

06-15-2019

US

41 Signins

394 Page Views

  • Posts: 39
  • Registered: ‎06-15-2019
  • Location: US
  • Views: 394
  • Message 5 of 65

Re:Lost LTE on Sprint after Android 10 upgrade on Moto G7.

2020-07-11, 18:14 PM
Glad a user provided what Lenovo official support would not. A way to get back to 9!
Reply
Options

21 Posts

10-02-2016

US

26 Signins

170 Page Views

  • Posts: 21
  • Registered: ‎10-02-2016
  • Location: US
  • Views: 170
  • Message 6 of 65

Re:Lost LTE on Sprint after Android 10 upgrade on Moto G7.

2020-07-11, 22:02 PM

Everyone is having the same problems - And Lenovo is SILENT ABOUT IT. WHERE ARE YOU LENOVO????????

Reply
Options

11321 Posts

03-05-2018

US

1159 Signins

157200 Page Views

  • Posts: 11321
  • Registered: ‎03-05-2018
  • Location: US
  • Views: 157200
  • Message 7 of 65

Re:Lost LTE on Sprint after Android 10 upgrade on Moto G7.

2020-07-13, 9:01 AM

Hi Everyone,

 

Sorry to know about this. I would like to assist you with this. Please update your profile with the current phone, carrier and serial number -- this will help me investigate. Please make sure that the options under Settings > System > Motorola Privacy are on as well, and let me know (just reply here) if it's okay for me to look at your software to see if they are a source of problems.

See here for the instruction. Thanks.

 

Best regards,
Rich
Motorola-Lenovo Support

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

4 Posts

07-13-2020

US

5 Signins

65 Page Views

  • Posts: 4
  • Registered: ‎07-13-2020
  • Location: US
  • Views: 65
  • Message 8 of 65

Re:Lost LTE on Sprint after Android 10 upgrade on Moto G7.

2020-07-13, 16:04 PM
I'm having the same problem. I have seen LTE once (about 5 seconds) since my phone updated to android 10 and even then it has an X through it before going back to 3G which is all I ever get anymore. Cellular signal is also much worse as my house. I have updated my profile and you can look at my software
Reply
Options

11321 Posts

03-05-2018

US

1159 Signins

157200 Page Views

  • Posts: 11321
  • Registered: ‎03-05-2018
  • Location: US
  • Views: 157200
  • Message 9 of 65

Re:Lost LTE on Sprint after Android 10 upgrade on Moto G7.

2020-07-13, 19:20 PM

Hi,

 

I appreciate all your reports and I'm sorry to know about this. I would like to make sure, can you please test this in safe mode?

 

To Enable Safe Mode
1. Press and hold the Power button until Power off comes up on the screen.
2. Touch and HOLD Power off on the screen until reboot to safe mode appears.

Turn off Airplane mode.
Just turn off and on the phone to boot back to normal mode.

 

Please let me know if there's improvement. Thanks.

 

Best regards,
Rich
Motorola-Lenovo Support



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

4 Posts

07-13-2020

US

13 Signins

85 Page Views

  • Posts: 4
  • Registered: ‎07-13-2020
  • Location: US
  • Views: 85
  • Message 10 of 65

Re:Lost LTE on Sprint after Android 10 upgrade on Moto G7.

2020-07-13, 20:59 PM

Same exact issue as OP.

 

I have two moto G7 phones (both model XT1962-1 purchased from Google Fi) with Sprint's unlimited service. 

 

Prior to the Android 10 update, both phones connected as expected on Android 9 with all Sprint services: voice, sms/mms, 3G, and 4G LTE.

 

Upon upgrading both phones to Android 10 on 7/9/2020, software update was successful but neither would not connect to Sprint's 4G LTE.

 

I spent most of Friday and Saturday chatting with Sprint and Motorola support trying to initiate a network reset... All unsuccessful.

 

After the update to Android 10, neither phone has these options available: Settings > Network & Internet > Mobile network > Advanced > Carrier Settings > Update PRL or Update device config

 

The classic sprint dialer code for a network reset *removed* (SCRTN) would not initiate a connection reset. I would enter the dialer code and it would disappear with no action. Sprint said this was necessary for all services to be re-provisioned/fixed.  No success.

 

On one phone, I performed a full "Erase all data (factory reset)" to try and initiate a reconnect. No success.

 

The Sprint dialer code and the Android "Carrier Settings" options used to reset services were not available.

 

For one of my moto G7 lines, I swapped my Sprint service to a different phone and back to the newly erased moto G7 (that had the Android 10 update) to try and kick-start the re-provisioning process. Oddly enough, 4G LTE connected and started working for only 4G LTE data but voice/sms/mms/3G would not connect. No success.

 

Retrying each of these methods from "safe-mode" did nothing different. No success.

 

I gave up until today when I saw posts about reverting to Android 9 and all the voices lighting up the forum + reddit.

 

Please help - this is frustrating that an official update would disrupt services and remove options that have been available on nearly every past Motorola phone on I own (moto g5s+, moto X, moto E, etc.)

 

Edit: No hidden codes - Rich

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete