Motorola Community

Moto G Phonesmoto g7 play / moto g7 / moto g7 power / moto g7 plus
All Forum Topics
Options

3 Posts

03-15-2020

US

5 Signins

40 Page Views

  • Posts: 3
  • Registered: ‎03-15-2020
  • Location: US
  • Views: 40
  • Message 1 of 10

Problem with G7 Plus and BT connection to car

2020-03-15, 8:03 AM

Hi,

 

I have a weird problem with the bluetooth connection. I can connect my G7 plus to my BMW (stock system from 2017) as audio player (spotify etc works great) but not as a phone.

The car also indicates that the phone is only connected as a media player and not phone, there´s two different icons that shows a phone and a music note, the phone icon is not lit.

 

I´ve tried to unpair and delete the connection from both car and phone but its still the same problem. In the car I choose to connect both phone and music and in the BT settings in the phone I have allowed the connection to handle everything.

I can see in my phone when i try to pair that it connects, disconnects, connects and keeps doing so (while music is playing so that connection seems to work during this) until the car says its connected but the phone icon is unlit.

 

The car works fine with other Android and iOS units...And I can connect my phone to other BT devices such as my headset without any issues.

 

Any ideas?

Reply
Options

3 Posts

03-15-2020

US

5 Signins

40 Page Views

  • Posts: 3
  • Registered: ‎03-15-2020
  • Location: US
  • Views: 40
  • Message 2 of 10

Problem with G7 Plus and BT connection to car

2020-03-15, 8:59 AM
I can also add that I've tried in safe mode aswell..
Reply
Options

1 Posts

03-16-2020

US

1 Signins

20 Page Views

  • Posts: 1
  • Registered: ‎03-16-2020
  • Location: US
  • Views: 20
  • Message 3 of 10

Re:Problem with G7 Plus and BT connection to car

2020-03-16, 9:29 AM

I experience exactly the same problem on a Landrover Discovery Sport. Technicians at the Landrover dealer were able to simply connect 4 other phones both Android and Apple. It therefore seems to be a Motorola G7plus problem.

I have seen a number of identical complaints on other fora but did not find any response  from Motorola/Lenovo. 

Action from them would be greatly welcomed.

Reply
Options

3 Posts

03-15-2020

US

5 Signins

40 Page Views

  • Posts: 3
  • Registered: ‎03-15-2020
  • Location: US
  • Views: 40
  • Message 4 of 10

Re:Problem with G7 Plus and BT connection to car

2020-03-16, 16:18 PM
Thanks for the reply, I've been trying different settings in developer mode aswell, guess I'll give a call to Motorola support tomorrow..
Reply
Options

8675 Posts

03-05-2018

US

1022 Signins

135687 Page Views

  • Posts: 8675
  • Registered: ‎03-05-2018
  • Location: US
  • Views: 135687
  • Message 5 of 10

Re:Problem with G7 Plus and BT connection to car

2020-03-18, 15:14 PM

Hi,

 

Please try removing/forgetting all Bluetooth connections for both phone and car. On your Settings > Connected Devices > Bluetooth > Tap on the gear icon next to each Bluetooth names > Forget). Do the same for your car. Once done, pair back your phone and car via Bluetooth. Let me know. Thanks.

 

Best regards,
Rich
Motorola-Lenovo Support

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Reply
Options

3 Posts

03-15-2020

US

5 Signins

40 Page Views

  • Posts: 3
  • Registered: ‎03-15-2020
  • Location: US
  • Views: 40
  • Message 6 of 10

Re:Problem with G7 Plus and BT connection to car

2020-03-20, 8:24 AM

Hi,

 

Done that aswell several times. Plus:

  • Tried different AVRCP versions
  • Resetted all BT and Wifi connetions
  • Disabled BT and BT Midi battery saving
  • Updated car software to latest version

 

Another thing I noticed while all call yesterday (with BT connection to the car but only media audio) the phone part suddenly connected to the car via BT but I could not hear anything, then it disconnected after a while, when it connected again I had to set the phone to speaker instead so I could talk, then it connected to the car again and I had to change to speaker again. 

Seems like it tries to connect but can´t stay connected and doesnt work while connected.

 

And just to be clear, the media audio works great and I haven´t experienced any problems with it at all.

 

Is it possible to try some kind of roll back? I´ve read that several people have issues with BT connection in Android 10.

 

Br

Roger

 

Reply
Options

8675 Posts

03-05-2018

US

1022 Signins

135687 Page Views

  • Posts: 8675
  • Registered: ‎03-05-2018
  • Location: US
  • Views: 135687
  • Message 7 of 10

Re:Problem with G7 Plus and BT connection to car

2020-03-23, 19:18 PM

Hi MdnSwe,

 

I appreciate the extensive troubleshooting you've tried. Can you please confirm the make and model of device? Also, please send me a a bug report so I can escalate this. 

 

 

Bluetooth Bug Report:
1. Go to Settings -> About Phone -> Tap on Build number 7 times on the build number to go into the developer options mode]
2. After the above steps Developer options will be enabled.
3. Go to Settings ->Developer options -> Enable USB debugging > Toggle On
4. Enable Settings -> Developer options -> Enable Bug Report shortcut > Toggle On
5. Enable Settings -> Developer options -> Enable Enable Bluetooth HCI snoop log > Toggle On
6. Once the issue is reproduced, Go to Settings -> Developer options -> Click on take bug report or Press Power button and then choose Bug Report from the Power down menu.
7. Wait for some time until the bug report is collected. It takes around 3 to 4 minutes to collect the Bug Report.
8. Then upload the BugReport to your personal Google Drive
9. Open the File Manager app on your phone and tap on Local on the top right. Browse to internal.
10. Upload the btsnoop_hci.log to your Google Drive as well
11. Share the link to the BugReport and btsnoop_hci.log on the forums via a private message.
12. Provide observations of what you saw happen right before the bug report was taken. Please indicate the time that you observed the behavior in local time.
13. One completed to Settings-> Developer options -> Enable Bluetooth HCI snoop log > Toggle Off

 

Thanks.

 

Best regards,
Rich
Motorola-Lenovo Support



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!
This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Reply
Options

1 Posts

05-03-2020

GB

4 Signins

20 Page Views

  • Posts: 1
  • Registered: ‎05-03-2020
  • Location: GB
  • Views: 20
  • Message 8 of 10

Re:Problem with G7 Plus and BT connection to car

2020-05-03, 19:13 PM

I have exactly the same problem with my G7 Plus. Has a solution to the above problem been found? Thanks.

Reply
Options

12 Posts

04-26-2020

GB

13 Signins

150 Page Views

  • Posts: 12
  • Registered: ‎04-26-2020
  • Location: GB
  • Views: 150
  • Message 9 of 10

Re:Problem with G7 Plus and BT connection to car

2020-05-04, 13:05 PM
It does sound like there is an issue with Android 10 on the G7 Plus as mine doesn't work with a MY2010 Land Rover Discovery. Rich has been helping and has a debug from my phone. Hopefully they can find the issue and fix it soon. Not a big issue during lock down as I drive once a week to the supermarket, but will be a bigger issue once the restrictions are relaxed a bit. Regards, Steve
Reply
Options

8675 Posts

03-05-2018

US

1022 Signins

135687 Page Views

  • Posts: 8675
  • Registered: ‎03-05-2018
  • Location: US
  • Views: 135687
  • Message 10 of 10

Re:Problem with G7 Plus and BT connection to car

2020-05-04, 14:24 PM

Hi IRB,  SteveKK,

 

Thanks for posting on this thread. I have reported this and we would like to investigate this. I was asking for a Bluetooth bug report - that will help us look into this further. But we recommend you to unpair all Bluetooth connections you have with your phone and pair back the Bluetooth device. 

 

 

Best regards,
Rich
Motorola-Lenovo Support

 

 

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!
This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save