Motorola Community

Moto G Phonesmoto g7 play / moto g7 / moto g7 power / moto g7 plus
All Forum Topics
Options

1 Posts

09-27-2020

CA

3 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎09-27-2020
  • Location: CA
  • Views: 5
  • Message 1 of 2

Will not send SMS over Celluar Network

2020-09-27, 16:13 PM

I have a Moto G7, XT1962-4 running Android 10, Build No: QPUS30.52-16-2-5, Kernel Ver 4.9.206-perf+.

 

I noticed the SMS messages were not being sent, until I returned home and connected to WIFI. Not sure when this started, probably after the last software update.

 

When I tried to send texts the Message App would just show "Waiting for connection..." 

 

I eventually found a setting lurking under Messages -> Settings -> Chat Features -> Use Wi-Fi or data for messaging when available.

I turned that feature off and normal SMS operation worked again.

 

It would appear that the feature has been implemented as Only use Wi-Fi or data for messaging.

 

Clearly this is a bug that needs to be fixed.

 

One other point - I do not have mobile data enabled so my guess is that the "Waiting for connection..." was the system getting stuck trying to use disabled mobile data.

 

 

Reply
Options

11395 Posts

03-05-2018

US

1163 Signins

157735 Page Views

  • Posts: 11395
  • Registered: ‎03-05-2018
  • Location: US
  • Views: 157735
  • Message 2 of 2

Re:Will not send SMS over Celluar Network

2020-09-28, 18:03 PM

Hi Ian S,

 

It will be my pleasure to help you with this. Let's investigate this. Can you please turn chat features back on and see if you can duplicate? If you're able to duplicate it again, please generate a bug report. 

 

To capture Bug Report:

Go to Settings > About phone > Build number 

Tap Build number seven times. After the first few taps, you should see the steps counting down until you unlock the developer options. Once activated, you will see a message that reads, “You are now a developer!”
Go to Settings ->Developer options -> Enable USB debugging > Toggle On
Enable Settings -> Developer options -> Enable Bug Report shortcut > Toggle On
Once the issue is reproduced: Go to Settings -> Developer options -> Click on take bug report or Press Power button and then choose Bug Report from the Power down menu.
Wait for some time until the bug report is collected. It takes around 3 to 4 minutes to collect the Bug Report.
Then upload the BugReport to your personal Google Drive and then share the link to the BugReport via private message.


Provide observations of what you saw happen right before the bug report was taken. Please indicate the local time when you observed the behavior. 


Also, please update your profile with the current phone, carrier and serial number -- this will help me investigate. Please make sure that the options under Settings > System > Motorola Privacy are on as well, and let me know (just reply here) if it's okay for me to look at your apps to see if they are a source of problems.

See here for the instruction. Thanks.

 

Best regards,
Rich
Motorola-Lenovo Support



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete