cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
DMFREE88
Fanfold Paper
Posts: 2
Registered: ‎04-11-2019
Location: US
Views: 685
Message 1 of 12

Problems with Moto G7 Power on Sprint 4G/LTE

I am unable to get sprint to function properly on my Moto G7 Power. Have tried 2 sim cards now that Sprint says is the only whitelisted one compatible, both have the same results. Model of simcard is SIMOLW516TQ. It will work ok for awhile especially with wifi on but as soon as 4G connects it immediately kills all cellular data (seems to crash the simcard) including phone calls/texts. It usually comes back 10-15 seconds later and maintains 3G connection for awhile, then randomly 4G comes back and kills it all. I can text and it seems to make and maintain phone calls fine (as long as it hasnt crashed during the call/send process). Any solutions greatly appreciated, thanks.

Motorola Admin Motorola Admin
Motorola Admin
Posts: 1,930
Registered: ‎02-11-2016
Location: US
Views: 633
Message 2 of 12

Re: Problems with Moto G7 Power on Sprint 4G/LTE


@DMFREE88 wrote:

I am unable to get sprint to function properly on my Moto G7 Power. Have tried 2 sim cards now that Sprint says is the only whitelisted one compatible, both have the same results. Model of simcard is SIMOLW516TQ. It will work ok for awhile especially with wifi on but as soon as 4G connects it immediately kills all cellular data (seems to crash the simcard) including phone calls/texts. It usually comes back 10-15 seconds later and maintains 3G connection for awhile, then randomly 4G comes back and kills it all. I can text and it seems to make and maintain phone calls fine (as long as it hasnt crashed during the call/send process). Any solutions greatly appreciated, thanks.


Please make sure your forum profile is updated with the IMEI or SN from your phone. Also, please PM me pictures of the SIM Kit you're using.

 

-Tom

 

Need help updating your profile? See here. https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943

-Tom

Need help updating your profile? See here. https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943
jbrogers63
Fanfold Paper
Posts: 3
Registered: ‎04-12-2019
Location: US
Views: 615
Message 3 of 12

Re: Problems with Moto G7 Power on Sprint 4G/LTE

Hi guys!  I'm having a similar issue with a Moto G7 (not Power, not Play, etc) on Ting (Sprint MVNO).  I just activated the phone yesterday and I updated to the lastest firmware.  I've been unable to access mobile data.

 

I contacted Ting and they have apparently had several users that have the same issue.  I was told that "everything up to putting the phone through a factory reset" hasn't worked.  There's a reddit thread for a G7 Power that seems to indicate that a firmware downgrade works.

 

Lastly, I'm unable to access the carrier update option (it's not present in the networks option of settings).  Don't know if that matters or not.

 

Is there any word on a fix from Motorola?

brontide
Punch Card
Posts: 28
Registered: ‎04-01-2019
Location: US
Views: 599
Message 4 of 12

Re: Problems with Moto G7 Power on Sprint 4G/LTE

That was me.  Factory reset did nothing for me.  You have a few options.

 

1. Use 1x mode until Moto comes up with a fix.  1990's data speeds.

2. Swap the phone and hope for a better result

3. Downgrade the firmware ( not recommended ).

 

Did you get the phone from Ting or direct?  

jbrogers63
Fanfold Paper
Posts: 3
Registered: ‎04-12-2019
Location: US
Views: 595
Message 5 of 12

Re: Problems with Moto G7 Power on Sprint 4G/LTE

I got the phone from Ting.  For now, I managed to get 3G working.  Not great, but at least it's mobile data.  I work from home a lot, so thankfully I don't have to depend on mobile data.  It just seems a little silly that a manufacturer would release a device with this kind of flaw.

 

I did start an attempt at a factory reset.  However, pulling firmware from random places on the web seems a little sketchy.  I'm not finding official firmware anywhere, so I'm going to hang out for a bit and see if Motorola comes up with a fix.

 

If someone finds a work around, let me know.  I'd be happy to be a guinea pig for a potential fix.

DMFREE88
Fanfold Paper
Posts: 2
Registered: ‎04-11-2019
Location: US
Views: 591
Message 6 of 12

Re: Problems with Moto G7 Power on Sprint 4G/LTE

Problem solved by replacing phone. Not waiting for firmware to be updated to fix problem. Brontide seems to be correct. Heres how to verify you are having the same issue:

 

If you go into the hidden menu ( don't press send, just dial )`*#*#3282#*#*`, select APN Settings, if the internet and pam boxes are blank then you currently have a brick. Unless this is an old post for you a firmware update may solve the issue but as of April 12, 2019 the only solution seems to be a new phone.

 

edit: Just so all information is provided I purchased my phone from Best Buy to use directly on sprint network. Replacement phone came from the same pile of phones they had in stock so I doubt it is batch related.

Seth14
Paper Tape
Posts: 3
Registered: ‎04-16-2019
Location: US
Views: 368
Message 7 of 12

Re: Problems with Moto G7 Power on Sprint 4G/LTE

I have 3 of these phones on Ting and none of them are getting any data. I've been using Motorola phones since the G4 and I really like them but this makethem nearly useless. Is there a timeline for when we can expenct the fix? If this doesnt' happen soon, I'm going to have to return them and buy a dirrerent phone.

brontide
Punch Card
Posts: 28
Registered: ‎04-01-2019
Location: US
Views: 359
Message 8 of 12

Re: Problems with Moto G7 Power on Sprint 4G/LTE

My direct from moto g7 did not get LTE data on Ting until I wiped and reflashed the unit ( not factory reset, reflashing, not recommended ).  If you're not getting LTE your best option is to swap the phones and hope that the new ones work.  I worked with Ting for a week on this and while they were super helpful there was nothing they could do as the phone refuses to take any changes to the APN settings necessary for data operation.

Seth14
Paper Tape
Posts: 3
Registered: ‎04-16-2019
Location: US
Views: 332
Message 9 of 12

Re: Problems with Moto G7 Power on Sprint 4G/LTE

Ting is being really good about it too. I looked at downgrading the firmware but I would rather not mess with it. I think I'm going to try a warranty replacement with them first and not install the firmware upgrade. I think I'll do it with one phone first to make sure it works. They said the factory firmware works.

jbrogers63
Fanfold Paper
Posts: 3
Registered: ‎04-12-2019
Location: US
Views: 290
Message 10 of 12

Re: Problems with Moto G7 Power on Sprint 4G/LTE

Let me know how that goes.  I may do the same thing.

Top Kudoed Authors