Motorola Community

Moto G Phonesmoto g7 play / moto g7 / moto g7 power / moto g7 plus
All Forum Topics
Options

2 Posts

04-12-2019

US

6 Signins

166 Page Views

  • Posts: 2
  • Registered: ‎04-12-2019
  • Location: US
  • Views: 166
  • Message 1 of 14

Problems with Moto G7 Power on Sprint 4G/LTE

2019-04-12, 1:20 AM

I am unable to get sprint to function properly on my Moto G7 Power. Have tried 2 sim cards now that Sprint says is the only whitelisted one compatible, both have the same results. Model of simcard is SIMOLW516TQ. It will work ok for awhile especially with wifi on but as soon as 4G connects it immediately kills all cellular data (seems to crash the simcard) including phone calls/texts. It usually comes back 10-15 seconds later and maintains 3G connection for awhile, then randomly 4G comes back and kills it all. I can text and it seems to make and maintain phone calls fine (as long as it hasnt crashed during the call/send process). Any solutions greatly appreciated, thanks.

Solved! See the solution
Reply
Options

1875 Posts

02-11-2016

US

2804 Signins

49246 Page Views

  • Posts: 1875
  • Registered: ‎02-11-2016
  • Location: US
  • Views: 49246
  • Message 2 of 14

Re: Problems with Moto G7 Power on Sprint 4G/LTE

2019-04-12, 15:37 PM

 wrote:

I am unable to get sprint to function properly on my Moto G7 Power. Have tried 2 sim cards now that Sprint says is the only whitelisted one compatible, both have the same results. Model of simcard is SIMOLW516TQ. It will work ok for awhile especially with wifi on but as soon as 4G connects it immediately kills all cellular data (seems to crash the simcard) including phone calls/texts. It usually comes back 10-15 seconds later and maintains 3G connection for awhile, then randomly 4G comes back and kills it all. I can text and it seems to make and maintain phone calls fine (as long as it hasnt crashed during the call/send process). Any solutions greatly appreciated, thanks.


Please make sure your forum profile is updated with the IMEI or SN from your phone. Also, please PM me pictures of the SIM Kit you're using.

 

-Tom

 

Need help updating your profile? See here. https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Reply
Options

4 Posts

04-12-2019

US

18 Signins

244 Page Views

  • Posts: 4
  • Registered: ‎04-12-2019
  • Location: US
  • Views: 244
  • Message 3 of 14

Re: Problems with Moto G7 Power on Sprint 4G/LTE

2019-04-12, 19:02 PM

Hi guys!  I'm having a similar issue with a Moto G7 (not Power, not Play, etc) on Ting (Sprint MVNO).  I just activated the phone yesterday and I updated to the lastest firmware.  I've been unable to access mobile data.

 

I contacted Ting and they have apparently had several users that have the same issue.  I was told that "everything up to putting the phone through a factory reset" hasn't worked.  There's a reddit thread for a G7 Power that seems to indicate that a firmware downgrade works.

 

Lastly, I'm unable to access the carrier update option (it's not present in the networks option of settings).  Don't know if that matters or not.

 

Is there any word on a fix from Motorola?

Reply
Options

94 Posts

04-02-2019

US

316 Signins

2338 Page Views

  • Posts: 94
  • Registered: ‎04-02-2019
  • Location: US
  • Views: 2338
  • Message 4 of 14

Re: Problems with Moto G7 Power on Sprint 4G/LTE

2019-04-12, 21:00 PM

That was me.  Factory reset did nothing for me.  You have a few options.

 

1. Use 1x mode until Moto comes up with a fix.  1990's data speeds.

2. Swap the phone and hope for a better result

3. Downgrade the firmware ( not recommended ).

 

Did you get the phone from Ting or direct?  

0 person found this solution to be helpful.

This helped me too

Reply
Options

4 Posts

04-12-2019

US

18 Signins

244 Page Views

  • Posts: 4
  • Registered: ‎04-12-2019
  • Location: US
  • Views: 244
  • Message 5 of 14

Re: Problems with Moto G7 Power on Sprint 4G/LTE

2019-04-12, 21:05 PM

I got the phone from Ting.  For now, I managed to get 3G working.  Not great, but at least it's mobile data.  I work from home a lot, so thankfully I don't have to depend on mobile data.  It just seems a little silly that a manufacturer would release a device with this kind of flaw.

 

I did start an attempt at a factory reset.  However, pulling firmware from random places on the web seems a little sketchy.  I'm not finding official firmware anywhere, so I'm going to hang out for a bit and see if Motorola comes up with a fix.

 

If someone finds a work around, let me know.  I'd be happy to be a guinea pig for a potential fix.

Reply
Options

2 Posts

04-12-2019

US

6 Signins

166 Page Views

  • Posts: 2
  • Registered: ‎04-12-2019
  • Location: US
  • Views: 166
  • Message 6 of 14

Re: Problems with Moto G7 Power on Sprint 4G/LTE

2019-04-12, 21:15 PM

Problem solved by replacing phone. Not waiting for firmware to be updated to fix problem. Brontide seems to be correct. Heres how to verify you are having the same issue:

 

If you go into the hidden menu ( don't press send, just dial )`*#*#3282#*#*`, select APN Settings, if the internet and pam boxes are blank then you currently have a brick. Unless this is an old post for you a firmware update may solve the issue but as of April 12, 2019 the only solution seems to be a new phone.

 

edit: Just so all information is provided I purchased my phone from Best Buy to use directly on sprint network. Replacement phone came from the same pile of phones they had in stock so I doubt it is batch related.

Reply
Options

3 Posts

04-16-2019

US

6 Signins

35 Page Views

  • Posts: 3
  • Registered: ‎04-16-2019
  • Location: US
  • Views: 35
  • Message 7 of 14

Re: Problems with Moto G7 Power on Sprint 4G/LTE

2019-04-16, 11:25 AM

I have 3 of these phones on Ting and none of them are getting any data. I've been using Motorola phones since the G4 and I really like them but this makethem nearly useless. Is there a timeline for when we can expenct the fix? If this doesnt' happen soon, I'm going to have to return them and buy a dirrerent phone.

Reply
Options

94 Posts

04-02-2019

US

316 Signins

2338 Page Views

  • Posts: 94
  • Registered: ‎04-02-2019
  • Location: US
  • Views: 2338
  • Message 8 of 14

Re: Problems with Moto G7 Power on Sprint 4G/LTE

2019-04-16, 12:51 PM

My direct from moto g7 did not get LTE data on Ting until I wiped and reflashed the unit ( not factory reset, reflashing, not recommended ).  If you're not getting LTE your best option is to swap the phones and hope that the new ones work.  I worked with Ting for a week on this and while they were super helpful there was nothing they could do as the phone refuses to take any changes to the APN settings necessary for data operation.

Reply
Options

3 Posts

04-16-2019

US

6 Signins

35 Page Views

  • Posts: 3
  • Registered: ‎04-16-2019
  • Location: US
  • Views: 35
  • Message 9 of 14

Re: Problems with Moto G7 Power on Sprint 4G/LTE

2019-04-16, 22:49 PM

Ting is being really good about it too. I looked at downgrading the firmware but I would rather not mess with it. I think I'm going to try a warranty replacement with them first and not install the firmware upgrade. I think I'll do it with one phone first to make sure it works. They said the factory firmware works.

Reply
Options

4 Posts

04-12-2019

US

18 Signins

244 Page Views

  • Posts: 4
  • Registered: ‎04-12-2019
  • Location: US
  • Views: 244
  • Message 10 of 14

Re: Problems with Moto G7 Power on Sprint 4G/LTE

2019-04-17, 12:37 PM

Let me know how that goes.  I may do the same thing.

Reply
Options

3 Posts

04-16-2019

US

6 Signins

35 Page Views

  • Posts: 3
  • Registered: ‎04-16-2019
  • Location: US
  • Views: 35
  • Message 11 of 14

Re: Problems with Moto G7 Power on Sprint 4G/LTE

2019-04-17, 19:58 PM

I called Ting last night and they are sending me new replacement G7's. The whole process will take a couple weeks to get them and my current G7's returned, but so far it's been pretty painless. Check out this thread on the Ting Forum:

 

https://help.ting.com/hc/en-us/community/posts/360029177814-Moto-G7-No-Data-CDMA

 

They say data will work if you don't do the firmware update so when I get the new phones I will see if data works and if it does I wont do any updates until I hear from Ting that it's OK to do. 

 

I'll post here when I get the new phones activated and let you know my results.

Reply
Options

22 Posts

05-05-2010

US

44 Signins

278 Page Views

  • Posts: 22
  • Registered: ‎05-05-2010
  • Location: US
  • Views: 278
  • Message 12 of 14

Re: Problems with Moto G7 Power on Sprint 4G/LTE

2019-04-17, 20:25 PM

Wow ok. I have a G7 Power. No LTE at all and it is stuck in HSPA+ in ATT Prepaid. I guess Moto released a bad rom that soft bricked the LTE radio. Hope they will fix it in the next update. 

Reply
Options

4 Posts

04-12-2019

US

18 Signins

244 Page Views

  • Posts: 4
  • Registered: ‎04-12-2019
  • Location: US
  • Views: 244
  • Message 13 of 14

Re: Problems with Moto G7 Power on Sprint 4G/LTE

2019-04-30, 19:14 PM

Motorola just released a firmware update for the G7.  I have 4G LTE now.  Maybe they released one for the G7 Power as well?

Reply
Options

5 Posts

05-10-2019

GB

6 Signins

43 Page Views

  • Posts: 5
  • Registered: ‎05-10-2019
  • Location: GB
  • Views: 43
  • Message 14 of 14

Re: Problems with Moto G7 Power on Sprint 4G/LTE

2019-05-10, 11:33 AM

I bought my Moto G7 Power and have a pay monthly SIM from Virgin. They responded to this issue by first asking me to text ALL to 789922. This however did not work so then they asked me to alter settings manually and I now have 4G up and running. Here's how:

Please do this manually:

1 Settings
2  Network and internet
3  Mobile Network
4  Access point Names
5  APN profile ....


Name: Internet
APN: goto.virginmobile.uk
Username: None
Password: None
MCC: 234
MNC: 38
APN type: Default


then SAVE.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save