Motorola Community

Moto G Phonesmoto g9 play/moto g9
All Forum Topics
Options

6 Posts

12-13-2017

GB

6 Signins

39 Page Views

  • Posts: 6
  • Registered: ‎12-13-2017
  • Location: GB
  • Views: 39
  • Message 1 of 4

Moto G9 Play charging seems slow / doesn't charge

2020-10-07, 11:47 AM

Just got my phone and it was on 65% battery. Had it plugged into my PC USB point while setting it up, and was surprised that after set up (about 30 minutes I guess) it was on 45% - I guess a lot of downloading etc.

 

But then left it, and even without using it, but plugged in to PC, it was dropping.

 

I plugged in with the plug provided, and it said Turbo Charging (I think that's what you call it) but only on 71% now. Seems to be taking ages. It doesn't seem to charge with the screen on, and all apps closed.

 

Is this normal? Is it impossible to charge in a PC USB now (Moto G7 Play would charge from PC). 

 

Will it charge in a car? If not, that could be a show stopper as I use it for navigation and will need to be able to drive for hours without the worrying about the battery ...

 

Update: just noticed in Settings that it says " 12hr, 41min until fully charged" Now on 72%. 

 

That cannot be correct?

 

Update 2: Spoke with support - they suggested doing a reboot to recalibrate the battery. Rebooting the phone resulted in battery dropping from 73% to 72%. Phone left plugged in, not using it, now on 70%

 

I can only assume that this Moto G7 Play battery is faulty - it shouldn't be losing charge this quick under normal circumstances, let alone when plugged in to a Turbo Charger!

Solved! See the solution
Reply
Options

737 Posts

08-15-2020

GB

281 Signins

7165 Page Views

  • Posts: 737
  • Registered: ‎08-15-2020
  • Location: GB
  • Views: 7165
  • Message 2 of 4

Re:Moto G9 Play charging seems slow / doesn't charge

2020-10-07, 14:20 PM

Electrical devices with li-ion batteries should never ship fully charged, breaks international shipping regs.
What you should have done straight away is charge it up to 100% with a charger, not trickle charge through a PC USB port.

Needs a few charge & discharge cycles (with a proper charger) before assessing battery condition. If after a few full charges (and sensible discharges, >15%), you think it may need calibrating then try calibrating but follow the instructions properly.

 

Plenty of good quality in-car chargers but pick a reputable brand.

Look after your battery, it will look after you.

■ I am not a Motorola/Lenovo Employee. I am a volunteer who happens to be a Moderator. All comments are my own and are not necessarily Motorola/Lenovo's position. ■ Please search the forum before posting. I do not respond to unsolicited PMs ■ Site Rules: https://tinyurl.com/yxlqjnal ■ Site Advice: https://tinyurl.com/yxchoq72 ■ If you post a question and no-one answers it does not mean no-one is thinking about it ■
Reply
Options

6 Posts

12-13-2017

GB

6 Signins

39 Page Views

  • Posts: 6
  • Registered: ‎12-13-2017
  • Location: GB
  • Views: 39
  • Message 3 of 4

Re:Moto G9 Play charging seems slow / doesn't charge

2020-10-07, 15:07 PM

Update! After rebooting and unplugging, plugging in, it started charging properly. Got up to 100%

Have unplugged it, will use until it gets down to below 15% before charging again.

 

0 person found this solution to be helpful.

This helped me too

Reply
Options

19342 Posts

02-03-2016

US

2384 Signins

59203 Page Views

  • Posts: 19342
  • Registered: ‎02-03-2016
  • Location: US
  • Views: 59203
  • Message 4 of 4

Re:Moto G9 Play charging seems slow / doesn't charge

2020-10-07, 18:33 PM

@ Jonbey wrote:
 

 

Just got my phone and it was on 65% battery. Had it plugged into my PC USB point while setting it up, and was surprised that after set up (about 30 minutes I guess) it was on 45% - I guess a lot of downloading etc.

 

But then left it, and even without using it, but plugged in to PC, it was dropping.

 

I plugged in with the plug provided, and it said Turbo Charging (I think that's what you call it) but only on 71% now. Seems to be taking ages. It doesn't seem to charge with the screen on, and all apps closed.

 

Is this normal? Is it impossible to charge in a PC USB now (Moto G7 Play would charge from PC). 

 

Will it charge in a car? If not, that could be a show stopper as I use it for navigation and will need to be able to drive for hours without the worrying about the battery ...

 

Update: just noticed in Settings that it says " 12hr, 41min until fully charged" Now on 72%. 

 

That cannot be correct?

 

Update 2: Spoke with support - they suggested doing a reboot to recalibrate the battery. Rebooting the phone resulted in battery dropping from 73% to 72%. Phone left plugged in, not using it, now on 70%

 

I can only assume that this Moto G7 Play battery is faulty - it shouldn't be losing charge this quick under normal circumstances, let alone when plugged in to a Turbo Charger!

 

Hi.

 

Thanks for reporting, and sorry if this is troublesome.

 

Let's try a full battery calibration and see if it helps. Apologies if this is what you already did -- I can't tell.

  • Do a hard reset of your phone by holding down the physical power button until the phone turns off. It will reboot on its own.
  • Plug the phone in and leave it on the charger for several hours -- long enough to fully charge and an additional couple hours. Overnight is good for this.

 

Let me know if this helps. Thanks.

 

-Matt

Please do not PM me - if you have issues, search the forums for threads on your topic and post there, or start a new thread. Thanks!
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete