Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto G Phonesmoto g9 plus
All Forum Topics
Options

4 Posts

01-19-2021

Australia

4 Signins

20 Page Views

  • Posts: 4
  • Registered: ‎01-19-2021
  • Location: Australia
  • Views: 20
  • Message 1 of 8

Texts Stuck on Sending...

2021-01-19, 1:38 AM

I recently got a new g9 Plus. Sometimes when I try to send texts on Messages it gets stuck on 'sending'. Restarting the phone solves this problem but I don't want to do that every time I want to send a text. I never had this issue with my previous phones.

 

Any help would be appreciated. Thxs.

Reply
Options

13049 Posts

03-05-2018

United States of America

1252 Signins

170480 Page Views

  • Posts: 13049
  • Registered: ‎03-05-2018
  • Location: United States of America
  • Views: 170480
  • Message 2 of 8

Re:Texts Stuck on Sending...

2021-01-19, 18:00 PM

Hi YEP12

 

Can you please confirm if your network signal strength is good? Also, make sure all apps are up to date in Play Store. 

 

Best regards,
Rich
Motorola-Lenovo Support



Did someone help you today? Click the thumbs up button to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

4 Posts

01-19-2021

Australia

4 Signins

20 Page Views

  • Posts: 4
  • Registered: ‎01-19-2021
  • Location: Australia
  • Views: 20
  • Message 3 of 8

Re:Texts Stuck on Sending...

2021-01-20, 0:00 AM

Thanks for the reply. All apps are up to date. I made sure of that when it wasn't sending.

The signal isn't at 100% but once I reset the phone, the network signal doesn't change and it sends.

Reply
Options

4808 Posts

02-11-2016

United States of America

3273 Signins

73561 Page Views

  • Posts: 4808
  • Registered: ‎02-11-2016
  • Location: United States of America
  • Views: 73561
  • Message 4 of 8

Re:Texts Stuck on Sending...

2021-01-20, 2:32 AM

@ YEP12 wrote:

Thanks for the reply. All apps are up to date. I made sure of that when it wasn' sending.

The signal isn' at 100% but once I reset the phone, the network signal doesn' change and it sends.

 

Thanks for confirming. How long have you waited before resorting to rebooting the phone to get the message to send? Also, are you using the stock messaging app or a 3rd party one?

 

-Tom



Did someone help you today? Press the thumbs up icon on the bottom right to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

4 Posts

01-19-2021

Australia

4 Signins

20 Page Views

  • Posts: 4
  • Registered: ‎01-19-2021
  • Location: Australia
  • Views: 20
  • Message 5 of 8

Re:Texts Stuck on Sending...

2021-01-22, 5:07 AM

I first noticed the issue when I tried to send a text and noticed the next day that it didn't send. Yesterday I waited about 4 minutes and it sent after moving round the house, if that helped... Normally I'd give it a minute or two before resetting.

Reply
Options

13049 Posts

03-05-2018

United States of America

1252 Signins

170480 Page Views

  • Posts: 13049
  • Registered: ‎03-05-2018
  • Location: United States of America
  • Views: 170480
  • Message 6 of 8

Re:Texts Stuck on Sending...

2021-01-22, 20:45 PM

Hi YEP12

 

Thank you for your reply. If you're using the stock Messages app by Google, please try sending a message while the phone is in safe mode. 

 

To Enable Safe Mode
1. Press and hold the Power button until Power off comes up on the screen.
2. Touch and HOLD Power off on the screen until reboot to safe mode appears.

Turn off airplane mode.
Just turn off and on the phone to boot back to normal mode.

 

Also, please update your profile with the current phone, carrier and serial number -- this will help me investigate. Please make sure that the options under Settings > System > Motorola Privacy are on as well, and let me know (just reply here) if it's okay for me to look at your apps to see if they are a source of problems.

See here for the instruction. 

 

Best regards,
Rich
Motorola-Lenovo Support



Did someone help you today? Click the thumbs up button to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

4 Posts

01-19-2021

Australia

4 Signins

20 Page Views

  • Posts: 4
  • Registered: ‎01-19-2021
  • Location: Australia
  • Views: 20
  • Message 7 of 8

Re:Texts Stuck on Sending...

2021-04-06, 5:02 AM
Hi. Since replying last time, I have: - tried a different SMS app - deleted any apps that I installed - done a full factory reset on the phone (so if can't be the apps can it?) - asked for help from where I bought the phone from - got a new sim card from my mobile provider - reset the network settings None of this has fixed this issue....
Reply
Options

2432 Posts

03-04-2016

India

1129 Signins

46760 Page Views

  • Posts: 2432
  • Registered: ‎03-04-2016
  • Location: India
  • Views: 46760
  • Message 8 of 8

Re:Texts Stuck on Sending...

2021-04-08, 3:41 AM

@ YEP12 wrote:

I first noticed the issue when I tried to send a text and noticed the next day that it didn' send. Yesterday I waited about 4 minutes and it sent after moving round the house, if that helped... Normally I' give it a minute or two before resetting.

Hi, 

 

Can you please try to Reset apps preferences to see if that helps Settings > Apps & notifications > See all apps > Menu (3 dots on the top right) > Reset app preferences > Reset apps.  Also, please try this enabling the mobile data always-on feature in the developer settings.

 

1. Enable Developer options a. Settings > About Phone > Tap on Build number 7 times > enter PIN/Password

 

2. Go into Developer options a. Settings > System > Advanced > Developer Options > Toggle on Mobile Data Always Active

 

Please check and let us know.

 

Regards

Sandip



Did someone help you today? Press the thumbs up icon on the bottom right to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms