Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

motorola edgemotorola edge 20
All Forum Topics
Options

19 Posts

09-14-2021

India

20 Signins

110 Page Views

  • Posts: 19
  • Registered: ‎09-14-2021
  • Location: India
  • Views: 110
  • Message 1 of 11

Ready For PC

2021-09-14, 10:48 AM

Hi Tom,

Good to be part if Lenovo Community.

 

I have a new purchase of Motorola Edge 20 and I am facing an issue with the 'Ready for PC' feature. I tried connecting to my laptop(s) one running Windows 11 beta version and another running Windows 10.

 

However, I am getting an error message whenever I am trying to connect over Wifi and USB cable. I have attached the error message. I am not using any VPN connection as well.

 

The good part is I am able to connect to my Smart TV using Miracast. Not sure what is causing the problem with PC connection.

 

Hopefully somebody can help me here.

Reply
Options

6998 Posts

02-11-2016

United States of America

3427 Signins

86946 Page Views

  • Posts: 6998
  • Registered: ‎02-11-2016
  • Location: United States of America
  • Views: 86946
  • Message 2 of 11

Re:Ready For PC

2021-09-14, 19:25 PM

@ adarsh76 wrote:

Hi Tom,

Good to be part if Lenovo Community.

 

I have a new purchase of Motorola Edge 20 and I am facing an issue with the 'Ready for PC' feature. I tried connecting to my laptop(s) one running Windows 11 beta version and another running Windows 10.

 

However, I am getting an error message whenever I am trying to connect over Wifi and USB cable. I have attached the error message. I am not using any VPN connection as well.

 

The good part is I am able to connect to my Smart TV using Miracast. Not sure what is causing the problem with PC connection.

 

Hopefully somebody can help me here.

 

Hello and welcome to the community. I'm glad to see you here. I'll do my best to help with your Ready For PC issue. I actually saw something very similar from a edge 20 lite customer. On the machines you tested, are they corporate-owned devices? If so, can you check with your IT department to see if Windows Remote Desktop is blocked or disabled on your machines? If so, this is likely why Ready For PC is not working. Please let me know,

 

Thanks,

Tom



Did someone help you today? Press the thumbs up icon on the bottom right to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

19 Posts

09-14-2021

India

20 Signins

110 Page Views

  • Posts: 19
  • Registered: ‎09-14-2021
  • Location: India
  • Views: 110
  • Message 3 of 11

Re:Ready For PC

2021-09-15, 5:08 AM

I am using my personal laptop which is not corporate owned or administered from my office IT department. Although I have configured office mails through outlook. My personal laptop is running the Windows 11 beta version.

 

I tried in my office laptop that's running Windows 10 as well which is of course corporate owned. 

 

Ready for PC doesn't work in both my laptops over WIFI or USB cable. I factory reset my Edge 20 but still the problem persists. 

Reply
Options

6998 Posts

02-11-2016

United States of America

3427 Signins

86946 Page Views

  • Posts: 6998
  • Registered: ‎02-11-2016
  • Location: United States of America
  • Views: 86946
  • Message 4 of 11

Re:Ready For PC

2021-09-15, 17:09 PM

@ adarsh76 wrote:

I am using my personal laptop which is not corporate owned or administered from my office IT department. Although I have configured office mails through outlook. My personal laptop is running the Windows 11 beta version.

 

I tried in my office laptop that's running Windows 10 as well which is of course corporate owned. 

 

Ready for PC doesn't work in both my laptops over WIFI or USB cable. I factory reset my Edge 20 but still the problem persists. 

 

Ok, thank you for confirming. Can you generate a bug report when you get the error with the connection? Steps are below

 

1. Go to Settings -> About Phone -> Tap on Build number 7 times on the build number to go into the developer options mode]
2. After the above steps Developer options will be enabled.
3. Go to Settings ->System -> Advanced -> Developer options -> Enable USB debugging > Toggle On
4. Enable Settings -> System -> Advanced -> Developer options -> Enable Bug Report shortcut > Toggle On
5. Once the issue is reproduced, Go to Settings -> System -> Advanced -> Developer options -> Click on take bug report or Press Power button and then choose Bug Report from the Power-down menu.
6. Wait for some time until the bug report is collected. It takes around 3 to 4 minutes to collect the Bug Report.
7. Then upload the BugReport to your personal Google Drive and then share the link to the bug report on the forums in a reply.
8. Provide observations of what you saw happen right before the bug report was taken. Please indicate the time that you observed the behavior in local time.

 

Thanks,

Tom



Did someone help you today? Press the thumbs up icon on the bottom right to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Answer
Options

19 Posts

09-14-2021

India

20 Signins

110 Page Views

  • Posts: 19
  • Registered: ‎09-14-2021
  • Location: India
  • Views: 110
  • Message 5 of 11

Re:Ready For PC

2021-09-16, 5:32 AM

Tom,

 

I found out the issue. This was because my laptop WiFi was set to Public where File Sharing wasn't allowed. I switched the mode to Private and now it's working even though I have Windows 11 Beta version.

I believe this instruction should have been available in the Ready for PC page and even the Motorola customer care support couldn't identify this could be the issue.

 

To compare, the Microsoft 'Your PC' app was connecting with Edge 20 even when the WiFi mode was public. Anyways, the issue is resolved but I thank you very much for providing the possible instructions.

 

Thanks,

Adarsh

0 person found this solution to be helpful.

This helped me too

Reply
Options

6998 Posts

02-11-2016

United States of America

3427 Signins

86946 Page Views

  • Posts: 6998
  • Registered: ‎02-11-2016
  • Location: United States of America
  • Views: 86946
  • Message 6 of 11

Re:Ready For PC

2021-09-16, 18:16 PM

@ adarsh76 wrote:

Tom,

 

I found out the issue. This was because my laptop WiFi was set to Public where File Sharing wasn't allowed. I switched the mode to Private and now it's working even though I have Windows 11 Beta version.

I believe this instruction should have been available in the Ready for PC page and even the Motorola customer care support couldn't identify this could be the issue.

 

To compare, the Microsoft 'Your PC' app was connecting with Edge 20 even when the WiFi mode was public. Anyways, the issue is resolved but I thank you very much for providing the possible instructions.

 

Thanks,

Adarsh

 

Adarsh, This is great to hear that you figure it out. I truly appreciate you sharing the solution. I'll be sure to pass it along.

 

I'm curious, did you ever try the direct USB connection? If so did that also have issues? The reason I ask is the 2 users I have using Edge 20 Fusion had issues with both WiFi and wired USB. I know it would be weird that a WiFi setting would have any impact on a USB connection, but I'm curious if you could try it to see. 

 

Thanks,

Tom



Did someone help you today? Press the thumbs up icon on the bottom right to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

19 Posts

09-14-2021

India

20 Signins

110 Page Views

  • Posts: 19
  • Registered: ‎09-14-2021
  • Location: India
  • Views: 110
  • Message 7 of 11

Re:Ready For PC

2021-09-18, 7:39 AM

Hi Tom, for me the USB cable connection also wasn't working initially.

I had set both Ethernet and WiFi settings to 'Public' mode which blocked the Remote Desktop services. I changed both to 'Private' and then both WiFi and USB cable connections are working. Hope it helps.

 

I am raising another concern in a separate thread on the Google Playstore UI. I am not sure if other users are facing this.

 

Thanks,

Adarsh

Reply
Options

3 Posts

10-18-2021

India

2 Signins

50 Page Views

  • Posts: 3
  • Registered: ‎10-18-2021
  • Location: India
  • Views: 50
  • Message 8 of 11

Ready for Not working

2021-10-18, 11:24 AM

I'm not able to connect to my laptop with ready for feature using my wifi, getting the error that wifi network is blocking the connection. I'm not sure if it is an route issue or issue with ISP. Any help on this is greatly appreciated. Attaching the error message screenshot with this thread.

 

 

 

 

Reply
Options

5260 Posts

10-05-2016

United States of America

651 Signins

54942 Page Views

  • Posts: 5260
  • Registered: ‎10-05-2016
  • Location: United States of America
  • Views: 54942
  • Message 9 of 11

Re:Ready for Not working

2021-10-18, 19:57 PM

Hi @ pramuknura ,

 

 I know how this could be a hindrance to use this with your phone. We'll try our best to help. Let's see if the suggestion will work.

 

  1. Check if your laptop Wifi is set to Public where File Sharing wasn't allowed. 
  2. Try to switch the mode to Private and see if it's working.

 

We merged your post to an existing thread so it would be easier for us to follow up with your thread.

 

Keep us posted.

 

Regards,
Jess
Motorola Support

Please do not send me a personal message regarding your concerns or questions if this can be posted to this community. We prioritize the ones posting on threads.
Reply
Options

3 Posts

10-18-2021

India

2 Signins

50 Page Views

  • Posts: 3
  • Registered: ‎10-18-2021
  • Location: India
  • Views: 50
  • Message 10 of 11

Re:Ready For PC

2021-10-19, 5:45 AM

Hi Jess,

 

Thanks for merging my post with this thread, changing the network mode to private fixed the issue. Appreciate your quick turnaround.

 

 

Arun.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms