Motorola Community

motorola one Phonesmotorola one / motorola one power
All Forum Topics
Options

23 Posts

01-17-2019

IN

20 Signins

262 Page Views

  • Posts: 23
  • Registered: ‎01-17-2019
  • Location: IN
  • Views: 262
  • Message 1 of 24

Performance and Ram Management issue with Moto One Power

2019-01-17, 9:06 AM

I updated to Pie as soon as I got my phone, but I have been experiencing issue with performance of my phone (Moto one power). It cant even handle two apps in memory! A simple browser(chrome) and photos app.

It is showing really less free memory available.

Which makes using it too frustrating.

I have included screenshots of current state of the phone.

I have tried clearing up cache and data from the Moto app launcher, as it is the one who is taking up more than 1.1 GB of RAM even though I use Nova Launcher instead of that.

Also is Android OS supposed to take 1.1 GB of memory?! 

But no help at all.

But this all goes away if I reboot my phone, but after a while the problem appears again.

I also booted up in safe mode, but I can't keep using my phone in safe mode, plus as I already mentioned after a reboot problem disappears for couple of hours then back to that slow, lagging, performance

IMEI information in my profile.

I hope you will look into it.

Thank you.

 

Reply
Options

8 Posts

12-14-2018

IN

7 Signins

112 Page Views

  • Posts: 8
  • Registered: ‎12-14-2018
  • Location: IN
  • Views: 112
  • Message 2 of 24

Why Moto App Launcher taking 1 GB of RAM?

2019-01-02, 22:29 PM

Moto App Launcher taking 1GB of RAM in background.

It's making my Motorola One Power slow very slow like snail. Laggs very much. Please do solve this issue. It wasn't in Android 8 but issue arrived after Android 9.

Screen Shot Attached.

Reply
Options

60 Posts

10-17-2018

IN

315 Signins

1914 Page Views

  • Posts: 60
  • Registered: ‎10-17-2018
  • Location: IN
  • Views: 1914
  • Message 3 of 24

Re: Why Moto App Launcher taking 1 GB of RAM?

2019-01-03, 4:01 AM

Hey it's unusual try clearing cache and storgae of moto app launcher and reboot and then tell, here my moto app launcher working as it should be

 

 

 

Reply
Options

23 Posts

01-17-2019

IN

20 Signins

262 Page Views

  • Posts: 23
  • Registered: ‎01-17-2019
  • Location: IN
  • Views: 262
  • Message 4 of 24

Re: Why Moto App Launcher taking 1 GB of RAM?

2019-01-17, 9:16 AM

That solved my problem for only couple of hours then it went back to same state again! 

Anything else you can help me with?

And my Android OS is also taking up more than 1.1 GB of ram!

I thought of wiping cache partition, but I couldn't find it in the recovery mode.

 

Reply
Options

4 Posts

12-06-2018

IN

22 Signins

186 Page Views

  • Posts: 4
  • Registered: ‎12-06-2018
  • Location: IN
  • Views: 186
  • Message 5 of 24

Ram management issues on Moto one power

2019-01-17, 14:31 PM

The phone has become sloppy and laggy after the pie update. The google apps consume a lot of ram. And because this the performance of my device has slowed down.

Reply
Options

60 Posts

10-27-2018

IN

288 Signins

3126 Page Views

  • Posts: 60
  • Registered: ‎10-27-2018
  • Location: IN
  • Views: 3126
  • Message 6 of 24

Re: Ram management issues on Moto one power

2019-01-17, 15:24 PM

 wrote:

The phone has become sloppy and laggy after the pie update. The google apps consume a lot of ram. And because this the performance of my device has slowed down.


Same here phone performance has been droped since updated to pie also had some app crash issues even stock apps like google chrome and photos apps.

Reply
Options

23 Posts

01-17-2019

IN

20 Signins

262 Page Views

  • Posts: 23
  • Registered: ‎01-17-2019
  • Location: IN
  • Views: 262
  • Message 7 of 24

Re: Ram management issues on Moto one power

2019-01-17, 15:52 PM
Reply
Options

23 Posts

01-17-2019

IN

20 Signins

262 Page Views

  • Posts: 23
  • Registered: ‎01-17-2019
  • Location: IN
  • Views: 262
  • Message 8 of 24

Re: Ram management issues on Moto one power

2019-01-17, 15:55 PM
I don't know if Android OS is supposed to take more than 1 GB of Ram, but Google apps do tend to take bit ram as they are well trying to make things snappier, I think you have no problem at all.

If you are experiencing lagging and freezing, please see if you messed up anything in developer option or it might be because of some 3rd party app is doing it.

I might need list of apps that you have recently installed.
Reply
Options

23 Posts

01-17-2019

IN

20 Signins

262 Page Views

  • Posts: 23
  • Registered: ‎01-17-2019
  • Location: IN
  • Views: 262
  • Message 9 of 24

Re: Why Moto App Launcher taking 1 GB of RAM?

2019-01-17, 16:07 PM
For time period you can do this-
Go into apps, find Moto App Launcher, then click on storage option in it. And clear up cache and storage
It will solve the problem for couple of hours, then you have to do this again until Motorola gives us permanent solution.
Tell me if it worked or not.
Thank you
Reply
Options

19088 Posts

02-03-2016

US

2337 Signins

57462 Page Views

  • Posts: 19088
  • Registered: ‎02-03-2016
  • Location: US
  • Views: 57462
  • Message 10 of 24

Re: Ram management issues on Moto one power

2019-01-17, 16:34 PM

I've merged three threads here, as they seem quite similar. There are two main items here that I can see.

  • Phone appears to be laggy and slow -- everyone on this thread.
  • The Motorola Launcher appears to be taking up a large amount of memory -- some of the people on this thread.

I think there is something unusual going on with those of you who are seeing the Motorola Launcher using a GB or more of memory. The Android OS using a GB or more appears to be perfectly normal; I checked several phones, different models, and they all seemed to use around a GB or more. 

 

General complaints of "lag, slow, etc." are very difficult to address. It's very subjective and hard to measure. If you can tie the lag back to use of any particular app or feature, that can help. For example, it happens after I do X or Y. We can then look at X or Y and see if we can improve.

 

You can also test in Safe Mode to see if this is an app issue. Safe Mode disables all 3rd-party apps so if the phone runs great in Safe Mode, it means an app is causing the lag. To go into Safe Mode, press the physical power key, then press and hold the pop-up "Power off" key until the Safe Mode instructions pop up.

 

There are two things I'd like each of you to do if you have not already:

  1. Check the memory usage of the Motorola Launcher and let me know if it's around a GB vs a few hundred MB. To do this:
    - Go to Settings -> About Phone -> Tap on Build number 7 times on the build number to go into the developer options mode
    - After the above steps Developer options will be enabled and will show in Settings > System > Advanced  Go to Settings >
    - Go to Developer options > Memory (should be the second item) > Memory use by apps > find Moto App Launcher and report the memory used
  2. Please update your profile with current phone, carrier and serial number -- this will help me investigate. Please make sure that the options under Settings > Motorola Privacy are on as well, and let me know (just reply here) if it's okay for me to look at your apps to see if they are a source of problems. Need help updating your profile? See here. https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943

Thanks,

 

- Matt

Please do not PM me - if you have issues, search the forums for threads on your topic and post there, or start a new thread. Thanks!
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete