Motorola Community

motorola one Phonesmotorola one vision
All Forum Topics
Options

37 Posts

05-30-2019

PL

90 Signins

688 Page Views

  • Posts: 37
  • Registered: ‎05-30-2019
  • Location: PL
  • Views: 688
  • Message 1 of 15

magnetometer stops working after some time

2019-05-30, 12:55 PM

Magnetometer stops working after some time, reboot is needed for it to work, i can't use compas without it, it stands still, attached a screenshot from Sensors Multitool app

Reply
Options

17932 Posts

02-03-2016

US

2249 Signins

54007 Page Views

  • Posts: 17932
  • Registered: ‎02-03-2016
  • Location: US
  • Views: 54007
  • Message 2 of 15

Re: magnetometer stops working after some time

2019-05-31, 14:27 PM

 wrote:

Magnetometer stops working after some time, reboot is needed for it to work, i can't use compas without it, it stands still, attached a screenshot from Sensors Multitool app


Hi.

 

The best way to test this is with Google Maps. Open Maps and look at your current location dot. If it has the little "fan" coming off of it, the magnetometer is working - the fan shows the direction you are facing.

 

I guess if it is not working consistently I would first test it in Safe Mode, to make sure the issue isn't app interference. To go into Safe Mode, press the physical power key, then press and hold the pop-up "Power off" key until the Safe Mode instructions pop up.

 

Unfortunately, if it is truly cutting out at times, then repair would be your next option. (Or return for another unit since it is so new.)

 

Let me know. Sorry you're having issues with this.

 

- Matt

 

 

Please do not PM me - if you have issues, search the forums for threads on your topic and post there, or start a new thread. Thanks!
Reply
Options

17932 Posts

02-03-2016

US

2249 Signins

54007 Page Views

  • Posts: 17932
  • Registered: ‎02-03-2016
  • Location: US
  • Views: 54007
  • Message 3 of 15

Re: magnetometer stops working after some time

2019-05-31, 16:00 PM

 wrote:

 wrote:

Magnetometer stops working after some time, reboot is needed for it to work, i can't use compas without it, it stands still, attached a screenshot from Sensors Multitool app


Hi.

 

The best way to test this is with Google Maps. Open Maps and look at your current location dot. If it has the little "fan" coming off of it, the magnetometer is working - the fan shows the direction you are facing.

 

I guess if it is not working consistently I would first test it in Safe Mode, to make sure the issue isn't app interference. To go into Safe Mode, press the physical power key, then press and hold the pop-up "Power off" key until the Safe Mode instructions pop up.

 

Unfortunately, if it is truly cutting out at times, then repair would be your next option. (Or return for another unit since it is so new.)

 

Let me know. Sorry you're having issues with this.

 

- Matt

 

 


Hi again.

 

If none of the above suggestions has an impact, would you mind generating a bug report for us? The steps are not as complicated as they look. 

 

After you see this problem...

 

1. Go to Settings -> About Phone -> Tap on Build number 7 times on the build number to go into the developer options mode]
2. After the above steps Developer options will be enabled and will show in your Settings menu.
3. Go to Settings > Developer options > Enable USB debugging > Toggle On
4. Enable Settings > Developer options > Enable Bug Report shortcut > Toggle On
5. Once the issue is reproduced, Go to Settings > Developer options > Click on take bug report or Press Power button and then choose Bug Report from the Power down menu.
6. Wait for some time until the bug report is collected. It takes around 3 to 4 minutes to collect the Bug Report.
7. Then upload the BugReport to your personal Google Drive and share the link to the BugReport via an email to supportforums@motorola.com, and include a note referring to this post so we know what it refers to.
8. Provide observations of what you saw happen right before the bug report was taken. Please indicate the time that you observed the behavior in local time.

 

Many thanks.

 

- Matt

Please do not PM me - if you have issues, search the forums for threads on your topic and post there, or start a new thread. Thanks!
Reply
Options

37 Posts

05-30-2019

PL

90 Signins

688 Page Views

  • Posts: 37
  • Registered: ‎05-30-2019
  • Location: PL
  • Views: 688
  • Message 4 of 15

Re: magnetometer stops working after some time

2019-06-01, 9:52 AM

thanks for the response, the suggestion safe mode about safe mode is a nice tip, didn't knew about it, will be usable in the future

as for the problem it happened only two times randomly, both times there was no blue "fan" in google maps, i have yet to pinpoint this problem, will then proceed with generating bug report

Reply
Options

1 Posts

06-03-2019

PL

3 Signins

60 Page Views

  • Posts: 1
  • Registered: ‎06-03-2019
  • Location: PL
  • Views: 60
  • Message 5 of 15

Re: magnetometer stops working after some time

2019-06-03, 11:20 AM

I have exactly the same problem with my Motorola One Visuon. 

Reply
Options

17932 Posts

02-03-2016

US

2249 Signins

54007 Page Views

  • Posts: 17932
  • Registered: ‎02-03-2016
  • Location: US
  • Views: 54007
  • Message 6 of 15

Re: magnetometer stops working after some time

2019-06-03, 16:50 PM

 wrote:

I have exactly the same problem with my Motorola One Visuon. 


Hi. Thanks for reporting.

 

If you observe this and can generate a bug report -- as described above -- that could be very helpful.

 

Also, if both of you could make sure your profile is updated with current phone, carrier and serial number, this will help me investigate. Please make sure that the options under Settings > Motorola Privacy are on as well, and let me know (just reply here) if it's okay for me to look at your apps to see if they are a source of problems.

Need help updating your profile? See here. https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943

 

Thanks,

 

- Matt

Please do not PM me - if you have issues, search the forums for threads on your topic and post there, or start a new thread. Thanks!
Reply
Options

33 Posts

04-17-2015

BR

248 Signins

2299 Page Views

  • Posts: 33
  • Registered: ‎04-17-2015
  • Location: BR
  • Views: 2299
  • Message 7 of 15

Re: magnetometer stops working after some time

2019-06-11, 21:50 PM

Same problem here. But it hasn't happened since the June patch, which I got yesterday.

Reply
Options

13 Posts

10-22-2017

NL

28 Signins

285 Page Views

  • Posts: 13
  • Registered: ‎10-22-2017
  • Location: NL
  • Views: 285
  • Message 8 of 15

Re: magnetometer stops working after some time

2019-06-21, 14:02 PM

I stil didn't receive the june update? When will it arrive on my phone? Can I force the update?

Reply
Options

33 Posts

04-17-2015

BR

248 Signins

2299 Page Views

  • Posts: 33
  • Registered: ‎04-17-2015
  • Location: BR
  • Views: 2299
  • Message 9 of 15

Re: magnetometer stops working after some time

2019-06-21, 22:28 PM
Maybe it's being rolled out in phases, or it was pulled out because of some bug. I got it in Brazil. Perhaps a forum admin could help?
Reply
Options

17932 Posts

02-03-2016

US

2249 Signins

54007 Page Views

  • Posts: 17932
  • Registered: ‎02-03-2016
  • Location: US
  • Views: 54007
  • Message 10 of 15

Re: magnetometer stops working after some time

2019-06-24, 15:07 PM

 wrote:

I stil didn't receive the june update? When will it arrive on my phone? Can I force the update?


We can look into this. What is your current software version?

 

Please update your profile with current phone, carrier and serial number -- this will help me investigate. Please make sure that the options under Settings > Motorola Privacy are on as well, and let me know (just reply here) if it's okay for me to look at your apps to see if they are a source of problems.

Need help updating your profile? See here. https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943

 

Thanks,

 

- Matt

Please do not PM me - if you have issues, search the forums for threads on your topic and post there, or start a new thread. Thanks!
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save