English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

18 Posts

05-17-2016

BG

33 Signins

247 Page Views

  • Posts: 18
  • Registered: ‎05-17-2016
  • Location: BG
  • Views: 247
  • Message 1 of 5

T520: always white screen

2016-05-17, 17:53 PM

Hello.

 

Today my ThinkPad T520 stopped showing anything, it always shows the white screen. How it started: in my Linux Mint, I verified that when I close the laptop cover, it enters Suspend mode, and when I open it back, it wakes up. I don't quite like it, since I may want to close it just to move from one room to another, and I would like it to keep running; so I adjusted system settings accordingly (there is a dropdown menu, like, what to do when the laptop cover is closed; I set to "do nothing"), and then I closed the cover.

 

I verified that it keeps running, so I opened it, and I see the white screen. I was thinking it is some issue with Linux, so, I just rebooted it, but just when it starts booting, it shows the white screen again. I can wait for some time, it boots into the OS (I'm judging by the HDD led). Alternatively, when it starts booting, I can press F1, it beeps and enters setup (I'm judging by the HDD led being idle).

 

So, the overall system works, but the display keeps being plain white. It looks like the hardware issue. :(

 

Could anyone please give me some clue? How could that happen, and how can I try to fix it?

 

Thanks in advance.

Solved! See the solution
Reply
Options

10534 Posts

01-02-2010

US

39303 Signins

406737 Page Views

  • Posts: 10534
  • Registered: ‎01-02-2010
  • Location: US
  • Views: 406737
  • Message 2 of 5

Re: T520: always white screen

2016-05-17, 18:20 PM

A white screen is usually 1 of 3 things:

Unplugged or partly unplugged LCD cable behind the screen

Broken cable

Bad panel


Rich


I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
Reply
Options

10534 Posts

01-02-2010

US

39303 Signins

406737 Page Views

  • Posts: 10534
  • Registered: ‎01-02-2010
  • Location: US
  • Views: 406737
  • Message 3 of 5

Re: T520: always white screen

2016-05-17, 18:20 PM

A white screen is usually 1 of 3 things:

Unplugged or partly unplugged LCD cable behind the screen

Broken cable

Bad panel


Rich


I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
Reply
Options

18 Posts

05-17-2016

BG

33 Signins

247 Page Views

  • Posts: 18
  • Registered: ‎05-17-2016
  • Location: BG
  • Views: 247
  • Message 4 of 5

Re: T520: always white screen

2016-05-17, 18:23 PM

Thanks, so, what are the right steps to replug the LCD cable?

Reply
Options

10534 Posts

01-02-2010

US

39303 Signins

406737 Page Views

  • Posts: 10534
  • Registered: ‎01-02-2010
  • Location: US
  • Views: 406737
  • Message 5 of 5

Re: T520: always white screen

2016-05-17, 19:20 PM

Here is the manual to look at:

 

https://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles_pdf/t520_t520i_w520_hmm_en_0A60078_08.pdf

 

It can be difficult to know how to proceed if you have no good parts to try.  It is usually a bad idea to start buying things.  If you know that the lid has never been taken apart, the cable is unlikely to be unplugged because it is held in place by tape, but the tape is less strong if it has been reused. If I had the machine here and knew nothing about the history, here are the steps I would follow:

 

Remove keyboard and palmrest

 

 Inspect the part of the cable that can be seen. (there are 2 cables - the one that goes into the lid through the right hinge is the one that does video.

 

Remove the lid assembly. 

 

If I had a good screen assembly, I would try that on this motherboard or I would try the screen with a different motherboard with the same video connector.  I am trying to avoid buying screen parts if the problem was the motherboard.  It isn't likely, but possible - more likely if you have discreet graphics.

 

If it turns out the screen was bad, I would disassemble the lid and try a different cable.  Otherwise, it is the panel.


Rich


I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save