cancel
Showing results for 
Search instead for 
Did you mean: 
pas
Punch Card
Posts: 36
Registered: ‎01-11-2013
Location: Seattle
Views: 10,404

Re: Yoga won't charge battery over 59%

It's the Lenovo Energy Management settings.

Go to Control Panel >> Power Options >> Change plan settings >> Change advanced power settings >> Lenovo Energy Management >> Enable Lenovo Energy Management.

Change the battery setting from "Optimized Battery Health" to "Maximum Battery Life."

 

By only partially charging the battery, the software is prolonging the lifespan of the battery itself.  This is true of all laptop batteries.  If you often leave your computer plugged in, it's best to keep this setting enabled.  If you can anticipate your mobile useage in advance, you can just turn off the feature at appropriate times.

It would be nice if the setting was easier to change.  If somebody knows an easier way, feel free to post it.

I suppose you could always put a shortcut to "C:\Program Files (x86)\Lenovo\Energy Management\Energy Management.exe" on your start screen, taskbar or desktop.  Alternatively, you could put a shortcut on the desktop, assign a hotkey to it, and super-hide the shortcut (a little more advanced).

Who Me Too'd this solution