cancel
Showing results for 
Search instead for 
Did you mean: 
lovecraft
Ctrl-Alt-Del
Posts: 8
Registered: ‎01-05-2014
Location: Paris
Views: 22,093

SSD Crucial m500 + T440s = 2100: Detection error on HDD0 (Main HDD)

Hi,

 

I used an SDD Crucial m500 480 Gb in my Thinkpad x201i for about a month.

It was configured in 'Self-Encrypting Drive' (SED) so my Thinkpad asked me a passphrase at boot.

It worked great, never got a problem with it.

 

Last week, I bought a t440s.

I decided to move my SSD into that t440s.

 

At first, I always got the same error message "2100: Detection error on HDD0 (Main HDD)" and wasn’t able to boot or install the OS.

I removed the SED passphrase (because I wasn’t sure if encryption was involved with the TPM chip or not) but that didn’t help.

 

I flashed the UEFI / bios to the latest version (2.17 at that time) without any more luck.

Then I updated the SSD Crucial m500 firmware to MU02 to MU03.

One of the fixes of that update is "Fix for potential Haswell compatibility issue (latest Intel platform)" which could only help.

And it helped : the drive was then recognized and I installed the Operating System after setting again a SED passphrase.

It worked great for several reboots but, this morning, a "hot reboot" (restart from the Operating System without power off), I’ve got the 2100 message error again...

I powered the system off, remove the power cord for several second then powered on and it worked but It keep me worried....

The problem is not permanent but It could be very bad to not be able to boot my laptop !

I thought I fixed the problem permanently with that firmware update but it seems not...

 

Do someone has any idea ?

Is that SSD a model to avoid installing in t440s ?

If so, are some SSD brand/model which work without any issue ?

Who Me Too'd this topic