cancel
Showing results for 
Search instead for 
Did you mean: 
inputrequired
Paper Tape
Posts: 2
Registered: ‎06-04-2014
Location: United States
Views: 4,165

2014 X1 Carbon: Ethernet dongle stopped working

Couldn't find anything by searching, so hopefully somebody could help:

 

I have a 2014 X1 Carbon (Gen 2) and my ethernet dongle stopped working this morning.

It worked fine for the past 3 weeks but after rebooting this morning i can't get to get access to the network via the ethernet port anymore.

The port's activity lights don't light up and a network connection is never recognized.

 

I have checked the Device Manager and verified that I have the latest drivers (12.11.77.1  for Intel I218-LM), and made sure that the Power Settings do not allow the port to go to sleep.

I have also tried 3 different ethernet dongles, all behaving the same way.

 

I was able to use a USB-to-Ethernet dongle to get access with a ethernet cable, but that's not an ideal solution.

Is my port just dead? I don't see any visible damage, or loose connectors. 

Any thoughts on what to inspect next? 

Who Me Too'd this topic